1 2 3 4 5 Previous Next 850 Replies Latest reply on Oct 1, 2019 12:48 PM by JasonHess Go to original post
      • 30. Re: ESX deployment appliance
        dconvery Virtuoso
        vExpert

        try setting your XP machine IP address 192.168.1.100. If that does not work try setting your NAT or HOSTONLY to 192.168.1.x and then use that network.

        • 31. Re: ESX deployment appliance
          brugh Expert
          vExpert

          moving a VM to workstation can get the network wrong. edit the vmx file and remove the line where it says 'networkname'. else you can try to remove the network card and add it again.

          • 32. Re: ESX deployment appliance
            usera Novice

             

            Thank brugh,

             

             

            So, is that ok? in Vmware Workstation, I setup a Windows XP VM Team with Appliance ("edit the vmx file and remove the line where it says 'networkname'.) and setup the IP Address to 192.168.1.1 /24, Default gateway to 192.168.1.1.  Then IE to url http://192.168.1.68.

             

             

            Thanks

             

             

            really want to try the appliance

             

             

             

             

             

            • 33. Re: ESX deployment appliance
              brugh Expert
              vExpert

               

              you should never point the gateway of any host to itself. rather have no gateway at all than point to it's own ip address. but if you put both xp and the eda in the same network they should see eachother nonetheless.. so yeah, your setup should work if they both have working network adapters.

               

               

              • 34. Re: ESX deployment appliance
                David Meekins Novice

                Hi I've download EDA I want to enlarge the system disk but I nothing about Ubuntu 7.10 can this be done and how, or can I attach a second disk and share this out via SAMBa if so how do I that?

                 

                Thanks

                • 35. Re: ESX deployment appliance
                  brugh Expert
                  vExpert

                   

                  the appliance is set up so it wouldn't need more diskspace than it has. but if you have to, you can add a new disk to it and then log into it as root. then you'll have to create a partition and filesystem on it and mount it somewhere. you'd do something like:

                   

                  • fdisk /dev/sdb

                    • create new partition

                  • mkfs -J -t ext3 /dev/sdb1

                  • vi /etc/fstab

                    • add '/dev/sdb1   /opt    ext3    defaults    0    0'

                  • mount -a

                   

                  and you're done. plenty of space in /opt.

                   

                   

                  • 36. Re: ESX deployment appliance
                    brugh Expert
                    vExpert

                    >!http://communities.vmware.com/people/Pauile3576/avatar/32.png?a=-1![476806] http://communities.vmware.com/images/status/lurker-16x16.gif [476806] 1 posts since

                    >13-jun-2008 > >Does anyone have a guide on how to setup and use this thing? I am completely lost. I moved the appliance onto a LUN and tried to create a custom VM and my VC will not see the VMDK. What the hell am I doing wrong???

                    >

                    >

                    >Thanks,

                     

                     

                    >

                    >Paulie

                     

                     

                     

                     

                     

                    the diskformat in ESX isn't the same as on workstation or server. you have to convert it in ESX before you can assign it to a VM. use 'vmkfstools -i newdisk.vmdk olddisk.vmdk' to do so. 

                     

                     

                    • 37. Re: ESX deployment appliance
                      David Meekins Novice

                       

                      Hi thanks for replying. The reason I wanted a larger disk!!! I'm deploying ESX 3.5 on to HP Proliant DL585's the script includes installing the HP DataProtector 6.0 agent. The agent files are rapped in the DP_DEPOT file which is 600+ megs hence I added a new disk , shared it out via Samba and rapped my own script around the install process , which is then pushed out via EDA....

                       

                       

                      Sorry have a question?

                       

                       

                      When EDA deploys does it disable the SAN drivers , if so how I do I reable the drivers so the ESX server can see the SAN

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      • 38. Re: ESX deployment appliance
                        brugh Expert
                        vExpert

                         

                        i would first try to extract only the files you need from that huge archive. hp agents are typically some 25mb so it's a shame to go through all the trouble of adding disks for all the agentfiles for windows and whatnot when you only need the esx agents.

                         

                         

                        but you can use the method in the earlier post to add a disk of say 1GB under /var/www/dl. it will then automatically be shared and the scriptbutton to get a file to the host will work automatically as well.

                         

                         

                        as for the san drivers. the current version strips the san drivers from the boot image which makes it save for the installer to install to the first harddisk which will always be a local disk. the current version 0.6 has a small problem though where somewhere it will still look at san disks and find a filesystem it doesn't know. i'm currently working on a new version 0.7 that fixes that problem. i'll upload it hopefully coming weekend. i'll post a message here where to find it.

                         

                         

                        • 39. Re: ESX deployment appliance
                          David Meekins Novice

                          Hi thanks for the information

                           

                          I think I have a different problem,  I've used EDA to deploy an esx 3.5 box all worked fine ... But I cannot see the SAN,,, have a look at the attach images  hence looking at the drivers and loaded modules etc

                           

                          I've used vmkload_mod -l

                           

                          Name                R/O Addr          Length      R/W Addr          Length        ID Loaded

                          qla2300_707_vmw     0x8b2000          0x59000     0x28c8300         0xac000       4  Yes

                           

                          looking at other ESX 3.02 boxes I see /proc/scsi/qla2300 which is correct,,,, But on the ESX 3.5 box ONLY /proc/scsi/  ,,,, Don't know what's happening

                           

                          The VC for ESX 3.02 see image "With SAM.bmp"  is fine.... but using the ESX 3.5 see image "NO SAN.bmp" there's no SAN

                           

                           

                          Do you have any advise , useful commands

                           

                          Thanks

                          • 40. Re: ESX deployment appliance
                            David Meekins Novice

                            Hi my SAN storage issue turned out to be a Hba hardware failure. Did you manage to release the next version of EDA

                            • 41. Re: ESX deployment appliance
                              brugh Expert
                              vExpert

                              it's ready but i haven't had a chance to test it with a real esx/san environment. as soon as i have and seen it work i'll upload it.

                              • 42. Re: ESX deployment appliance
                                unreal2 Novice

                                 

                                Hello Brugh,

                                 

                                 

                                I've got a question, also posted on the VMUG.

                                 

                                 

                                I'm trying to use your EDA to build a deployment for a number of ESX systems.

                                 

                                 

                                Running the appliance under Workstation, and seperated this, and the target system from the network by using a switch, I am now ready to go for a unattended trial-run.

                                The target system is a IBM X346 with additional broadcom NICs.

                                 

                                 

                                The target boots fine from the PXE of the appliance, and the configuration names I made in the browser shows up.

                                I choose one, and it starts the installation process, until it wants to copy the ks.cfg file.

                                 

                                The text installations stops at "choose the language you want to use during installation"

                                 

                                 

                                CTRL-F3 shows:

                                 

                                 

                                ks location http:.............hostname=TestESX01

                                transferring ks............... to a fd

                                failed to retrieve ..... ks.php hostname=TestESX01

                                 

                                 

                                CTRL-F4 shows:

                                 

                                 

                                cdrom: open failed.

                                 

                                 

                                And then everything stops.

                                 

                                Do you, or anyone here knows what is going wrong, and what I have to do to get it running ?

                                 

                                 

                                • 43. Re: ESX deployment appliance
                                  brugh Expert
                                  vExpert

                                   

                                  this is usually a VLAN or network segmenting problem. once the PXE part of the boot process is over, stage 2 starts and restarts the network. it's possible that a differnet NIC is considered primary and tries to get an IP address. this NIC can be in a different VLAN as the PXE/web server and will fail to connect.

                                   

                                   

                                  you can try stepping through the wizard as a normal installation, choosing http as your installations source. type the ip address of the EDA as webserver and 'esx' as directory. if that fails you have to try booting from another NIC or put everything in one LAN. if that works however, forget all the previous VLAN stuff because you have another issue. in that case let me know and I'll have another look.

                                   

                                   

                                  • 44. ESX deployment appliance v0.71
                                    brugh Expert
                                    vExpert

                                    OK! i finaly got around testing the new EDA 0.71 version and it works like a charm. no more problems with SAN connected ESX servers. it installs perfectly. i added some new scriptbuttons so people downloading it just for it's scriptbuilder will have more options too.

                                     

                                    i'll post it this weekend and will leave a msg here to it's whereabouts

                                     

                                     

                                     

                                     

                                     

                                    and it's online. v0.71 now available at http://www.virtualappliances.eu/

                                    1 2 3 4 5 Previous Next