4 Replies Latest reply on Apr 11, 2008 10:28 PM by ForeverYoung

    USB memorysticks corrupted

    aaron_sf Novice

       

      I have tried two different USB2 memory sticks and got the same results ... I format them with FAT32 on my 'real' XP machine... copy files onto them... then I plug in to my XP bootcamp partition (while it has focus) - explorer hangs... drive mounts outside on the OS X (10.5) desktop .. filesystem on stick is now corrupted.

       

       

      Any ideas?

       

       

        • 1. Re: USB memorysticks corrupted
          MandarMS Master

          Can you check the USB controllers are properly installed in Boot camp VM also try attaching the USB device manually and check you can use the same in Virtual Machine?

          • 2. Re: USB memorysticks corrupted
            aaron_sf Novice

             

            ive got 'enable usb2' and 'auto connect' On in settings... and other USB2 devices, like external hard drives, seem to work fine - so I think the drivers must be installed properly. It's just memory sticks. I format them in FAT32 on my laptop.... OSX mounts them just fine... so does real XP of course... but when an XP vm has focus, I insert - I hear the usb 'din dong' chime, the device says it is connected, but when i click on it in explorer, it says the disk is corrupt/not formatted .. when I know for sure it was just before I inserted it...

             

             

            so far i've tried two completerly different sticks - one that i was given last time i was up on the microsoft campus (no-name brand .. just says 'Vista' on it) and the other .. purchased yeterday at best buy .. the geeksquad 8GB  ....

             

             

            buy one - try it...

             

             

            • 3. Re: USB memorysticks corrupted
              aaron_sf Novice

              ok these 8GB sticks came preconfigured with U3 launchpad - which may have been the problem with those - uninstalling it gives better results. Still doesn't explain the issies with the first stick. I hope VMware take a look...

              • 4. Re: USB memorysticks corrupted
                ForeverYoung Lurker

                When I try to use my thumb drive or my external USB hard drive when running a virtual XP machine in fusion, the USB device gets corrupted.  I cannot use my external USB hard drive at all.  Just turning it on causes both XP and Leopard to hang since it was corrupted and neither OS can open the USB hard drive files.  I hope my external hard drive can be resuscitated.  Very frustrating.  I am trying to be able to save Office documents on the USB hard drive so that I can access them either from Office 2008 on Mac or Office 2007 on XP virtual machine.  When virtual machine is running, Leopard cannot access my XP hard drive on my Mac Pro, so I have to save my documents on the external USB drive.  I can mount and dismount the USB drive in fusion, but I have had major problems with corrupting the USB drives.