10 Replies Latest reply on Sep 23, 2008 11:16 AM by Jacky Mao

    Unable to access VM consoles...

    fgilain Novice

       

      Hello,

       

       

      i was running VMWARE Server 2.0beta since few months in windows 2003 Server x64. This week end, it seems to have stop working due to timebomb ?

       

       

      i upgraded to VMWARE Server 2.0beta2, but now, i can't access to all my VM's console...very annoying for me  ;-((

       

       

      please see attachment for problem details.

       

       

      Florent

       

       

        • 1. Re: Unable to access VM consoles...
          Hot Shot

           

          You are probably hitting the NetBIOS name limitation mentioned in the release notes, take a look:

           

          • On Windows, the VMware Server desktop and Start menu shortcuts use the NetBIOS name in the connection URL. This may cause VI Web Access to fail to connect to VMware Server.

          • Workaround: Enter the correct host name as the External Name when prompted by the Windows installer. Or, if the URL specified in the shortcut does not work, use the correct host name, IP address, or localhost, as appropriate, in the connection URL.

           

          I see in your attached images that the error message doesn't end up using a fqdn so this is definintely a possibility in your case.  Hope this helps.

          • 2. Use of NETBIOS names is simply dead idea - it wont work...
            SigmaEng Enthusiast

            Use of NETBIOS names in the connection URL  is very bad idea. This method might work for 1 installation of 1000! It should be by default "localhost" or 127.0.0.1.

             

            So far Server 2 Beta 2 seems to be huge improvement from beta 1. Well done.

            • 3. Re: Unable to access VM consoles...
              fgilain Novice

               

              you're right, my server has 2 netword card into associated with its hostname...i suppose it's a problem with that Beta version.

               

               

              using the IP ADDRESS has solved my problem of accessign the VM's consoles. Thanks a lot.

               

               

              Florent

               

               

              • 4. Re: Unable to access VM consoles...
                Dazzle Lurker

                 

                Hi,

                 

                 

                I got nearly the same problem except that I get a "Error opening the remote virtual machine localhost:8333/16 - An unexplained error occured"

                 

                 

                Does anyone have a clue of what's the problem.

                 

                 

                Its a fresh install of W2K3server as host and the latest VMware BETA.

                 

                 

                Regards

                 

                 

                Brian

                 

                 

                • 5. Re: Unable to access VM consoles...
                  Dazzle Lurker

                   

                  Ahhh - network was not attached - not it's working.

                   

                   

                  -Brian

                   

                   

                  • 6. Re: Unable to access VM consoles...
                    coombea Lurker

                    It does raise an issue though - how do you get the remote console working when you are not connected.

                     

                    I have VMWare Beta 2 on my laptop - running a Solaris host - and the remote console works fine when I am connected to my wireless network.  But when I am not I get the "unexplained error" message when starting the Remote console.

                     

                    I have installed the MS Loopback adapter to ensure I have an adapter always 'connected' but it doesn't seem to work and I am not sure why.

                     

                    Any Ideas?

                    • 7. Re: Unable to access VM consoles...
                      Dazzle Lurker

                      Unfortunately I never found a way of connectiong without network connection

                      • 8. Re: Unable to access VM consoles...
                        tomstewart Lurker

                        Did you try adding the MS LoopBack adapter?  This will make sure you have an IP stack even when never plugged into a physical network.

                        • 9. Re: Unable to access VM consoles...
                          bug splat Lurker

                          I'm getting the same error and can not view the console from VMware host but I can MSTSC into the XP pro Virtual Machine from any other machine in our network. What is this MS loopback adapter? Why can every PC in the network see my virtual server but the host running it can't? I have been using VMware server 1.0 for our other servers but the lack of auto-booting VM servers really pushed me to 2.0. I like the look and feel of 2.0 but if I cant even manage my servers from one location that really sucks. BTW the host PC is running server 2003 std stripped and the latest firefox.

                          • 10. Re: Unable to access VM consoles...
                            Jacky Mao Lurker

                             

                            Edit the file "hosts" in you windows system.

                             

                             

                            c:\winnt\system32\drivers\etc\hosts

                             

                             

                            add a new recode in the file:

                             

                             

                            127.0.0.1   s-vmware-01