3 Replies Latest reply on Feb 5, 2008 11:31 AM by rjcchan

    Fedora 8 and OpenSUsE 10.3 problems

    dp_fusion Hot Shot

      Owing to the near simultaneous death of my backup drive and my MacBookPro drive I lost my virtual machines and everything not on my thumb drive. So I had to reinstall Fusion, then reinstalled 1.1.1 - very timely. I was able to use the new importer tool to salvage my old Parallels version of Win XP - worked perfectly. Thought I'd save some time by downloading an OpenSUsE appliance, and I grabbed Fedora while I was there. I also had Fedora as a full install iso, so installed both versions.

       

      I have a 200g drive in my MBP now so why not

       

      Anyway - I can not get vmware tools to install. Well, they install but will not run. In the case of the appliance, they don't install because the appliance builder did not include gcc (note to appliance builders - don't leave this out!). So now I have three Linux systems that don't have network access, very poor video options, and cut/paste is right out, and I've never gotten dynamic screen resolution to work with any flavor of Unix. These same products run fine on my Win laptop with VMPlayer including dynamic screen resolution. The problem is obviously me.

       

      I installed the two appliances, and did a full install from a distro dvd iso. Three virgin Linux vms all clamoring for VMware Tools, so...

       

      With just one vm running I did the following to each, in turn:

       

      I ran the "Install VMware tools" from the Fusion menu

      I installed the rpm

      I ran /usr/bin/vmware-config-tools.pl and it compiled and installed all modules without error (except on the system without the gcc compiler)

      I set the video to 1152x800

      I don't choose the experimental code

      I restart the system (reboot)

      I get a startup screen that says the tools are installed but not configured right (but doesn't say what is wrong). I re-run the VMware tools and the same thing happens. No joy, no clues. I disabled SELinux and tried again - still no joy. These are the very same steps I used to get these same systems running under VMPlayer in Windows.

       

      This isn't rocket science but I'm clearly missing something. Anyone have a suggestion? Is there a link somewhere I've missed that explains to a very experienced Unix pro what is happening here?

       

      MacBookPro 15"

      2 Gig RAM

      200 Gig disk drive <- very nice Momentus 7200 rpm with gravity sensor - took 30 minutes to install

      OS X 10.5.1, fresh install on an empty drive

      Wireless network

        • 1. Re: Fedora 8 and OpenSUsE 10.3 problems
          Guru

          Have you tried copying the working Player VMs over to your Mac (or vice versa)? Do they work as expected?

          • 2. Re: Fedora 8 and OpenSUsE 10.3 problems
            dp_fusion Hot Shot

            Yes - exact same problem exists. But I've learned some things since I last brought one in and I'm going to have another go at it. I also have a perfectly running vm in a vmplayer environment I'll make some comparisons with. I had tried to copy it from the Windows system to my Mac but that didn't work at all. I think I know the reason for that, now.

            • 3. Re: Fedora 8 and OpenSUsE 10.3 problems
              rjcchan Enthusiast

               

              The appliances at the bagvapp.com site usually come with the tools already installed and they seem to work. If they work, I just ignore any warnings about out of date tools or reconfiguring. Not the most elegant approach. You might look at one of their appliances for comparison.

               

               

              I ran into a similar problem with a different distro - zenwalk 5.0. The VM I created myself  lets me install and configure the tools and everything works (drag $drop etc) until I reboot. Then I have to configure all over agin.  The appliance from Bagvapp just works.

               

               

              I did compare the ".vmx" files for these two VMs. There are entries related to Drag and drop ="True" in the Bagvapp version that aren't in the one that I created.  At that point I was already over my head and had to go to my real job so I stopped. You might want to look there instead of in theLinux files tho.