5 Replies Latest reply on Jan 31, 2008 4:07 PM by mykmelez

    VMWareTools v7.6.2 install breaks networking ( NAT / Wireless ) on Ubuntu 7.10

    tonyespy Novice

      I've been running VMWare Fusion for a few months on a fairly new Macbook Pro running Leopard. I use it primarily for Ubuntu development.

       

      I recently updated to VMWare Fusion 1.1 and had no problems until I installed the new version of VMWare Tools ( v7.6.2 build 62573 ).  As soon as I did so, my network ( NAT to my Macbook's WiFi ) connection died. 

       

      It seems that this is a pretty common problem.  There are quite a few posts on this board, and there's also a Ubuntu network-manager bug  for this problem.

       

      As pointed out in the Ubuntu NM bug, the problem seems to stem from the fact that the device link is missing from /sys/class/net/eth0.   This in turn prevents NetworkManager ( via Hal ) from seeing the device, so it's never started.

       

      I've tried re-installing VMWare Tools several times, to no avail.  I also made sure to run the steps output by vmware-config-tools.pl ( eg. stopping networking, rmmod pcnet32, vmxnet, etc... ).

       

      As an experiment, I installed a fresh version of Ubuntu 7.04 and then installed VMWare Tools, ran vmware-config-tools.pl and everything worked fine.  If I check the /sys/class/net/eth0 dir, I see the following device link:

       

      • device -> ../../../devices/pci0000:00/0000:00:11.0/0000:02:00.0

       

      The other difference I've found is that if I cd to to the device link, and do an `ls -l', the driver link in this directory is different between the two guests.  On the working system, I see:

       

      • driver -> ../../../../bus/pci/drivers/pcnet32

       

      If I cd directly to the pci device dir on the broken guest ( /sys/devices/pci000:00/0000:11.0/0000:02:00.0 ) and run `ls-l`, I see:

       

      • driver -> ../../../../bus/pci/drivers/vmxnet

       

      There also is a missing link in this dir.  On the working system, the following link exists:

       

      • net:eth0 -> ../../../../../class/net/eth0

       

       

      FYI, Ubuntu 7.04 is running an earlier version of the kernel ( 2.6.20-15-generic ), whereas Ubuntu 7.10 is running 2.6.22-14-generic.

       

      There is a temporary workaround which involves using network-admin to disable roaming for the Wired Connection ( this adds eth0 to /etc/network/interfaces and removes the device from NM's control ).

       

      I tried a fresh install of Ubuntu 7.10 just to make sure the problem wasn't with any of the post-release updates, and it breaks networking just the same.

       

       

      It looks like this is a problem with the vmware-config-tools.pl script, as the network doesn't go offline, till this script is run ( ie. it's OK after the initial install of the tools ).