1 2 3 4 5 6 Previous Next 342 Replies Latest reply on Jun 2, 2009 3:35 PM by AlbertChurba Go to original post
      • 45. Re: SATA Support Clear as Mud!?
        doctorttt Enthusiast

        Thanks guys. I will try tonight and see how it goes. By the way, do I have to do all these including running the script using the root account?

        • 46. Re: SATA Support Clear as Mud!?
          myxiplx Enthusiast


          I honestly don't remember I'm afraid, but I do know that when the script worked it was very quick with no errors at all, so you'll soon know if it works.  Because I don't know Linux too well though, when I'm running something like this in Ubuntu, most of the time the first command I run is "sudo bash"



          • 47. Re: SATA Support Clear as Mud!?
            gopherhockey Novice

            I tried an Asus MN2-SLI Deluxe AM2 motherboard and had the same end result "mountin root failed".

            • 48. Re: SATA Support Clear as Mud!?
              pdewild Lurker


              But that's a whole other nVidia chipset. I wonder if that'll work with the script provided, as the PCI-ID will probably be another one. Try a "lspci", just to see what it is.



              (btw. on which controller have you connected your harddrive? )



              • 49. Re: SATA Support Clear as Mud!?
                gopherhockey Novice

                I plugged it into one of the 6 on-board sata slots, so I assume its the NVIDIA nForce® 570 SLI. I didn't even realize there was another choice.


                I will do some reading on this script. The system I put together was cheap and fast and runs Windows 2008 Hyper-V just fine... but I really want to test esx 3.5 as well. If I can get it to work I'll order a second system with the same equipment and run both.



                I don't want to invest in another motherboard etc. until I know it will work, of course. I'd also like not to have to go the SCSI route as I have a lot of sata drives lying around.



                I did some back reading on the script that has been posted.  (shoulda done that first).  I will try that, but honestly I'd rather someone posted up a sata card that was just compatible out of the box so all that was not necessary.   If I have to buy an extra card or a different motherboard to avoid all that it would be nice.    No disrespect meant to the genious work behind the script tho!

                • 50. Re: SATA Support Clear as Mud!?
                  rpartmann Expert


                  if you could install ESX3.5 your lucky, so then

                  1.) get a linux live cd.

                  2.) boot.

                  3.) lspci -v -nn | less     .....    and for the rest see my posting in this thread from     Jan 7, 2008 1:50 AM



                  kind regards,


                  • 51. Re: SATA Support Clear as Mud!?
                    Dave.Mishchenko Guru

                    I have a ECS GEFORCE6100SM-M2 /AMD Sempron 3000+ that I was able to get working.  Here's what I did



                    1)  Setup a single SATA with no RAID (the MB uses NVIDIA Geforce6100 chipset for storage). 

                    2)  Installed an Intel Pro/1000 NIC (the onboard is not supported)

                    3)  Installed ESX

                    4)  On the first reboot, I selected the Service Console only (troubleshooting mode) boot option.

                    5)  Let the host boot up and logged in.

                    6)  Edited the file /etc/vmware/pciid/sata_nv.xml - change the last entry to use a device ID of 03f6  (and I updated the device name to MCP61 SATA Controller).  I was able to determine the device ID by running lspci   (since your MB has the nVidia nforce 560 chipset (yes/no?) you can run lspci | grep "nVidia"  and you should see an IDE Nvidia controller that is an unknown device - make a note of the device id and you'll update sata_nv.xml to use that device id).

                    7)  After saving the file, I ran esxcfg-pciid

                    8)  Rebooted and the controller came up fine.


                    I did have to re-format the default vmfs partition with vmkfstools -C vmfs vmhba32:0:0:x, as the VI client did not see any free space on the drive.  In hindsight I would not create a VMFS partition during the install next time I do this.


                    The PC has been running an x64 Windows guest for the last few days without any issues.

                    • 52. Re: SATA Support Clear as Mud!?
                      doctorttt Enthusiast

                      I tried this line, and it didn't work: find . -name \*.sh -exec perl -i -n -e 's/\015//;print' {} \;

                      I forgot what the error was. I remember it was something about .-name not found


                      When I tried lscpi, I got a list of devices. How do I find out which one is the controller?  I again tried copy and paste + execute each line from the script, and I kept on getting error on the #!/bin/bash line.

                      • 53. Re: SATA Support Clear as Mud!?
                        doctorttt Enthusiast

                        Hi Dave, I will try your method; it looks easier. Where can I find the esxcfg-pciid file? To run esxcfg-pciid, do you mean using ./ to execute it? I have no knowledge of Linux, and I'm trying to learn. Thanks

                        • 54. Re: SATA Support Clear as Mud!?
                          rpartmann Expert



                          you will find it under




                          root@myhost:/ which esxcfg-pciid



                          The command  "which" can help you there.




                          • 55. Re: SATA Support Clear as Mud!?
                            Dave.Mishchenko Guru

                            In step 5 I logged in with the root login that was created during the install, so I just had to enter the command and not worry about the path.

                            • 56. Re: SATA Support Clear as Mud!?
                              doctorttt Enthusiast


                              Nothing but frustration - I believe I found the device ID when I used the lspci command - Intel 6300ESB SATA Controller (25a3).  Ok, so I edited sata_nv.xml and saved the file.  I then ran "which esxcfg-pciid" as per partman.  Reboot ESX, same error message - can't mount.






                              • 57. Re: SATA Support Clear as Mud!?
                                doctorttt Enthusiast

                                After playing around and reading more posts, I discovered that my controller: Intel 6300ESB SATA IS supported in ESX 3.5. I looked at the ata_piix.xml file, and my controller was there! So why ESX gave me the unmount error after the installation? I'm so close to get this working without buying a new white box. Pleae help out.

                                • 58. Re: SATA Support Clear as Mud!?
                                  doctorttt Enthusiast

                                  YEYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYY. I found out the problem!!!!!!


                                  The ati_pixx.xml gave me a lot of hint. If my controller was there, and the device ID was correct, why wouldn't it mount? I then started looking at the BIOS. I remember the guys on this forum said that there was no way you can mount with IDE drive, and you would get errors. So in BIOS, I made Intel 6300ESB Sata Controller to be SATA only. It was in MIX mode before - IDE + SATA. I had to do that in order to have my IDE dvd burner to be seen in BIOS. As soon as I turned off the IDE on the 6300 controller, all IDE devices were gone in BIOS. ESX was able to MOUNT! YEYYYYYYYYYY This is a great start for me in learning ESX, but it's only the beginning. Thanks everyone.



                                  FYI - I'm using an old Super Micro motherboard.

                                  • 59. Re: SATA Support Clear as Mud!?
                                    asgard Lurker


                                    I went through and attempted to run the script, after adjusting for my sata controller address.  I found I was having issues, so I decided to walk through the script manual.  What I've found is that there is no /mnt/eroot/etc/vmware/pciid folder.  There may be other issues, but this is what I hit first. 



                                    I'm not a Linux guy by any sense of the word, but can muddle my way through things as I need to.  What I'm wondering is if there was a problem with the install or a reason why I don't have this folder.  Either way, is there something I need to or can do to correct for this?  Or do I just reinstall and try again? 



                                    For reference, I'm a home office base tech who had work pay for a lic that I could load on a spare PC at home.  It is nothing special, but other then not mounting root, I don't see any other impediments.  The SATA controller is the Intel 82801EB (ICH5).  The install and the troubleshoot mode have no issues with it, so I'm hoping it is the same situation others in this and similar threads are fighting with. 



                                    Thank you to any one who can help. 



                                    1 2 3 4 5 6 Previous Next