13 Replies Latest reply on Mar 23, 2020 10:17 AM by STem1980

    Older versions of Windows NT

    seanneko Novice

      Hi

       

      Has anybody been able to install older (pre-4.0) versions of NT under VMWare Fusion? I get these errors when trying to install them:

       

      NT 3.51: Installs and runs, but reports a failed service and network is non-operable

      NT 3.5: Gives a stop error when using SCSI hard drive, or "cannot load keyboard layout" with IDE hard drive

      NT 3.1: Gives a cryptic "ArcPathToDosPath" error when installing

       

      I've tried both with and without the patches to allow them to work on post-P5 architecture processors, and it didn't really make much of a difference either way.

       

      I could've sworn that I had these working on VMWare Workstation under Windows a while back, so hopefully there's some way to get them working under Fusion too.

        • 1. Re: Older versions of Windows NT
          seanneko Novice

          I've tried this under VMWare Server on Linux now and had the same results, so this isn't limited to just Fusion.

           

          I managed to solve the NT 3.5 issue (cannot load keyboard layout) though - turns out that it's caused by a corrupt partition table. I had to manually modify the partition ID using a program called PTS Disk Editor. It installed and runs now, but still with the network problem like NT 3.51.

           

          I haven't gotten any further with NT 3.1 though.

          • 2. Re: Older versions of Windows NT
            rcardona2k Champion

            These OS's were quite limited in terms of hard disk sizes and RAM they could handle.  I would highly advise installing these OS's with virtual disks with less than 2 GB in size and less than or equal to 64 MB of RAM.

            • 3. Re: Older versions of Windows NT
              seanneko Novice

              Thanks, I got them all working to an extent. I'm using 1GB IDE disks and 32MB RAM.

               

              I played around with the partition table a bit more and got NT 3.1 to install. The only problem is that it randomly gives a stop error when booting, maybe 20% of the time. Once it's booted successfully, it runs fine. Microsoft says that this was a known problem that was fixed in a service pack, but I installed the service pack and it still happens. Maybe VMWare is triggering it or another problem somehow.

               

              I downloaded an AMD NDIS 3 network driver for NT 3.51 which got network support working. However, I'm not aware of any NDIS3 driver for NT3.1/3.5, so I don't know if there's any way to get network going in them.

              • 4. Re: Older versions of Windows NT
                rcardona2k Champion

                May I ask what possesses you to run NT 3.1 and NT 3.51??  NT 3.51 was "decent" prior to Win95, but NT 3.1 brings back bad memories of staying at the HoJo next to the BurgerMaster ( yes, that BurgerMaster in Windows ) in Kirkland, WA.

                • 5. Re: Older versions of Windows NT
                  tagq2 Novice

                  3.51 initial boot reports wrong memory (290820 KB, even when I allocate under 32MB) with Fusion 2.0.1. The system then hangs at the blue NT boot screen.

                   

                  Fix is to "downgrade" the virtual machine to a Fusion v1 machine.

                   

                  Anywhere to submit bug report that doesn't require a support contract?

                   

                  Cheers.

                  • 6. Re: Older versions of Windows NT
                    Guru

                    Here is fine. So we can reproduce this, is this a fresh install of 3.51?

                     

                    Actually, NT 3.5 is not on the list of supported guests, so even if I file a bug, it'll probably be immediately closed as wontfix.

                    • 7. Re: Older versions of Windows NT
                      tagq2 Novice

                      Thanks. Yep, fresh install of 3.51 Advanced Server (MSDN). I choose default settings for a "Windows NT" machine, excepting: allocating memory down to 28MB, changing from NAT to bridged, and allowing boot from floppy so I can do initial install (via Windows 98 DOS floppy and winnt /b). Fusion is build 128865.

                       

                      FWIW, I'm also getting a missing registry entry error in the Event Log from the amd pcnet driver, so networking does not start, though I haven't looked into this yet. It'll be obvious on first reboot, as a failed service error appears a couple of seconds after the login screen.

                       

                      (edit) Upgrading to SP5 fixes the amd pcnet error (so install w/o networking, upgrade to SP5, install adapter, then re-apply SP5 so Server service works properly). The correct memory is now reported even with an "upgraded" VM, but still hangs at the NT blue boot screen; solution to revert to v1. Perhaps slipstreaming SP5 would install different HAL/drivers so it all works from the start.

                       

                      Message was edited by: tagq2

                      • 8. Re: Older versions of Windows NT
                        kandoIDN Lurker

                        OK, i got 3.50 working in vmware...not fusion, but workstation...dont have a mac...reguardless...

                         

                        to get past the blue kernel screen, you need to set the "multiprocessor type" in the bios screen in the vmware image from 1.4 to 1.1

                         

                         

                         

                        however, heres some tips to installing:

                         

                         

                         

                        you need a fat16 file system. and i suggest making 2 partitions. c drive small, d drive will be your actual install directory. i used 100/400mb.

                         

                         

                         

                        when booting from the cd, hit f3 twice to exit. the x: is the cd, and the a: will have a virtual drive created by the cd with fdisk and format. se these to set the 2 partitions, but when you restart, only format the c drive.

                         

                         

                         

                        go back to the x: (is what the virtual CD drive is), make sure you are in x:\i386, and type winnt /b (this will not require the 3 floppies)

                         

                         

                         

                        when it shows the 2 partitions inside of the setup later on, select the second partitoin, delete the "existing partition" which is "unknown", and DO NOT USE NTFS, USE FAT...using ntfs will render 30 mins-an hour of your time worthless at the end.

                         

                         

                         

                        usually it likes to corrupt some files, so after it copies all the files over and tries to boot for the first time, i suggest u reboot from the cd, f3 twice, a:, scandisk both hard drives.

                         

                         

                         

                        I ended up having to make many snapshots, and even manually copying the vmdk, and in the end, i manually expanded the entire cd on my real computer, looked at the vmdk directory structure to make mine match, mashed my files over the messed up ones,which almost made it, but then an inf file was messed right before installing the network card, in which i had to copy a different named good one over it, like one letter up or down...you'll see. one you get past the network selection screen, usually you are home free

                         

                         

                         

                        hope this helps!

                        • 9. Re: Older versions of Windows NT
                          thanuk Lurker

                          I've got NT 3.51 SP5 working just fine, as someone says above you do have to downgrade the virtual machine otherwise it hangs at the blue boot screen.

                           

                          How do you get NT 3.1 installed though? I've got as far as the screen asking about additional SCSI adapters, I tried selecting the BusLogic family but it didn't seem to work. I also tried pre-formatting the virtual disk with MS-DOS first. The error message each time is 'unable to locate the hard drive partition prepared by the MS-DOS portion of setup"

                          • 10. Re: Older versions of Windows NT
                            kandoIDN Lurker

                            boot from a windows 98 startup disk, and use fdisk and format there....only up to a 2gig max per partition, the file system HAS to be fat16 and the windows 98 startup disk uses that...

                             

                            to be safe i usually know a 500mb partition, either just with the above disk straight up, or by saying NO to large disk support on other fdisks, always makes fat16 when formatted. once you format, you can go for it

                             

                             

                            if you need more help you can find me on irc at irc.ircdotnet.net channel #ot...i have become an OS collecting addict and id like to talk to others who work with images

                             

                             

                            -kando

                            • 11. Re: Older versions of Windows NT
                              me23 Lurker

                              I know this is really old but, changing the hardware compatibility to version 5 worked for me. I got Windows NT 3.51 to work.

                              • 12. Re: Older versions of Windows NT
                                gringley Enthusiast

                                I would like to see a table of recommended VM hardware versions for the various OS over the years.

                                • 13. Re: Older versions of Windows NT
                                  STem1980 Lurker

                                  I've got 3.51 SP5 up and running on 2 vCPUs with 2G of RAM. There are a few tricks:

                                  1. A fix for halmps.dll to issue 'hlt' instructions (solves high CPU consumption issue): here's the difference between the original and the fixed one from the Q163852 package:

                                  fc /b halmps.old halmps.dll

                                  Comparing files HALMPS.OLD and HALMPS.DLL

                                  000000D8: F0 E7

                                  000000D9: 4B 7C

                                  000062E1: C3 F4

                                  000062E2: CC C3

                                  2. VBEM driver 2010.07.09 works fine, the later version crashes

                                  3. SB16 has to be forced with sound.virtualDev = "sb16", MPU-401 set to "disabled" during the installation