0 Replies Latest reply on Nov 28, 2007 3:59 PM by pizzacake

    Instructions: enable wacom pressure sensitive tablet in Ubuntu 7.10, Leopard & VMware Fusion 1.1

    pizzacake Lurker

      I got this info from various sources and thought it would be useful to combine the info here, thanks to the original posters.  My setup Mac OS X Leopard, Alu iMac C2D 2.4Ghz with wireless keyboard and mouse, VMware Fusion 1.1, Ubuntu 7.10 installed as 64bit VMWare machine.

      Before I continue the downside to getting tablet support in VMware is that once you're finished, in Mac OS X the tablet isn't seen again until you reboot afaik.

       

      First we have to get VMware to see the wacom tablet and the cursor not to disappear.

      In Finder right click the VMware machine file and choose show package contents.

       

      In the virtual machine directory, open the virtual machine's configuration (.vmx) file in a text editor (not textedit as it may corrupt the file, I used xcode) and add the following lines to the end of the virtual machine's configuration (.vmx) file:

       

      usb.generic.allowHID = TRUE

      vmmouse.present = "FALSE"

       

      In your home directory, add the following line to the end of the file ~/Library/Preferences/VMware Fusion/preferences:

       

      pref.motionUngrab = "FALSE"

       

      In Ubuntu

      Remember to plug in your tablet before you boot; it makes things simpler.

       

      With the version of the Linux Wacom driver (0.7.2) in Ubuntu, if you unplug you tablet, it won't function when you plug it back in and you will have to restart X. For this reason, it is best to leave the tablet plugged in.

           1.     Open synaptic package manager and search for wacom and make sure the following packages are installed wacom-kernel-source, wacom-tools and xserver-xorg-input-wacom.. If you prefer using the command line, you can also execute : 
sudo apt-get install xserver-xorg-input-wacom wacom-tools

           2.     Save a copy of your /etc/X11/xorg.conf with this command in terminal

                      sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

                   then edit xorg.conf with the command line 


                      gksudo gedit /etc/X11/xorg.conf


                      and change all /dev/wacom occurences into /dev/input/wacom (created by wacom-tools udev scripts),

                      You'll need to uncomment some lines in /etc/X11/xorg.conf to get the tablet working properly:

                       

      1. Uncomment if you have a wacom tablet

                      InputDevice     "stylus"        "SendCoreEvents"

                      InputDevice     "cursor"        "SendCoreEvents"

                      InputDevice     "eraser"        "SendCoreEvents

                      then save the file.

       

      In GIMP and Inkscape and other tablet aware applications make sure you enable tablet support by modifying configure extended input devices e.g. device eraser, cursor, stylus to mode screen.

      My Wacom Intuos 2 is fully pressure sensitive and works well in Inkscape and GIMP.