1 2 Previous Next 16 Replies Latest reply on Mar 25, 2008 3:28 AM by Turkalex

    The VMware host agent service (vmware-hostd.exe) crashes on windows XP

    Learnincurve Novice

       

      Tried installing VMware server 2 beta after unistalling v.1.0.3  Install went okay but no prompt for serial number.

       

       

      After install,vmware-hostd.exe crashes before I can log into the web GUI. on restart it runs for a few seconds then crashes again..

       

       

      Error details are:

       

       

      szAppName: vmware-hostd.exe  szAppVer:0.0.0.0 szModName:statssvc.dll szModVer:0.0.0.0 offset:00021826

       

       

      Have tried uninstalling/reinstalling, with restarts between uninstall/reinstall.

       

       

      Have read on forum that Infrastructure client can be used as admin GIU, but this is available for licensed (commercial) products only??? I can't find a download that I can use.

       

       

       

       

       

      Any tips/hints?

       

       

        • 1. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
          Peter_vm Guru

          VI Client 2.5.0 for Windows is a part of VMware Server 2.0 Beta 1 package for Linux.

          • 3. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
            Learnincurve Novice

             

            Duh! Can't find it. I've downloaded the 32 and 64 bit linux tarballs. What's the infrastructure client installer called?

             

             

            • 5. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
              Learnincurve Novice

              Thanks very much! No go though. Installed client, but can't log in. Probably due to same failure as for the Web GUI.

               

              Any ideas where to start hunting for what's killing my vmware-hostd process?

               

               

              UPDATE:

               

               

              I found my ~~\Application Data\VMware\VMware Server\hostd-0.log file and have the following extra information:

               

               

              ...

               

               

              ...

               

               

              'Proxysvc' 888 info] Proxy: Starting new Proxy service

              Proxy Https service started

              Proxy: Starting new Proxy service

              Proxy Http service started

              Plugin started

              HTTP datastore document access not implemented

              Patch uploading will fail because /tmp does not exist

              soapPort: 8085

              VM inventory configuration: C:\Documents and Settings\All Users\Application Data\VMware\VMware Server\hostd\vmInventory.xml

              Option path '' not found

              Option node '' not found

              Option path '' not found

              Option node '' not found

              Http Service started: TCPServerSocket(listen=:8085)

              Using new VMDB VMOMI serialization format

              Not enablng management restriction checks

              Plugin started

              Http Service started: class Vmacore::System::NamedPipeServerWin32:03E72B30

              Http Service started: class Vmacore::System::NamedPipeServerWin32:03E72A90

              Starting statssvc plugin

              Failed to add enumerator to the refresher

              Failed to add memory object to the refresher

               

               

               

               

               

               

               

               

              Maybe this will help in bugfixing.

               

               

               

               

               

              Cheers!

              • 6. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                Learnincurve Novice

                 

                New update:

                 

                 

                  I fiddled with the config.ml file and changed the line under <statssvc>:

                 

                 

                <enableMockup>false</enableMockup>

                 

                 

                to

                 

                 

                <enableMockup>true</enableMockup>

                 

                 

                Might have broken something else, but at least:

                 

                 

                Service now starts and I can connect and login through the web GUI

                 

                 

                Still can't connect to 127.0.0.1 using the infrastructure client though. Any tricks to make this work?

                 

                 

                 

                 

                 

                Cheers!

                 

                 

                • 7. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                  BigDaddio Novice

                  Greetings all.  I had a similar problem with VMWare Server 2, build 63231 installed on Windows Server 2003 SP2.  I looked for the config.ml file and could not find it. Since I had extenuating circumstances (installed as Domain Admin, but logged in as LM Admin on first run, and had XAMPP 1.6.4 installed with Tomcat 5.5 add-on) I figured those had possible problems may have caused it. I uninstalled VMServer 2, XAMPP, Tomcat, and TightVNC (also has a http server component), and reinstalled only Server 2 as local machine admin.  That seemed to fix the problem with the hostd service crashing.  I kept the logs and dumps from the original installation if you can do anything with them.  Let me know where to send them.  Thanks.

                  1 person found this helpful
                  • 8. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                    Learnincurve Novice

                     

                    Thanks!

                     

                     

                    I did have VNC installed, so removed it. Also have IBM CDP for files which has a webserver element, and have tried both disabling the service, and removing it. Ther was also an FTP client which the VMware installer asked me to close, so I removed that altogether too. This is a laptop (for testing purposes), so I do have far too many applications installed and running to be able to do a clean install. Will try installing in my Linux partition also, as this is cleaner. Unfortunately the problem still persists.

                     

                     

                    Even with the workaround I mentioned earlier, I have problems with the service crashing if I try to add USB devices to my VM, I don't know if that problem is related or not...have a separate thread for it in the Beta forum, but haven't had an answer yet.

                     

                     

                    • 9. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                      MonsterMaxx Enthusiast

                       

                      hmm, XP here too.

                       

                       

                       

                       

                       

                      Guess I'll uninstall

                       

                       

                      • 10. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                        Learnincurve Novice

                         

                        Do you have the same problem?

                         

                         

                        I got a mail today from Vmware asking for feedback. So I gave it. Next move is to try running it from Linux and finding a smart way to install the Infrastructure Client as a Gui. Doesn't work in Wine, so I'm trying a minimal Windows98 VM just for VIC.. will let you know how it goes.

                         

                         

                        • 11. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                          MonsterMaxx Enthusiast

                           

                          D'oh, my bad. Yes, I have the same problem. vmware-hostd.exe crashes immediatly on bootup.

                           

                           

                          I uninstalled V2 and went back to V1.x

                           

                           

                           

                           

                           

                          First I tried VM workstation 6 which runs fine on my V64 lappy. It BSOD'd the workstation running XP.  I tried everything to stop it from doing so, finally a system restore prior to VM6 install brought it back. If that hadn't worked I'd have been hacking the reg.

                           

                           

                          I'm kind of thinking this is because I had to setup IIS to get V1.x running, perhaps some conflict. The bsod was something to do with '...power...' (I forget what the error was and unfortunatly didn't write it down)

                           

                           

                          Then reinstalled V1.x and it barfed a few error messages on install, which I ignored, rebooted and it seems to work fine.

                           

                           

                          • 12. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                            mspiller Lurker

                             

                            Crashes for me too Windows XP sp1 x64:

                             

                            C:\Program Files (x86)\VMware\VMware Server>"C:\Program Files (x86)\VMware\VMwar

                            e Server\vmware-hostd.exe" "C:\Documents and Settings\All Users\Application Data

                            \VMware\VMware Server\hostd\config.xml"

                            Current working directory: C:\Document

                            s and Settings\All Users\Application Data\VMware\VMware Server

                            HOSTINFO: Seeing AMD CPU, numCore

                            sPerCPU 2 numThreadsPerCore 1.

                            HOSTINFO: This machine has 1 phys

                            ical CPUS, 2 total cores, and 2 logical CPUs.

                            Trying blklistsvc

                            Trying cimsvc

                            Trying directorysvc

                            Trying hostsvc

                            Using netmap configuration

                            file C:\Documents and Settings\All Users\Application Data\VMware\VMware Server\

                            netmap.conf

                            VNL_GetBriggeState call f

                            ailed with status 1.Refreshing network information failed

                            Active ftp is 1

                            Allowanyoui is 0

                            udptimeout is 30

                            No advanced options found

                             

                            Deserialized nas datsto

                            re inventory is NULL

                            2007-11-28 21:19:47.734 'Hostsvc::AutoStartManager' 3292 info VM autostart con

                            figuration: C:\Documents and Settings\All Users\Application Data\VMware\VMware S

                            erver\hostd\vmAutoStart.xml

                            Locale subsystem initialized from C

                            :\Program Files (x86)\VMware\VMware Server\locale/ with default locale en.

                            Resource pool in

                            stantiated

                            Refresh interval

                            : 60 seconds

                            Plugin initialized

                            Trying internalsvc

                            Trying nfcsvc

                            Breakpoints disabled

                            Using system libcrypto, version 9

                            070AF

                            Successfully loaded t

                            he diskLib library

                            Plugin initialized

                            Trying partitionsvc

                            Trying proxysvc

                            Proxy config filepath is C:\Docum

                            ents and Settings\All Users\Application Data\VMware\VMware Server\hostd\proxy.xm

                            l

                            Plugin initialized

                            Trying snmpsvc

                            Trying solo

                            Vmacore::InitSSL: doVersionCheck = fal

                            se, handshakeTimeoutUs = 120000000

                            Initialized SSL context with version

                            all

                            Host name: zombie

                            Compute resource instantia

                            ted

                            Environments file: C:\D

                            ocuments and Settings\All Users\Application Data\VMware\VMware Server\hostd\/env

                            ironments.xml

                            Descriptor loaded: 4

                            Options loaded

                            Descriptor loaded: 2

                            Options loaded

                            Descriptor loaded: 3

                            Options loaded

                            Plugin initialized

                            Trying statssvc

                            Initializing statssvc plugin

                            Collection interval is 20 sec

                            Stats Depot has future timestamp

                            s. Discarding old statistics information

                            Reverting to default stats con

                            figuration

                            Trying supportsvc

                            Plugin initialized

                            Trying vcsvc

                            Trying vimsvc

                            Initializing vimsvc plugin

                            Wrong formatted ADs path of

                            'WinNT://zombie'

                            Failed to initialize active di

                            rectory

                            Failed to initialize Active Directory

                            services

                            error: Not initialized

                            backtrace:

                             

                            backtrace[00] eip 0x005fea25 ?GenerateCoreDump@System@Vmacore@@YAXXZ

                            backtrace[01] eip 0x0056bf9a ?CreateBacktrace@SystemFactoryImpl@System@Vmacore@@

                            UAEXAAV?$Ref@VBacktrace@System@Vmacore@@@3@@Z

                            backtrace[02] eip 0x00543610 ??0Throwable@Vmacore@@QAE@ABV?$basic_string@DU?$cha

                            r_traits@D@std@@V?$allocator@D@2@@std@@@Z

                            backtrace[03] eip 0x06277f22 (no symbol)

                            backtrace[04] eip 0x062783c0 (no symbol)

                            backtrace[05] eip 0x062644f6 (no symbol)

                            backtrace[06] eip 0x00563d4d ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[07] eip 0x00567402 ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[08] eip 0x005678bc ?InitApp@Service@Vmacore@@YAXHPAPADABV?$Ref@VAppInf

                            o@Service@Vmacore@@@2@@Z

                            backtrace[09] eip 0x004025d7 (no symbol)

                            backtrace[10] eip 0x00401bff (no symbol)

                            backtrace[11] eip 0x0040115a (no symbol)

                            backtrace[12] eip 0x7d4e992a BaseProcessInitPostImport

                             

                             

                             

                            Exception: Assert Failed: "adapterServer != 0" @ d:\build\ob\bora-63231\bfg-atla

                            ntis\bora\vim\lib\public\vmomi/server.h:1071

                            Backtrace:

                            backtrace[00] eip 0x005fea25 ?GenerateCoreDump@System@Vmacore@@YAXXZ

                            backtrace[01] eip 0x0056bf9a ?CreateBacktrace@SystemFactoryImpl@System@Vmacore@@

                            UAEXAAV?$Ref@VBacktrace@System@Vmacore@@@3@@Z

                            backtrace[02] eip 0x00543610 ??0Throwable@Vmacore@@QAE@ABV?$basic_string@DU?$cha

                            r_traits@D@std@@V?$allocator@D@2@@std@@@Z

                            backtrace[03] eip 0x00541d47 ?PanicExit@Vmacore@@YAXABV?$basic_string@DU?$char_t

                            raits@D@std@@V?$allocator@D@2@@std@@@Z

                            backtrace[04] eip 0x00541f5c ?RunTimeFailure@Vmacore@@YAXPBD00HH@Z

                            backtrace[05] eip 0x0526fe4d (no symbol)

                            backtrace[06] eip 0x05270cbb (no symbol)

                            backtrace[07] eip 0x0055ea25 ?DecRef@ObjectImpl@Vmacore@@UAEX_J@Z

                            backtrace[08] eip 0x05265f0b (no symbol)

                            backtrace[09] eip 0x0055ea25 ?DecRef@ObjectImpl@Vmacore@@UAEX_J@Z

                            backtrace[10] eip 0x00562e8a ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[11] eip 0x00562e6c ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[12] eip 0x005632c9 ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[13] eip 0x0056400c ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[14] eip 0x0056618f ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[15] eip 0x0056639b ?GetApp@Service@Vmacore@@YAPAVApp@12@XZ

                            backtrace[16] eip 0x0055ea25 ?DecRef@ObjectImpl@Vmacore@@UAEX_J@Z

                            backtrace[17] eip 0x01a1fa80 (no symbol)

                            backtrace[18] eip 0xc001a1fd (no symbol)

                             

                            CoreDump: Writing minidump to C:\Docum

                            ents and Settings\Administrator\Local Settings\Application Data\VMware\vmware-ho

                            std-3500-3292.dmp

                             

                            This application has requested the Runtime to terminate it in an unusual way.

                            Please contact the application's support team for more information.

                             

                            C:\Program Files (x86)\VMware\VMware Server>

                            • 13. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                              Learnincurve Novice

                               

                              Looks like I've been lucky then to get it to work at-all. I now see that USB (which is why I decided to try the Beta) isn't suported at-all yet, let alone in version 2. So I guess I'll abandon this release and have another look when Beta2 comes along. Looking at your log it does look like it's a statssvc problem for you too, not liking something in your AD. Have you tried the config.xml hack?

                               

                               

                              • 14. Re: The VMware host agent service (vmware-hostd.exe) crashes on windows XP
                                mspiller Lurker

                                 

                                No, <enableMockup>true</enableMockup> didn't work.

                                 

                                 

                                Still same error:

                                 

                                 

                                Initializing vimsvc plugin

                                Wrong formatted ADs path of

                                'WinNT://zombie'

                                Failed to initialize active di

                                rectory

                                Failed to initialize Active Directory

                                services

                                error: Not initialized

                                backtrace:

                                 

                                 

                                 

                                 

                                 

                                1 2 Previous Next