1 2 3 4 Previous Next 48 Replies Latest reply on Mar 26, 2008 9:07 AM by arekgondek

    Console doesn't work with Firefox 2.0 (Linux)

    jmmarton Hot Shot

      Running Firefox 2.0.0.8 on SUSE Linux Enterprise Desktop (SLED) 10 SP1.  I have the "VMware Virtual Machine Remote Console Plug-in" installed (version 2.0.0.63231).  However when I go to the console tab I just get a black screen.  Seems to work ok with FF2 and IE6 on Windows, though.

       

      Joe

        • 1. Re: Console doesn't work with Firefox 2.0 (Linux)
          Hot Shot

          The way the plug-in is being packaged sometimes requires a Firefox restart even if the browser does not request one.  This is a long-standing Firefox feature request which may be fixed in a future release.  Can you confirm that the problem is still evident after restarting the browser (please verify the process has completely exited)?  Thanks.

          • 2. Re: Console doesn't work with Firefox 2.0 (Linux)
            jmmarton Hot Shot
            bkolin wrote:

            The way the plug-in is being packaged sometimes requires a Firefox restart even if the browser does not request one.  This is a long-standing Firefox feature request which may be fixed in a future release.  Can you confirm that the problem is still evident after restarting the browser (please verify the process has completely exited)?  Thanks.

             

            I already did that assuming a restart was needed. After this post I decided to try a second restart just for the heck of it.  Still no luck getting things to work.  When I select the console I'm still getting just a black box while using FF on SLED.

             

            Joe

            • 3. Re: Console doesn't work with Firefox 2.0 (Linux)
              cross37 Novice

               

              I'm having the same problem. 

               

               

                  firefox 2.0.0.8 - gentoo linux kernel 2.6.17

               

               

                  Under firefox for linux I just get a blank screen, so I tried connecting from firefox running on Windows XP on a different machine.  The plug-in installed, but all I get is this error:

               

               

              http://communities.vmware.com/servlet/JiveServlet/downloadImage/1282/vmerror.jpg

               

               

               

              The windows xp machine can access other services on the host without any problems.

               

               

               

               

               

               

               

               

              • 4. Re: Console doesn't work with Firefox 2.0 (Linux)
                PicatrixSomoza Novice

                Could it be a permissions related problem?  Did you try to run Firefox as root?

                • 5. Re: Console doesn't work with Firefox 2.0 (Linux)
                  adlerweb Lurker

                  And another blank screen with FF 2.0.0.8(64Bit) on Gentoo 2.6.22-gentoo-r9, x86_64 (root shows the same problem)

                   

                  2.0.0.9 (32Bit) on Gentoo 2.6.22-gentoo-r9, x86_64 leads to a timeout:

                  Cannot view virtual machine console. The request timed out.

                  The attempt to acquire a valid session ticket took longer than expected. If this problem persists, contact your system administrator.

                   

                  Firefox 2.0.0.9 on Windows XP SP2 works for me.

                   

                  Message was edited by: adlerweb (Cleanup)

                  • 6. Re: Console doesn't work with Firefox 2.0 (Linux)
                    PicatrixSomoza Novice

                    Are you sure the main server is running?  If it's running, did you issue netstat to see if the webconsole service is running?

                    • 7. Re: Console doesn't work with Firefox 2.0 (Linux)
                      adlerweb Lurker

                      The VMware-Server is running - netstat shows several vmware-processes. I tested all Browsers on the same server. Since the XP-Client works i think its related to the client.

                       

                      And another test: Again a blank screen with 2.0.0.8 and 2.0.0.9 32Bit Linux on another PC.

                       

                      Ill try it tomorrow with another host and client, but as i said: i think the problem is related to the plugin/browser.

                      • 8. Re: Console doesn't work with Firefox 2.0 (Linux)
                        ARADTech Lurker

                         

                        Running latest FF on Fedora 8.  Get the same issue.  Plugin is in stalled , entire machine has been rebooted.  First connect to console advises that it is uable to connect , connection refused. Subsiquent retries gives a black screen.

                         

                         

                        I am running with eth0(100) turned off and entire system is running on eth1(1000) could that have something to do with this issue does eth0 need to be active?

                         

                         

                        I will do some more testing along that path shortly.

                         

                         

                        Peace and Creativity

                         

                         

                        Chris

                         

                         

                        • 9. Re: Console doesn't work with Firefox 2.0 (Linux)
                          DottedT Lurker

                          I had something similar happen with the FireBug plugin using Ubuntu.  As it turned out I had to compile FireFox from the source.

                           

                          One possible test is to install the FireBug plugin.

                           

                           

                           

                          Restart FireFox

                           

                           

                           

                          Go to any page http://www.google.com will due.

                           

                           

                           

                          In the lower right corner of the browser look for the green circle with a white check mark in it.

                           

                           

                           

                          Click on it.  You should see the FireBug interface expand from the bottom.  If nothing happens look into compileing FireFox from the sources and enable mozdevelop.  I'm not sure of other distros but here's a thread for Ubuntu.

                           

                           

                           

                          http://ubuntuforums.org/showthread.php?t=433967

                           

                          Message was edited by: DottedT

                          • 10. Re: Console doesn't work with Firefox 2.0 (Linux)
                            Garret Novice

                            I'm using Gutsy and it all works fine here.

                            • 11. Re: Console doesn't work with Firefox 2.0 (Linux)
                              setha Novice

                               

                               

                               

                               

                              Fedora 6.  Firefox 1.5.0.12.  Installed plugin.  Firefox told me to restart if I wanted the  plugin to work.  I did.  Brought firefox back up.  Still could not see the guest's console.  Instead, firefox suggested that I install the plugin.  Re-installed.  Restarted the machine.  Still didn't work.  Tried running firefox as root, installing the plugin, etc. Still didn't work.

                               

                               

                              Oh, and during the shutdown the machine hung up.  I believe it was in /etc/init.d/vmware at the line:

                               

                               

                               

                              vmware_run_vimsh_cmd "`vmware_product_name` Host Agent" 'internalsvc/shutdown'

                               

                               

                               

                              And I was only able to log in to the server as root.  The server is the same machine on which I'm running the Firefox browser.

                               

                               

                               

                              Gave up and went back to VMware Server 1.0.4.

                               

                               

                               

                              --Seth

                              • 12. Re: Console doesn't work with Firefox 2.0 (Linux)
                                dr.evil Lurker

                                 

                                I have the same problem here. I'm running the 32bit server on a Debian Sid host. All is working well so far, except the blank console. I have tried so far: Iceweasel-2.0.0.8 from Debian, firefox-2.0.0.9 from mozilla.org,  firefox-3.0beta from mozilla.org. In all cases I get only a blank console.

                                 

                                 

                                I tried all of them in a terminal a and get this:

                                 

                                 

                                /home/acidman/.mozilla/firefox/olq827uf.default/extensions/VMwareVMRC@vmware.com/plugins/vmware-vmrc-2.0.0-63231/bin/vmware-vmrc-legacy: symbol lookup error: /home/acidman/.mozilla/firefox/olq827uf.default/extensions/VMwareVMRC@vmware.com/plugins/vmware-vmrc-2.0.0-63231/lib/libvmwareui.so.0/libvmwareui.so.0: undefined symbol: ZN4view10FieldEntry15onsize_requestEP15_GtkRequisition

                                 

                                 

                                 

                                Maybe it's the cause of the problem. I also tried galeon-2.0.2 and epiphany-2.20.1 after I copied the vmware plugin to ~/.mozilla/plugins manually - but then the console fails to connect to the running vm. I also tried to add a new vm with no installed os at that moment -> same problems. Then I was testing for fun with a wine emulated IE6 and the console worked as far as i tried to log in to the running XP guest. But I didn't expect it to work in an emulated IE6. I wish my vmware-server-console back

                                 

                                 

                                • 13. Re: Console doesn't work with Firefox 2.0 (Linux)
                                  fsanders Novice

                                   

                                  No luck with getting the Console to work in Firefox 2.0.8 under Ubuntu Gutsy here either.  I also tried Opera, Konqueror, and Epiphany with no luck.  I installed the plugin, but I just get the black screen in the console.  I have also rebooted. 

                                   

                                   

                                  Fred

                                   

                                   

                                  • 14. Re: Console doesn't work with Firefox 2.0 (Linux)
                                    barnys Enthusiast

                                    Did you install the plugin for Firefox (in the admin guide).  Also did you see the "known issues" for firefox that were documented with this release (see release notes).  Maybe you are missing something that is already documented there?

                                    1 2 3 4 Previous Next