1 2 Previous Next 18 Replies Latest reply on Dec 15, 2008 3:17 PM by jp42

    Fusion suddenly ignoring keyboard input

    Keltia Novice

       

      I have a FreeBSD 8.0/amd64 VM running under Fusion.  I was happy using it with the previous version (build 57nnn - 1.1fc1 IIRC) and decided to uprade to 1.1 RC build 61385.  Upgrade went fine but all of a sudden, my VM refuses keyboard input and just beeps.  I went back to the prevous build, same thing happen.  I installed again 61385 still no keyboard input.  This is on a Tiger 10.4.10 macbook pro with 2 GB of RAM (512 for the VM).  The only other thing that changed was that I tried to give more memory to the VM (516 -> 768 MB).

       

       

      Any idea why this could happen?  I really enjoyed Fusion compared to Parallels with amd64 & dual core CPU support but I'm ready to go back to parallels if this does not work...

       

       

      Thanks

       

       

        • 1. Re: Fusion suddenly ignoring keyboard input
          Guru

          Can you check if any app is using SecureInput while this occurs (run "ioreg -l -w 0 | grep SecureInput" in an OS X terminal)?

          1 person found this helpful
          • 2. Re: Fusion suddenly ignoring keyboard input
            Keltia Novice

             

            Good catch:

             

             

            209 roberto@rron:~> ioreg -l -w 0 | grep SecureInput

              |   "IOConsoleUsers" = ({"kCGSSessionGroupIDKey"=501,"kCGSSessionOnConsoleKey"=Yes,"kCGSSessionIDKey"=256,"kCGSSessionUserNameKey"="roberto","kCGSessionLoginDoneKey"=Yes,"kCGSessionLongUserNameKey"="Ollivier Robert","kCGSSessionSystemSafeBoot"=No,"kCGSSessionLoginwindowSafeLogin"=No,"kCGSSessionConsoleSetKey"=0,"kCGSSessionUserIDKey"=1193,"kCGSSessionSecureInputPID"=270})

             

             

            PID 270 is Checkpoint SecureClient:

             

             

              270  ??  S     57:59.36 /opt/CPsrsc-50/bin/SecureClient.app/Contents/MacOS/SecureClient -psn_0_2228225

             

             

            Now, how to workaround that?

             

             

             

             

             

            • 3. Re: Fusion suddenly ignoring keyboard input
              Guru

              One workaround is to not use SecureClient and Fusion at the same time.

              • 4. Re: Fusion suddenly ignoring keyboard input
                czantra Novice

                I am having the same problem with keyboard input. At first I thought it was something up with my install of the release candidate (I'd upgraded to Leopard, and then downloaded the RC while my iMac was racing between Spotlight and Time Machine on a newly attached external disk so Terminal and Disk Utility stuck while I was going to do an md5 sum of the RC's dmg) as the VMware tools disk image was broken when trying to upgrade within Ubuntu 7.10 or with the fact that the first VM I used had been suspended midflow and then copied to another disk.

                 

                I downloaded the RC again and tried both Ubuntu 7.10 and Windows XP and both had the same problem. Coming here, I did the appropriate search for SecureInput. I expected it to be Terminal as I had (at one stage) switched secure entry on and Terminal was running but I had evidently switched it off again. I found that Opera was the program that was preventing keyboard entry as it was using SecureInput. I quit Opera and am able to type into my VMs again.

                 

                In related news, the VMware Tools image is OK now (with my second download (md5-ed first)).

                • 5. Re: Fusion suddenly ignoring keyboard input
                  kovar Novice

                   

                  Greetings,

                   

                   

                   

                   

                   

                  In my case, PGP Desktop turned out to be the culprit. Killing it cleared up my VM keyboard problem and, when it restarted, the problem did not reappear.

                   

                   

                  This problem started after I installed the latest beta and then backed it out because it was causing OS X to kernel panic.

                   

                   

                  -David

                   

                   

                   

                   

                   

                  • 6. Re: Fusion suddenly ignoring keyboard input
                    matthewls Hot Shot

                    I've had the same issue..sort of. I'm running xp32 pro in fusion, and in full-screen mode the keyboard started to "boink" and not deliver to the VM. When I switched to fusion mode the keyboard input worked. Returning to full screen broke it again. Single window mode also works.

                    Leopard, RC 61385. Didn't happen before in 1.0 and betas, but today was the first day I really pushed the mac (book pro).

                    • 7. Re: Fusion suddenly ignoring keyboard input
                      silliker Novice

                      Of course, if one needs to use ones VPN client to connect to resources needed for the VM, that's not a great solution. Is this issue being SecureInput issue being fixed?

                      • 8. Re: Fusion suddenly ignoring keyboard input
                        Keltia Novice

                        Considering that it took Checkpoint more than one year to build a Tiger-compatible of Secureclient after Tiger's release, I'm not holding my breath for that.  I don't have much more hope for a Leopard-compatible one either.  I think I'll move my Fusion to the other MBP I have. Bonus, it has now 3 GB instead of 2.

                        • 9. Re: Fusion suddenly ignoring keyboard input
                          Wolfsokta Lurker

                          Not useing SecureClient and Fusion at the same time really isn't an option. It seems it's not just SecureClient that is causing the issue but a feature of the OS that fusion can't handle if it's running. Are you working on a fix or workaround that will let us use Fusion while another app is using secure input?

                           

                          Thanks

                          • 10. Re: Fusion suddenly ignoring keyboard input
                            jempey Novice

                            Do you have an ETA for a fix for this issue?

                            • 11. Re: Fusion suddenly ignoring keyboard input
                              Designer72 Lurker

                              I just found a fix for my particular problem with the keyboard not working. I don't have SecureClient so I was really confused, so I just started disabling programs in OSX. I found that XHub was causing my keyboard to stop working. Once I disabled it everything worked fine. I hope this helps someone who was as frustrated as I was.

                              • 12. Re: Fusion suddenly ignoring keyboard input
                                BooCross Novice

                                I have a MacBoom Pro 17" Intel Dual Core 4 Gb running Leopard as well as Vista via Bootcamp. I load VM Fusion successfully into Leopard and select Vista from Bootcamp - Fusion starts correctly with no errors. I have the same problem, however - when Fusion loads Vista, the keyboard does not respond in the Fusion window. My MacBook Pro is brand new and there are no other programs running - unless they are some native processes to Leopard. I have no idea, as I new to MAC since 1 week having made the conversion from PCs.

                                Does anyone have any sggestions - please keep in mind that I am still new to the Mac system.

                                • 13. Re: Fusion suddenly ignoring keyboard input
                                  rcardona2k Champion

                                  There are some good tips for dealing with keyboard configuration, mostly for installing the VMware Tools in this thread Re: No mouse or keyboard on Mac Pro using Leopard and Fusion 1.1rc1

                                  • 14. Re: Fusion suddenly ignoring keyboard input
                                    RickyF Novice

                                     

                                    I am running Leopard (OS X 10.5.1) on a MacBook Pro 15". I found that XHUB created the same problems with VMware Fusion 1.1 where I had lost keyboard input in all Fusion client sessions. Quiting XHUB solved the problem.

                                     

                                     

                                    My thanks to the community for helping me solve this problem - quickly.

                                     

                                     

                                    1 2 Previous Next