7 Replies Latest reply on Mar 5, 2008 5:20 AM by Andy Burns

    Error "You do not have access rights to this file" - apparently caused by spaces in .vmx file name?

    Andy Burns Lurker

      I had an interesting problem over the weekend. I had been working on a VM several times last week. When I went to open it on Saturday, I got an error:

       

      Could not open virtual machine: I:\MOSS003 - OCT07 Base\Windows Server 2003 Enterprise Edition.vmx.

      You do not have access rights to this file

       

       

      Naturally, it struck me that a) I'm admin on my own machine, so privileges seems unlikely, and b) it had worked fine on Thursday. As I: is a USB hard disc, I copied the VM to my local drive, but the problem persisted.

       

       

      I made sure that permissions were the same for this VM and others - they were.

       

       

      I tried upgrading VMWare from 6.0.1 to 6.0.2, just on the off-chance - the problem persisted.

       

       

      I was trying to open the VM by double clicking on the  .vmx file. I tried opening the VM through the 'file open' dialog too - that didn't work either. In fact, that caused VMWare to crash. I've attached the support dump from that.

       

       

      In the end, one of my colleagues suggested removing all spaces in the VMX file name (based on this post: http://communities.vmware.com/message/716278#716278 ) - and that fixed it. If I put the spaces back into the VMX file name - errors again. The really weird thing is, though, that I have plenty of other virtual machines with spaces in the file name, and they seem to work just fine. Further, why did it work and then it start to raise errors when the file names hadn't changed?

       

       

      Sounds like a fairly daft bug. I'm not sure how to report this to Support, though - I don't want to open a support call (removing the spaces works for me) - but I'd like to alert development/quality control. Something isn't right there.

       

       

      Oh, I'm using VMWare workstation for Windows 6.0.2 on Vista