3 Replies Latest reply on Aug 5, 2008 5:33 PM by Puney

    Re-enable CD autoplay

    jakkan Enthusiast

      When I installed VMWare Workstation it disabled CD autoplay for me. How can I re-enable autoplay?

        • 1. Re: Re-enable CD autoplay
          ceolin Novice

          Double click on the My Computer icon on your Desktop until it opens.

           

          Then gently click on your CD / DVD Rom Drive just until it becomes highlighted.

           

          Then click on the word File, which is contained in your top tool bar area.

           

          This will pull down a menu for you to now click on Properties.

           

          Then click on the Auto Play tab at the top of the screen.

           

          You can adjust settings for Music CDs, Music Files, Pictures, Video Files and Mixed Content.

           

          Now select a multimedia types by using the pull down arrow to the right with your mouse.

           

          Then for each multimedia type, use your mouse to encircle the Select an action to perform: option.

           

          To disable that multimedia type, click on the Take no action icon at the bottom of the screen.

           

          Now click on the Apply button at the bottom of the screen to save your changes.

           

          Continue in the above fashion for each multimedia type, choosing the Take no action option.

           

          And ensure that you click on the Apply button at the bottom of the screen to save your changes.

           

          Once all options have been set, then click on OK button to exit the CD Drive Properties window.

           

          Repeat the above procedure on any additional CD Rom Drives you have in your system.

           

          Note: If you feel you have made a mistake, you can click on the Restore Defaults icon at any time.

          • 2. Re: Re-enable CD autoplay
            dave.english Hot Shot
            ceolin wrote:

            ...

            Then click on the Auto Play tab at the top of the screen.

             

            You can adjust settings for Music CDs, Music Files, Pictures, Video Files and Mixed Content.

            ...

            Continue in the above fashion for each multimedia type, choosing the Take no action option.

            ...

            Note: If you feel you have made a mistake, you can click on the Restore Defaults icon at any time.

             

            Thanks for the detailed description, it is obviously for how to disable autoplay, rather than to re-enable it - but we can no doubt all get the idea.

             

            However, I don't think that those settings are the ones that VMWare tends to disable.  I believe my machine had disc insertion disabled by VMware Server & I appear to have "Prompt me each time to choose an action", not "Take no action".

             

            I think that what the original poster needs is to re-enable autoinsert, rather than autoplay.  That is controlled by:

             

            HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun

             

            which needs to be returned to its default value of 0x91 or 0x95, mine is presently 0xff.

             

            It is described here:

             

            http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/93502.mspx

             

            which also describes other registry entries that can be involved.

             

            Also have a look at:

             

            HKEY_LOCAL_MACHINE\Systems\CurrentControlSet\Services\cdrom\AutoRun

             

            which should be 1

             

            I don't know of a GUI method of changing this (other than the registry editor) but apparently there is a downloadable "Autoplay Repair Wizard" which might help.

             

            http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en

             

            At the end of all this, I am assuming this is about Windows

            • 3. Re: Re-enable CD autoplay
              Puney Novice

               

              i seem to have this problem: 

               

               

              http://www.microsoft.com/windowsxp/expertzone/newsgroups/reader.mspx?dg=microsoft.public.virtualpc&tid=5f651fea-a974-4be0-810a-68ba393cdf65&cat=⟨=en&cr=US&sloc=&p=1

               

               

              Win Vista 32bit

               

               

              Basically it seems to disable my cdrom completely, its an LG, not sure what driver, but is caused by the default autoplay feature being disabled.

               

               

              When i try to reinable it via VMserver, upon restart of VMserver, enter my host admin user name, user name, password, which you would assume is the same for the win user name you are using + registration details...... it says it  can recognise host "Windows User" but has no text to support it as an admin.

               

               

              Naturally "Windows User" is the only profile i have set up. with most admin control... i still get warnings and permissions when installing.

               

               

              so is there a "vista" alternative to enabling autoplay cause i mucked around for a while and couldn't see how to, properties didn't seem to have the option.

               

               

              Additionally i doubt this works anyway, i did just find options for every type of cd,dvd in control panel and actions to take, but for some reason with the autoplay disabled it is reading every cd as blank and promting nero to reformat/burn.