11 Replies Latest reply on Oct 10, 2007 10:21 AM by jwnchoate

    unable to browse vmfs3 datastore from VC2

    jwnchoate Enthusiast

       

      I installed VC2 and am trying to browse the SAN to add a disk to a virtual machine.  I just get a blank when I choose the vmfs3 LUN.  No folders or disks can be seen.  I can see them from command line.

       

       

        • 1. Re: unable to browse vmfs3 datastore from VC2
          esiebert7625 Guru
          vExpert

          How are you trying to browse the vmfs volume? If you are in the VM settings and adding a disk you will only be able to choose a VMFS volume for the disk if you specify a data store, the default is to store the disk with the VM. You cannot specify a directory when you choose a data store, it automatically will create the directory and disk file.

           

           

           

           

          -=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

          Thanks, Eric

          Visit my website: http://vmware-land.com

          -=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

          • 2. Re: unable to browse vmfs3 datastore from VC2
            jwnchoate Enthusiast

            I see the /vmfs folder, I choose LUN1 which is my vmfs3 datastore where the vm is installed.  The disk I wish to add is in that folder as well.  I cant even see the folder to choose, nor can I see the .vmdk if its in the root of the LUN.  I am an administrator on the box so security wise I should be able to browse the datastore.  I can do everything else without restriction.

            • 3. Re: unable to browse vmfs3 datastore from VC2
              esiebert7625 Guru
              vExpert

              So are you selecting 'Browse Datastore' in the VI Client to browse the volume? If so and you are not seeing anything make sure you are using the same version of the VI Client as the VC Server.

               

               

               

               

              -=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

              Thanks, Eric

              Visit my website: http://vmware-land.com

              -=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

              • 4. Re: unable to browse vmfs3 datastore from VC2
                jwnchoate Enthusiast

                 

                its the VI Client off the CD on the Virtual Center Server itself.

                 

                 

                • 5. Re: unable to browse vmfs3 datastore from VC2
                  Tom Cronin Expert
                  vExpert

                  In the VI client do Help/About and make sure the server and client version numbers match.

                  • 6. Re: unable to browse vmfs3 datastore from VC2
                    jwnchoate Enthusiast

                    This is from the VC server, using the VC client that was on the CD. I am logged in as an administrator.

                     

                     

                     

                     

                     

                    http://communities.vmware.com/servlet/JiveServlet/downloadImage/1096/bds0.bmp

                     

                     

                    Here is what I get when I choose the vmfs3 LUN when I try to add an existing disk to my virtual machine. Security is default security setup. I have domain and local administrator rights and have been able to do everything at this point. ls -al shows root:root on all the files in the LUN. The VM was migrated from a VI system, the disk was upgraded to vmfs3, hardware was upgraded to vmw3 and the tools have been updated.

                     

                     

                     

                     

                    I was looking around after posting a reply and I found this.  Can anyone tell me why the LUN looks full?   it shows negative space and the space is all used.  That is not true.

                     

                     

                    • 7. Re: unable to browse vmfs3 datastore from VC2
                      Tom Cronin Expert
                      vExpert

                       

                      Ok, basics.  What is your san hardware?  Are you sure that all luns are presented to all hosts with the same lun number?

                       

                       

                      Try also restarting the management agents on the host:

                       

                       

                      service mgmt-vmware restart

                      service vmware-vpxa restart

                       

                       

                       

                       

                       

                      1 person found this helpful
                      • 8. Re: unable to browse vmfs3 datastore from VC2
                        jwnchoate Enthusiast

                        HP MSA1500, I have 2 LUNs and all are presented to the vmware system. LUN0 is vmfs2 with older vm's, LUN1 is upgraded from vmfs2 to vmfs3. There is one single migrated VM from the vm2 world, and I am in process of upgrading the entire system to VI3. SHOW CONNECTIONS will show all the hosts connected and online. SHOW ACL says its not configured.

                         

                         

                         

                         

                         

                        When I restart the services, I actually get the real usage numbers for a brief period, then I will refresh or try to browse the lun and the 'disk full' numbers reappear. I am betting that this might be related to my problem. I can start and stop the migrated vm just fine.

                         

                         

                        I continue to look over the settings for anomalies.

                         

                         

                        FYI, I can select create a new disk and it will create the new disk on the LUN without error and add it to the vm.  I can go to cli and find it in the proper spot, but I wont see that from browse datastore.  I would think if I can see the files from the host, format the lun to vmfs3 and start virtual machines and run them without a problem that my SAN should be configured correctly. 

                         

                         

                        If this helps, I can try to add a disk to a VI2 vm on a VI2 host and when I try to browse a vmfs2 LUN to a VI2 host it will lock up the client and I have to kill VI client.

                        • 9. Re: unable to browse vmfs3 datastore from VC2
                          Tom Cronin Expert
                          vExpert

                          Are you sure the luns are presented to all hosts with the same lun number?

                          • 10. Re: unable to browse vmfs3 datastore from VC2
                            jwnchoate Enthusiast

                            yes, all hosts see the lun exactly the same vmhba1:0:2 LUN ID2

                             

                            fyi, i can add a new disk to local vmfs3 storage and browse the LUN.

                             

                             

                             

                             

                             

                            Also, from the esx2 servers, naturaally the new vmfs3 lun will not be readable.  Should I remove the connection to LUN1 from the esx 2 boxes or will that foul up my future migrations?

                            • 11. Re: unable to browse vmfs3 datastore from VC2
                              jwnchoate Enthusiast

                              I got this resolved!

                               

                               

                               

                               

                               

                              I noticed in 'Inventory/Datastores/LUN1/hosts' tab that 2 of the 3 esx2 servers still were listed as using the lun but not my second host who listed the LUN as 'unformatted'. I had already looked at each host and made sure nobody was using anything on lun1 last week because links to cd's or floppys would show that connection. Well it dawned on me that esx2 was monkeyed with last weekend and I had to reboot several times and rescan the SAN and since it wasnt on the list there had to be something with those hosts.

                               

                               

                              I went to the other 2 esx2 version hosts and rescanned the SAN. It changed LUN1's reference on each of those from 'vmfs2 volume' to unformatted volume and now I can browse the disk system!

                               

                               

                               

                               

                               

                              PS thx for the help...ill give you an assist for your prompt replies.