14 Replies Latest reply on Sep 6, 2017 7:00 PM by jimsy1

    no ethernet driver inside guest Windows XP OS

    thegambit Lurker

      I've searched for this inside kb to no avail.  I am running a Mac Pro with Vmware Fusion and Windows XP as the guest OS.  When Windows boots it finds an ethernet controller, but can't seem to locate a driver for it.  When I attempt to install vmware tools it starts normally then when "preparing for install" I get a message saying it cannot continue because Windows is either in safe mode or the Windows Installer is not properly installed.  The message says it cannot access the Windows Installer Service.  The windows installer I replaced with the latest one from Microsoft, 3.1 and Windows is not booted into safe mode.  Any thoughts?

        • 1. Re: no ethernet driver inside guest Windows XP OS
          thegambit Lurker

          Ok.  Managed to fix one issue.  I was able to successfully install Vmware Tools on the host machine.  However when rebooted Windows still has no driver available for the Ethernet controller.

          • 2. Re: no ethernet driver inside guest Windows XP OS
            rcardona2k Champion

            Check to make sure your VM has a virtual network adapter configured under Virtual Machine > Settings > Removable Devices > Network.  The virtual network card should be "connected".  If there are no network adapters, you have to shutdown Windows XP and add one under Removable Devices by clicking on the + on the lower left of that screen, choose Add Network...

             

            Next, in Windows XP try opening the Device Manager (Start > Run > devmgmt.msc), look under Network Adapters and see if you have any listed.  If there are none, go to View > Show Hidden devices to be thorough.  If you see any devices with a yellow mark (?) or any starting with "VMware ..." delete them.  Don't delete anything else.  Next run Action > Scan for hardware changes.  WIth the VMware Tools installed, it should find your virtual network adapter and install it successfully.

            • 3. Re: no ethernet driver inside guest Windows XP OS
              j8zzyb3ll5 Lurker

              I realize this isn't quite the right place to be posting this, but I figured you might be able to help (I've got the same problem as the person above me). I'm running Ubuntu 8.04 as a host with Win XP Pro as the guest with VMware Server 2.0 Release Candidate 2. I followed the instructions you gave but windows is still unable to find the applicable ethernet drivers. I have vmware tools installed and mounted. Any suggestions?

              • 4. Re: no ethernet driver inside guest Windows XP OS
                WoodyZ Guru

                Considering this is the Fusion Forum and your Host is not an Intel Based Mac running OS X or running Fusion you're not in the right place!

                 

                If you're using VMware Server 2.0 Release Candidate 2 try posting over in the VMware Server Forum

                • 5. Re: no ethernet driver inside guest Windows XP OS
                  KLeach Novice

                   

                  I have this exact same issue... even with the tools installed the driver will no work inside XP.

                   

                   

                  I am running 2.0

                   

                   

                  Is there another driver I can try?  even when I point the driver installer to the exact location of the files it will not take..

                   

                   

                  It is like the nic does not have a name and can not be matched to the driver??? sounds weird I know..

                   

                   

                  I have tried everything and just need a working driver....

                   

                   

                   

                   

                   

                  ANY help would be great.. thanks

                   

                   

                   

                   

                   

                  -Ken

                   

                   

                  • 6. Re: no ethernet driver inside guest Windows XP OS
                    Technogeezer Expert

                    When you configured your virtual machine, what type of operating system did you choose, and what version of Windows XP did you install (including whether it's 32- or 64-bit). Sometimes the virtual machine type does matter, and influences the types of emulated hardware available to the VM.  For example, the virtual machine type for a 64-bit Windows XP Professional install should be "Windows XP Professional x64 Edition" not "Windows XP Professional".

                     

                    If you could also post a copy of your VM's vmx file, that might help us.

                    • 7. Re: no ethernet driver inside guest Windows XP OS
                      earukan Novice

                       

                      Hi,

                       

                       

                      I have also ran into the exact same issue, was anybody able to solve this problem, NIC not getting detected in Windows guest OS ?

                       

                       

                      FYI, this is my vmx file

                       

                       

                      #!/usr/bin/vmplayer

                      .encoding = "windows-1252"

                       

                      1. Filename: WindowsXP.vmx

                      2. Generated 2008-12-10;08:42:41 by EasyVMX! 2.0 (beta)

                      3. http://www.easyvmx.com

                       

                      1. This is a Workstation 6 config file

                      2. It can be used with Player

                      config.version = "8"

                      virtualHW.version = "6"

                       

                      1. Selected operating system for your virtual machine

                      guestOS = "winvista"

                       

                      1. displayName is your own name for the virtual machine

                      displayName = "WindowsXP"

                       

                      1. These fields are free text description fields

                      guestinfo.vmware.product.url = "http://www.easyvmx.com/"

                      guestinfo.vmware.product.class = "virtual machine"

                       

                      1. Number of virtual CPUs. Your virtual machine will not

                      2. work if this number is higher than the number of your physical CPUs

                      numvcpus = "2"

                       

                      1. Memory size and other memory settings

                      memsize = "512"

                      MemAllowAutoScaleDown = "FALSE"

                      MemTrimRate = "-1"

                       

                      1. PowerOn/Off options

                      gui.powerOnAtStartup = "FALSE"

                      gui.fullScreenAtPowerOn = "FALSE"

                      gui.exitAtPowerOff = "FALSE"

                       

                      1. Unique ID for the virtual machine will be created

                      uuid.action = "create"

                       

                      1. Settings for VMware Tools

                      tools.remindInstall = "FALSE"

                      tools.upgrade.policy = "upgradeAtPowerCycle"

                       

                      1. Startup hints interfers with automatic startup of a virtual machine

                      2. This setting has no effect in VMware Player

                      hints.hideAll = "TRUE"

                       

                      1. Enable time synchronization between computer

                      2. and virtual machine

                      tools.syncTime = "TRUE"

                       

                      1. USB settings

                      2. This config activates USB

                      usb.present = "TRUE"

                      usb.generic.autoconnect = "FALSE"

                       

                      1. First serial port, physical COM1 is available

                      serial0.present = "TRUE"

                      serial0.fileName = "Auto Detect"

                      serial0.autodetect = "TRUE"

                      serial0.hardwareFlowControl = "TRUE"

                       

                      1. Optional second serial port, physical COM2 is not available

                      serial1.present = "FALSE"

                       

                      1. First parallell port, physical LPT1 is available

                      parallel0.present = "TRUE"

                      parallel0.fileName = "Auto Detect"

                      parallel0.autodetect = "TRUE"

                      parallel0.bidirectional = "TRUE"

                       

                      1. Sound settings

                      sound.present = "TRUE"

                      sound.fileName = "-1"

                      sound.autodetect = "TRUE"

                       

                      1. Logging

                      2. This config activates logging, and keeps last log

                      logging = "TRUE"

                      log.fileName = "WindowsXP.log"

                      log.append = "TRUE"

                      log.keepOld = "3"

                       

                      1. These settings decides interaction between your

                      2. computer and the virtual machine

                      isolation.tools.hgfs.disable = "FALSE"

                      isolation.tools.dnd.disable = "FALSE"

                      isolation.tools.copy.enable = "TRUE"

                      isolation.tools.paste.enabled = "TRUE"

                       

                      1. Other default settings

                      svga.autodetect = "TRUE"

                      mks.keyboardFilter = "allow"

                      snapshot.action = "autoCommit"

                       

                      1. First network interface card

                      ethernet0.present = "TRUE"

                      ethernet0.virtualDev = "e1000"

                      ethernet0.connectionType = "bridged"

                      ethernet0.addressType = "generated"

                      ethernet0.generatedAddressOffset = "0"

                       

                      1. Settings for physical floppy drive

                      floppy0.present = "FALSE"

                       

                      1. Settings for physical CDROM drive

                      ide1:0.present = "TRUE"

                      ide1:0.deviceType = "cdrom-image"

                      ide1:0.startConnected = "TRUE"

                      ide1:0.fileName = "C:\Users\earukan\Downloads\Windows XP Professional SP3\VRMPVOL_EN.iso"

                      ide1:0.autodetect = "TRUE"

                       

                      1. Settings for the optional virtual CDROM, ISO-image

                      ide1:1.present = "TRUE"

                      ide1:1.fileName = "F:"

                      ide1:1.deviceType = "cdrom-raw"

                      ide1:1.mode = "persistent"

                      ide1:1.startConnected = "FALSE"

                       

                      1. LsiLogic SCSI card

                      scsi0.present = "TRUE"

                      scsi0.virtualDev = "lsilogic"

                       

                      1. First IDE disk, size 4800Mb

                      ide0:0.present = "TRUE"

                      ide0:0.fileName = "WindowsXP.vmdk"

                      ide0:0.mode = "persistent"

                      ide0:0.startConnected = "TRUE"

                      ide0:0.writeThrough = "TRUE"

                       

                      1. Second SCSI disk image, size 3Gb

                      scsi0:1.present = "TRUE"

                      scsi0:1.fileName = "WindowsXP-2.vmdk"

                      scsi0:1.mode = "persistent"

                      scsi0:1.startConnected = "TRUE"

                      scsi0:1.writeThrough = "TRUE"

                       

                      1. END OF EasyVMX! CONFIG

                       

                      extendedConfigFile = "WindowsXP.vmxf"

                       

                      virtualHW.productCompatibility = "hosted"

                       

                      ethernet0.generatedAddress = "00:0c:29:c0:e2:2a"

                      uuid.location = "56 4d dc 18 bd 7a 30 d2-3c ba 2b 2f a8 c0 e2 2a"

                      uuid.bios = "56 4d dc 18 bd 7a 30 d2-3c ba 2b 2f a8 c0 e2 2a"

                      ide0:0.redo = ""

                      scsi0:1.redo = ""

                      vmotion.checkpointFBSize = "16777216"

                      scsi0.pciSlotNumber = "16"

                      ethernet0.pciSlotNumber = "17"

                      sound.pciSlotNumber = "18"

                       

                      hgfs.mapRootShare = "TRUE"

                       

                       

                       

                      • 8. Re: no ethernet driver inside guest Windows XP OS
                        Technogeezer Expert

                        Two deviations I see from a Fusion (or even Workstation) created vmx file that may be relevant:

                         

                        The guestOS string should read "winxppro", not "winvista"

                         

                        The emulated network card for XP in a Fusion-created VM is an AMD pcnet NIC (indicated by the absence of an ethernetx.virtualDev entry), not an Intel e1000. I'm not sure if XP has a native e1000 driver.

                         

                        Shut down the VM, exit Fusion, and edit the vmx.file. Change the guestOS string and remove or comment out the line containing ethernet0.virtualDev, and restart Fusion and your VM. See if you can now configure your network.

                        • 9. Re: no ethernet driver inside guest Windows XP OS
                          KLeach Novice

                           

                          That was it!!

                           

                           

                          Fat fingered the dropdown to select theOS when I built the VM..never noticed...

                           

                           

                          I rebuilt with the proper OS chosen and amazingly everything worked once I installed the tools..

                           

                           

                           

                           

                           

                          Thanks... I needed another pair of eyes..

                           

                           

                           

                           

                           

                          -Ken

                           

                           

                          • 10. Re: no ethernet driver inside guest Windows XP OS
                            earukan Novice

                             

                            hi guys,

                             

                             

                            great work, thanks alot, the commenting out the e1000 driver worked for me...tks heaps for the hint

                             

                             

                            keep in touch..I will come back with more Qs

                             

                             

                            cheers

                             

                             

                            • 11. Re: no ethernet driver inside guest Windows XP OS
                              texnguy Novice

                              Cheers to those with the helpful ideas. I know the post is old, but still highly relevant. I installed WinXPPro-64 for my OS, and I was unable to get my NIC working either. The removal of the e1000 device was my cure.

                              • 12. Re: no ethernet driver inside guest Windows XP OS
                                Stephen_on_The_Grid Novice

                                I cant get the nic to show up in xp.  I removed the e1000 line but still no go.  Here is my VMX file:

                                 

                                Any help is appreciated.

                                 

                                ---

                                .encoding = "windows-1252"
                                config.version = "8"
                                virtualHW.version = "9"
                                scsi0.present = "TRUE"
                                scsi0.virtualDev = "lsisas1068"
                                memsize = "1024"
                                mem.hotadd = "TRUE"
                                ide0:0.present = "TRUE"
                                ide0:0.fileName = "WinXP.vmdk"
                                ide1:0.present = "TRUE"
                                ide1:0.fileName = "c:\rt.iso"
                                ide1:0.deviceType = "cdrom-image"
                                floppy0.startConnected = "FALSE"
                                floppy0.fileName = ""
                                floppy0.autodetect = "TRUE"
                                ethernet0.present = "TRUE"
                                ethernet0.connectionType = "nat"
                                ethernet0.wakeOnPcktRcv = "FALSE"
                                ethernet0.addressType = "static"
                                usb.present = "TRUE"
                                ehci.present = "TRUE"
                                ehci.pciSlotNumber = "35"
                                sound.present = "TRUE"
                                sound.virtualDev = "hdaudio"
                                sound.fileName = "-1"
                                sound.autodetect = "TRUE"
                                mks.enable3d = "TRUE"
                                serial0.present = "TRUE"
                                serial0.fileType = "thinprint"
                                pciBridge0.present = "TRUE"
                                pciBridge4.present = "TRUE"
                                pciBridge4.virtualDev = "pcieRootPort"
                                pciBridge4.functions = "8"
                                pciBridge5.present = "TRUE"
                                pciBridge5.virtualDev = "pcieRootPort"
                                pciBridge5.functions = "8"
                                pciBridge6.present = "TRUE"
                                pciBridge6.virtualDev = "pcieRootPort"
                                pciBridge6.functions = "8"
                                pciBridge7.present = "TRUE"
                                pciBridge7.virtualDev = "pcieRootPort"
                                pciBridge7.functions = "8"
                                vmci0.present = "TRUE"
                                hpet0.present = "TRUE"
                                usb.vbluetooth.startConnected = "TRUE"
                                displayName = "WinXP"
                                guestOS = "winxppro"
                                nvram = "WinXP.nvram"
                                virtualHW.productCompatibility = "hosted"
                                gui.exitOnCLIHLT = "FALSE"
                                powerType.powerOff = "hard"
                                powerType.powerOn = "hard"
                                powerType.suspend = "hard"
                                powerType.reset = "hard"
                                extendedConfigFile = "WinXP.vmxf"
                                scsi0.pciSlotNumber = "160"
                                ethernet0.pciSlotNumber = "33"
                                usb.pciSlotNumber = "32"
                                sound.pciSlotNumber = "34"
                                vmci0.id = "-1970804028"
                                vmci0.pciSlotNumber = "36"
                                uuid.location = "56 4d ae d6 55 c2 46 10-76 26 e1 7e 8a 87 ea c4"
                                uuid.bios = "56 4d ae d6 55 c2 46 10-76 26 e1 7e 8a 87 ea c4"
                                cleanShutdown = "FALSE"
                                replay.supported = "FALSE"
                                replay.filename = ""
                                scsi0:0.redo = ""
                                pciBridge0.pciSlotNumber = "17"
                                pciBridge4.pciSlotNumber = "21"
                                pciBridge5.pciSlotNumber = "22"
                                pciBridge6.pciSlotNumber = "23"
                                pciBridge7.pciSlotNumber = "24"
                                scsi0.sasWWID = "50 05 05 66 55 c2 46 10"
                                usb:1.present = "TRUE"
                                ethernet0.generatedAddressOffset = "0"
                                tools.remindInstall = "TRUE"
                                vmotion.checkpointFBSize = "134217728"
                                softPowerOff = "FALSE"
                                usb:1.speed = "2"
                                usb:1.deviceType = "hub"
                                usb:1.port = "1"
                                usb:1.parent = "-1"
                                bios.bootDelay = "10000"
                                tools.syncTime = "FALSE"
                                ide0:0.redo = ""
                                ide1:0.startConnected = "TRUE"
                                ethernet0.linkStatePropagation.enable = "FALSE"
                                unity.wasCapable = "FALSE"
                                ethernet0.address = "00:50:56:24:54:F8"
                                sound.startConnected = "FALSE"
                                usb:0.present = "TRUE"
                                usb:0.deviceType = "hid"
                                usb:0.port = "0"
                                usb:0.parent = "-1"

                                • 13. Re: no ethernet driver inside guest Windows XP OS
                                  Stephen_on_The_Grid Novice

                                  never mind I removed the e1000 line in the VMX, allowed the NIC in the guest os to detect a driver.  works.....

                                  • 14. Re: no ethernet driver inside guest Windows XP OS
                                    jimsy1 Novice

                                    how do i get this really annoying stuff working in 2017 and version 12.5.7???? (win7 vmware player)

                                    it just shows that Ethernet Controller is not installed and does not even show how to install it