14 Replies Latest reply on Oct 4, 2007 4:20 AM by Luciano Patrao

    Install VMOTION

    Luciano Patrao Hot Shot
    vExpert

      Hi

       

      I have two VMware servers whith Dell PowerEdge 1950, and i want to use HA and/or DRS

      The VMware are working just fine, but i need to install the VMotion

      I have enabled the vmotion licence, and is ok. But adding the VMKernel to use vmotion is where I need some help

      My vmware server's ip are 192.68.0.1 and 192.168.0.2, and my Virtual Center is 192.168.0.3

       

      I have 6 adapters in each vmware server. Five adapters i am using for the VM in connecting to the local network. In my adapter nr 6 I use for Service Console. I have added the VMKernel vmotion on this adapter, with a different IP and LUN ID.

       

      I have created this for both vmware servers. In one I have give to VMKernel IP 192.168.04 and for the other 192.168.0.5

       

      My question is, is this the correct way to do it? Must I use a single adapter for each vmotion? And can I use the HBA port to use this?? Or not?

       

      Thank you for the help

       

      Jail

        • 1. Re: Install VMOTION
          sbeaver Guru
          User ModeratorsvExpert

          That is the correct way to do that.  For me I have 2 NICS in a bond for the ServiceConsole and Vmotion.  You must use ethernet for vmotion

          • 2. Re: Install VMOTION
            Luciano Patrao Hot Shot
            vExpert

            Hi

             

            Thank you for the reply

             

            This forum is impossible to read/write today

             

            Yes i have my vmkernel(with vmotion) enable with the adapter that i use for the Service Console. Is your opinion that i use a adapter for each service?

             

            Another question is, must my storage be shared between the hosts? I have create 2 storage(one for the VM HD System Operation, and another for VM HD Data Files) for each host, but host 1 do not see the storage from the host 2. Is this a problem to work with automatic vmotion?

             

            Thank you

             

            Jai

            • 3. Re: Install VMOTION
              sbeaver Guru
              vExpertUser Moderators

              Everything must be exactly the same between all ESX servers in a cluster.  They must see all the same things especially in Storage.

              • 4. Re: Install VMOTION
                Luciano Patrao Hot Shot
                vExpert

                 

                Hi again

                 

                 

                Yes that is problem to me

                 

                 

                Because i have already some LUN alocated to host 1 and LUN alocated to HOST 2, and if change from HOST 1 to HOST 2 in my storage(EMC) i will loose the information in the LUNs

                 

                 

                Is there any other option?

                 

                 

                Thank You for the help

                 

                 

                Jail

                 

                 

                • 5. Re: Install VMOTION
                  sbeaver Guru
                  vExpertUser Moderators

                  You should have all ESX servers seeing all the same LUNS.  ESX is designed to do this and I have 7 ESX servers all seeing the same 25 LUNS.  This is how ESX is designed to work.  On the EMC side change all the masking and zoning to be the same.

                   

                  Steve

                  • 6. Re: Install VMOTION
                    Luciano Patrao Hot Shot
                    vExpert

                     

                    Hi

                     

                     

                    Yes i must change the LUNs from one RAID Grou(that is connected to an vmware host) to another RAID Group. But if change this i will damage and erase the LUNs. And i have allready Virtual Servers in production in this vmware servers.

                     

                     

                    In the EMC when i try to move i get this:

                     

                     

                    "VMWARE-HOST1:  This host is already connected to a different storage group. Connecting it to the current storage group will cause it to be disconnected from the other storage group. This will cause the host to be unable to access the LUNs that are within the other storage group."

                     

                     

                    So i will not risk changing this and have my vm erased.

                     

                     

                    Do i have another option?

                     

                     

                    Jail

                     

                     

                    • 7. Re: Install VMOTION
                      sbeaver Guru
                      vExpertUser Moderators

                      Best thing I can say before you really try to do anything is get a good backup

                      • 8. Re: Install VMOTION
                        Luciano Patrao Hot Shot
                        vExpert

                         

                        Hi

                         

                         

                        Yes that is always the first thing to do.

                         

                         

                        The problem is that i do not have yet my ML6010 working.

                         

                         

                        I think i will try to move the VM from one storage to another, and then move the storage, or create a new one for the same host.

                         

                         

                        I think i will create a RAID Group connected to both hosts and give the LUN to this Group

                         

                         

                        Jail

                         

                         

                        • 9. Re: Install VMOTION
                          sbeaver Guru
                          vExpertUser Moderators

                          If you have the space then that sounds like a good idea

                          • 10. Re: Install VMOTION
                            GiriRaju Lurker

                            You need to configure VMotion dedicated network before you proceed. also make sure your resources are configured correctly.

                            • 11. Re: Install VMOTION
                              aharkin Novice

                               

                              While I would definitely suggest grabbing a backup first, I think you're probably misreading the message you're getting on the EMC side of things.  You should be moving the LUNs between Storage Groups, not Raid Groups.  You can't really move a LUN between Raid groups, other than I suppose destroying it and recreating a new LUN with the same LUN ID.  What you're going to want to do is get all of your ESX hosts and all of the LUNs in the same storage group.  This will allow all of the hosts to see all of the LUNs, and should not lose any of the data on them.  By should, I mean that I've been doing storage management for years, and have never once seen changing storage groups result in a loss of data on the LUN on an EMC array.  That doesn't stop me from backing the stuff up first, though, that's always the best idea, no matter how sure you are of yourself.

                               

                               

                              All that said, there is some pretty heavy documentation out on the VMWare support section centered around how to configure multiple ESX hosts with a SAN back-end, and I think you would be well served to go read through it until you get a solid understanding of the why and how of what you're setting up.  EMC is pretty unforgiving when it comes to their array interfaces, and if you don't have a plan down, you're more than likely going to cause yourself more issues than you'll fix.

                               

                               

                              I'm guessing that might not be quite the answer you're looking for, but I honestly think you'd be better served by understanding how the back end works so you can leverage that knowledge into a better setup than if you got the exact steps to set it up but didn't really understand it.

                               

                               

                              1 person found this helpful
                              • 12. Re: Install VMOTION
                                Luciano Patrao Hot Shot
                                vExpert

                                Hi aharkin

                                 

                                I have moved my VM to Storage and after that i try your option, and yes I can move LUNs between hosts in the EMC Manager Console.

                                And the LUN has not been destroyed, but after I add the vmware 2 host to that Storage Group all is ok no problem until then.

                                But when I try to use any of the LUN(that I moved) in my vmware(host 1 or 2) add storage, I cannot see the LUN. Now in vmware 2 I can see the LUNs that are allocated to vmware 1, but I cannot use this, because if I add storage, and add a Disk Lun it will be destroy. And of course I cannot add this.

                                 

                                To add(and share) the storage between the vmware servers, must I add as a Netwrok

                                 

                                And if I go to my EMC Manager I see that this LUNs(that I moved) don’t have a ID, so the vmware cant find. I have update host, I have update the RAID etc., and nothing worked. I give up, and destroy the LUNs and create another. But after I create new LUNs I see that I have the same problem.

                                 

                                Any Ideas?

                                 

                                Thank You

                                 

                                JailBreak

                                • 13. Re: Install VMOTION
                                  Luciano Patrao Hot Shot
                                  vExpert

                                  Hi again

                                   

                                  OK my mistake.

                                   

                                  I forget to rescan the Storage Adapters to see all the LUNs in the vmware.

                                   

                                  After I rescan the Stora Adapters I see all the LUNs in both vmware servers.

                                   

                                  Thank you both for the help.

                                   

                                  JailBreak

                                  • 14. Re: Install VMOTION
                                    Luciano Patrao Hot Shot
                                    vExpert

                                    Hi

                                     

                                    After i change and reconnect all the Host to all the LUNs i have a problem.

                                     

                                    First let me explain what I have done.

                                     

                                    In the EMC I have add the host 2 to the Storage Group. Now in this Storage Group I have both hosts. And in the Storage group I have 4 LUNs. Two for the Host 1, and another two for the Host 2. All hosts see all the LUNs. In the Data Center(Cluster) I can create a VM in 2 of the LUNs with no problem(this LUN is the original LUNs, the other two are new). I tested several ways, and have no problem. But if I use the other two off the LUNs(is a LUN that I use for the Host 2 to hold VM System Operation Disk, and Data Disks), and I get an error"a specified parameter was no correct".

                                     

                                    All the times I use this LUN I get this error"a specified parameter was no correct".

                                     

                                    I have created a Resource Pool, and add all the VM to it, just to separate my infrastructure, and still get the error.

                                     

                                    In the console(Linux) VMware Server I can create, write, delete any think to this LUN, but from the Virtual Center I get this error.

                                     

                                    Any one as any idea what is the problem?

                                     

                                    Thank You

                                     

                                    Jail