1 2 3 Previous Next 67 Replies Latest reply on Jul 22, 2009 3:52 PM by sgsax

    Workstation 6 under Linux, Xorg 7.3 Keyboard

    dweigert Lurker

       

      Hello folks,

       

       

      I'm running Workstation 6 64 bit under Gentoo Linux.  Recently the Xorg 7.3 release happened and after install, I started experiencing the following:

       

       

      1) as long as I don't enter fullscreen mode, all is well.

       

       

      2) once fullscreen mode is entered, when I switch back to the Linux desktop, the shift, control, and capslock keys no longer function.  Nothing will get this back to normal, short of restarting X.  xev shows key presses and releases as normal.

       

       

      I'm not sure if this is due to the API change in the latest version of X, or if it is a bug in X.

       

       

      Has anyone run itnto this, or have a workaround?

       

       

       

       

       

      Dan

       

       

        • 1. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
          jra_vm Novice

           

          Hello,

           

           

          I have the exact same problem. I'm using VMware 6 Workstation for Linux (Debian GNU/Linux 4.0) and VMware Server Console 1.0.3 and 1.0.4 for Linux (same host operating system).

           

           

          Since the update to X.Org 7.3, my keyboard is gone crazy every time I go fullscreen in VMware!

           

           

          May we expect to see a VMware update for this issue?

           

           

           

           

           

          Thank you

           

           

          • 2. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
            Sillern Lurker

             

            Hi.

             

             

            I'm having the same problem, and as you say, the only remedy is to restart X, which is a bit too cumbersome.

             

             

            I'm running VMware Server 1.0.4 build-56528 on Gentoo x86_64, on Xorg 7.2.

             

             

            I noticed the problem when I updated vmware.

            • 3. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
              mrenouf Lurker

               

              Hi guys,

               

               

              I ran into the same issue. Ubuntu 7.10 (Gutsy Gibbon). Xorg 7.3 I beleive as well...

               

               

              Are you using the default "Ctrl-Alt" escape sequence to ungrab the keyboard?

               

               

              I haven't completely solved this issue, but I have noticed that when this happens, my default keyboard layout has been switched to "Generic 105-key International" (on Ubuntu: System->Preferences->Keyboard, Layouts tab)

               

               

              You will sometimes need to press "Reset to Defaults" to refresh the setting because the applet will not notice it's been changed.

               

               

              Anyway, selecting either "Evdev-managed keyboard" or "Generic 104-key PC" fixes it again.

               

               

              I don't think this is related to VMware. As a test. you can reproduce the problem by just pressing "Ctrl-Alt", then click "Reset to defaults" and notice the problem is back and the layout has again switched "Generic 105-key PC Intl". 

               

               

              • 4. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                thewalrus Lurker

                I have a separate, but perhaps related keyboard issue.  I am running Gentoo on x86 (32-bit) with xorg 7.3 and VMware Workstation 6.0.2.  I am a fast typist, and when I type into a virtual machine, the many key presses are swapped.  Interestingly, for a given word, it is always the same mutation.  Example:  I type 'report' and it gets consistently mutated to 'rperot'--the 'ep' and 'or' in the middle of the word are swapped.  Anyone have any ideas?

                • 5. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                  jra_vm Novice

                  Le Wed, 28 Nov 2007, thewalrus <communities-emailer@vmware.com> a dit:

                  I have a separate, but perhaps related keyboard issue.  I am running 

                  Gentoo on x86 (32-bit) with xorg 7.3 and VMware Workstation 6.0.2.  

                  I am a fast typist, and when I type into a virtual machine, the 

                  many  key presses are swapped.  Interestingly, for a given word, it 

                  is  always the same mutation.  Example:  I type 'report' and it gets 

                  consistently mutated to 'rperot'--the 'ep' and 'or' in the middle 

                  of  the word are swapped.  Anyone have any ideas?I noticed that it only happens when I enter full-screen in VMware 

                  (Workstation 6.x or VMware Server 1.x, this was not tested on other 

                  versions) using the key combination (CTRLALTENTER or whatever I 

                  changed it for).

                  If I use the GUI button for "Fullscreen", nothing unusual happens to 

                  my keyboard.

                   

                  Anyway, when the keyboard map is ****** up, I only have to use 

                  "setxkbmap" to restore it:

                  setxkbmap -rules xorg -layout "fr" -model thinkpad

                   

                  I tried to use several different layouts and models before entering 

                  full-screen mode, and everytime the same thing happened with the 

                  keyboard.

                   

                  I'm using Debian GNU/Linux 4.1 (sid) on my Laptop (IBM T41).

                   

                  Oh and, on my desktop computer, I'm using Ubuntu 7.10 and everything 

                  works fine, although I have the exact same configuration...

                  • 6. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                    daedius Novice

                    Wow, glad I found this thread.  Thought I was losing my mind!  So the current fix is to just not go into fullscreen mode?

                    • 7. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                      webograph Lurker

                      same happens to me with 6.0.3-80004 on ubuntu hardy beta. the control key locks up at the moment ctrl-alt-return is used to escape from fullscreen mode (ctrl-alt-return is safe for entering full screen, as is using ctrl-alt to ungrab the input or using the bar at the top to leave full screen).

                       

                      moreover, when i press the ctrl key after having left full screen with ctrl-alt-return, the currently focused application dies (tested for nautilus and gnome-terminal).

                       

                      the setxkbmap fix does not work for me.

                       

                      this looks very much like a bug in vmware and should be fixed!

                      • 8. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                        jra_vm Novice

                        Ok, I'm glad some people are continuing this thread

                         

                        My "fix" as you call it is only temporary, and should be applied every time the problem pops out. So it's not really a fix...

                        As I said in my previous message, this problem doesn't happen on my Ubuntu 7.10 computer.

                         

                        I use VMware Workstation 6.02 on this computer, and VMware-server-console 1.05.

                         

                        I'm going to make a diff of every configuration file I have on my Ubuntu system with the files on my Debian laptop, where the bug still happens despite several updates, either of VMware products, or libraries and programs (including the X.Org server).

                         

                        I'll keep you updated and I really hope to find a solution.

                         

                        Note: a workmate is having exactly the same issue on his T60 laptop, with an Intel graphics adapter (I have a radeon mobility 7500 in mine, using the free "radeon" driver). We are going to find this out

                         

                        Note 2 : it happens sometimes when I'm not using the full-screen mode, but juste making copy/paste or installing the VMware tools... could be a lead!

                        • 9. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                          daedius Novice

                           

                          Thanks for your effort jra_vm ! Looking forward to what you have to say.  This bug has been annoying me so much on VMWare Linux.  As more and more distros upgrade to 7.3, this problem will only become larger.  I implore VMware to pay attention to this thread before you have more than a handful of us complaining.

                           

                           

                          - Daedius

                           

                           

                          • 10. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                            thool Novice

                             

                            Just to keep the thread alive :-)..

                             

                             

                            I've got the exact same problem and I've runned VMware on hosts Arch x64 and Xubuntu x64.

                             

                             

                            Would really like this to be solved.

                             

                             

                            BR

                             

                             

                            //thool

                             

                             

                            • 11. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                              dhurst Lurker

                                Well, on a Gateway laptop using the Kubuntu Hardy Beta and VMplayer 2.03, I found that I had the problem every time just like everyone else.  However, after using the KDE System Settings tools to turn on in Language and Regional settings in the keyboard layout area the specific layout that I use, which is the US english pc104, that the problem went away.  I can go fullscreen with the player and minimize and return back and my Linux host keymap is no longer switching to the pc105.

                              • 12. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                                mattskr Lurker

                                I installed VMWare Workstation onto a fresh install of Ubuntu 8.04 Hardy (64-bit final release) and am experiencing the same problem. Just to let people know that the problem has not been fixed with either an update to Hardy or Workstation. It is very annoying, but I have not checked the keyboard settings. If it is as simple as setting it back to to the proper layout at least I can live with that until a fix is released. Restarting X after leaving fullscreen is not acceptable!

                                • 13. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                                  pondo Lurker

                                   

                                  Same problem with VMWare Server 1.0.5 under Ubuntu 8.04. I even tried to reinstall the whole machine again but the only thing that happened was that  I could reproduce this problem.

                                   

                                   

                                  BTW: I did not have any problems with former versions of VMWare Server under Ubuntu 7.10 and 7.04.

                                   

                                   

                                  VMWare: You really need to fix this!!!!!!

                                   

                                   

                                  • 14. Re: Workstation 6 under Linux, Xorg 7.3 Keyboard
                                    eholme Lurker

                                    <!--

                                    @page

                                    P { margin-bottom: 0.08in }

                                    -->

                                     

                                    OK,  so I have been testing.  And have been able to

                                    confirm this issue with Workstation 6.02, Server  1.05 and player 2

                                    under Linux using a couple of  distributions that utilize XORG 7.3. 

                                    There has been talk in other forums of a possible video card issue

                                    as well so I tried a couple of  cards and drivers from ATI, INTEL,

                                    and NVIDIA which all had the same results. 

                                     

                                    If there are any other thoughts or other workarounds out there  that

                                    would be greatly appreciated,  as my distro of choice is Ubuntu  and I

                                    have ditched Gutsy and gone to Hardy which suffers from this issue,  but lacks the high IO wait issues.  The workaround mentioned for KDE does work,  but only if

                                    you have the flag for the keyboard layout and language show in the

                                    sys tray area.   So for anyone who does not know how to enable this

                                    here is a quick step by step. 

                                     

                                     

                                     

                                    1. Open kcontrol

                                    2. Choose Regional and Accessibility

                                    3. Go to Keyboard Layout

                                    4. Enable Keyboard Layouts needs to be checked

                                    5. switch to the Switching Options tab

                                    6. Check Show indicator for single layout

                                     

                                    Apply changes and logout and back into KDE,  this has worked for

                                    me 50% of the time,  otherwise its still a mystery.

                                    1 2 3 Previous Next