8 Replies Latest reply on Sep 5, 2007 1:57 PM by jolson

    Windows 2003 R2 server guest os time syncronization not working

    jolson Novice

      Our Windows 2003 R2 guest operating system is not keeping the correct time. The clock is very fast. VMware tool is installed, and the check box for "Time synchronization between the virtual machine and the host operating system" is checked.  ntpd is installed and working on the host operating system.

       

      Host Operating System: RHEL 5 x86_64

      Guest Operating System: Windows 2003 R2 Enterprise Edition Service Pack 2

      VMware Tools Build: build-44356

      VMWare server 1.0.3 build-44356

       

      Does anyone have a suggestion?

        • 1. Re: Windows 2003 R2 server guest os time syncronization not working
          esiebert7625 Guru
          vExpert

          fyi...this post has been moved to the VMware Server forum

           

          Eric Siebert

          url=http://www.vmware.com/community/ann.jspa?annID=84 VMTN User Moderator[/url]

          • 2. Re: Windows 2003 R2 server guest os time syncronization not working
            KevinG Guru

            What type of 64-bit processor are you using in the host?

            • 3. Re: Windows 2003 R2 server guest os time syncronization not working
              jolson Novice

              cat /proc/cpuinfo

              processor       : 0

              vendor_id       : GenuineIntel

              cpu family      : 6

              model           : 15

              model name      : Intel(R) Xeon(R) CPU            5148  @ 2.33GHz

              stepping        : 6

              cpu MHz         : 2000.000

              cache size      : 4096 KB

              physical id     : 0

              siblings        : 2

              core id         : 0

              cpu cores       : 2

              fpu             : yes

              fpu_exception   : yes

              cpuid level     : 10

              wp              : yes

              flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm

              bogomips        : 4658.33

              clflush size    : 64

              cache_alignment : 64

              address sizes   : 36 bits physical, 48 bits virtual

              power management:

               

              processor       : 1

              vendor_id       : GenuineIntel

              cpu family      : 6

              model           : 15

              model name      : Intel(R) Xeon(R) CPU            5148  @ 2.33GHz

              stepping        : 6

              cpu MHz         : 2000.000

              cache size      : 4096 KB

              physical id     : 0

              siblings        : 2

              core id         : 1

              cpu cores       : 2

              fpu             : yes

              fpu_exception   : yes

              cpuid level     : 10

              wp              : yes

              flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm

              bogomips        : 4630.07

              clflush size    : 64

              cache_alignment : 64

              address sizes   : 36 bits physical, 48 bits virtual

              power management:

              • 4. Re: Windows 2003 R2 server guest os time syncronization not working
                Rumple Master

                Did you also disable the time service within the Windows services?  If not, both the Windows time service and the vmware tools are fighting each other.

                • 5. Re: Windows 2003 R2 server guest os time syncronization not working
                  jolson Novice

                  Did you also disable the time service within the Windows services?

                  If not, both the Windows time service and the vmware tools are fighting each other.

                   

                  No, thank you for the tip. I have disabled the "Windows Time" service, and set the clock yet again. I will report on the results. Is there a KB or instruction set that should have informed me to disable the "Windows Time" service?

                  • 6. Re: Windows 2003 R2 server guest os time syncronization not working
                    esiebert7625 Guru
                    vExpert

                    There are good time docs...

                     

                    Vmware time sync and windows time service (understand windows time first) - http://kb.vmware.com/kb/1318

                    Timekeeping in VMware virtual machines - http://www.vmware.com/pdf/vmware_timekeeping.pdf

                    • 7. Re: Windows 2003 R2 server guest os time syncronization not working
                      boogieshafer Expert

                      cat /proc/cpuinfo

                       

                       

                      model name      : Intel(R) Xeon(R) CPU

                                 5148  @ 2.33[/b]GHz

                       

                       

                      Hz         : 2000.000[/b]

                       

                       

                      the fact that the Hz is different from the clock speed reported by the model (and its a round number...i.e. 2000) its likely that you have something running at the host level which is adjusting the speed of the CPU

                       

                      1. disable any BIOS level functions that effect the cpu speed/voltage.....with Intel you want to look for the the following in the BIOS and disable them...."SpeedStep" "EIST" "C1 Enhanced"

                       

                      2. disable any OS level functions that adjust the cpu clock.....on linux this is usually a service called "cpuspeed"....chkconfig should allow you to control it and turn it off

                       

                      3. configure the vmware environment with the correct clock speed for the cpu. set something similar to the following in your /etc/vmware/config file

                       

                      \# adjust cpuKhz to match the cpu in the machine

                      \# entry below is for 2.33 GHz

                      host.cpukHz = "2330000"

                      host.noTSC = "TRUE"

                      ptsc.noTSC = "TRUE"

                       

                      4. with a windows guest that is part of a domain, you will probably have the best luck with time drift if you disable the vmtools time sync function, but leave the windows time service running.....YMMMV so try either config and see what works more reliably

                      • 8. Re: Windows 2003 R2 server guest os time syncronization not working
                        jolson Novice

                        Following these instructions fixed the problem

                         

                        64-bit Systems

                        In the x86_64 Linux kernel, use the boot option notsc instead of clock=pit.

                         

                        LILO example:

                        image=/boot/vmlinuz

                        label="linux"

                        root=/dev/hda1

                        initrd=/boot/initrd.img

                        append="resume=/dev/hda6 splash=silent notsc"

                        read-only

                         

                        GRUB example:

                        title Fedora Core (2.6.9-1.667)

                        root (hd0,0)

                        kernel /vmlinuz-2.6.9-1.667 ro root=/dev/hda2 notsc