Highlighted
Enthusiast
Enthusiast

vMotion problem with LAG ports

I get a vmotion error "A general system error occurred: Migration fialed while copying data. Timeout." only between hosts that use a port-channel for their vMotion traffic. I can vMotion between a host that has a port-channel to another that is not connected via a port-channel. I am using Dell 6448 switches. I am using the following hash algorithim on the switch "Source IP and Source TCP/UDP Port" the options are:

(Source MAC, VLAN, EtherType, SourceModule and Port Id)

(Destination MAC, VLAN, EtherType, SourceModule and Port Id)

(Source IP and Source TCP/UDP Port)

(Destination IP and Destination TCP/UDP Port)

(Source/Destination MAC, VLAN, EtherType, SourceModule and Port Id)

(Source/Destination IP and source/destination TCP/UDP Port)

I have two ESX 4.1 hosts with the following configuration:

ESX1:

Switch0 - vmknic0(1/g1),vmknic2(2/g1) Load Balancing: IP Hash

Port Group's

VMotion Network (VLAN 104)
Management Network (VLAN 103)

ESX2:

Switch0 - vmknic0(1/g4),vmknic2(2/g4) Load Balancing: IP Hash

Port Group's

VMotion Network (VLAN 104)

Management Network (VLAN 103)

Switch configuration:

interface port-channel 11

switchport mode trunk

switchport trunk allowed vlan add 101-108

switchport trunk allowed vlan remove 1

exit

interface ethernet 1/g1

channel-group 8 mode on

mtu 9216

exit

interface ethernet 2/g1

channel-group 8 mode on

mtu 9216

exit

interface ethernet 1/g4

channel-group 11 mode on

mtu 9216

exit

interface ethernet 2/g4

channel-group 11 mode on

mtu 9216

exit

I believe this is due to an incorrect hash algorithm type but I don't want to test each one to find out, anyone else use these dell switches in the same way?

0 Kudos
0 Replies