Highlighted
Enthusiast
Enthusiast

When will Intel(R) Ethernet Connection X552/X557-AT 10GBASE-T be supported in vSphere 6?

Any ideas, this is explicitely speaking to the Intel Xeon D-1540 platforms that include 10G option? IE: SuperMicro X10SDV-TLN4F

Any takers?  I'm hearing reports it does not work in vSphere but does in Hyper-V which is depressing.   Is there a custom vib or driver hack out there yet that anyone is aware of?

42 Replies
Highlighted
Enthusiast
Enthusiast

Dang, these too obscure or not enough SKU's out in the vendor space yet?  Bummer that a network adapter that is so closely related to an Intel X520 (evolution of 10G LOM X520) seems to be unsupported ATM.

0 Kudos
Highlighted
Enthusiast
Enthusiast

There has been support for Linux for 2 driver releases now. ixgbe 4.0.3 (April 15 release) and now ixgbe 4.1.1 (June 17). For whatever reason, neither version has made it into a VIB driver package. The most recent VMWare driver is 3.23.21, which is from February.

Not keeping up on the driver releases that support the Intel 10GbE adapter in the Xeon D-1540 SoC kills the product line for visualization, unless you're going with Hyper-V or some variant of Linux (KVM / Xen / etc.)

The NIC driver is the only thing stopping me from deploying the D-1540 in my own cluster. Given that we now have native bandwidth hungry features like VSAN and 4 vCPU Fault Tolerance available to us, 10GbE is pretty much a staple for VMWare now. Have it, or pay the price - only we can't get it because the drivers haven't been updated in 4 months.

Highlighted
Enthusiast
Enthusiast

Fully concur, VMware engineering, PLEASE update this driver w/in the ESXi codebase, really is a shame for us to not be able to drive adoption of this incredible platform due to a silly driver issue that will not even allow the nics to be detected by the latest 6.0 hypervisor.

Highlighted
Hot Shot
Hot Shot

Agreed, great little motherboard, but 10GbE support is sorely needed.

See also Supermicro support for ESXi 6.0 listed here:

Super Micro Computer, Inc. - Support | OS Compatibility Chart

http://www.supermicro.com/support/resources/OS/Broadwell-DE.cfm

SupermicroESXi6Compatibility.png

TinkerTry.com
0 Kudos
Highlighted
Enthusiast
Enthusiast

Yeah, they show it as compatible, and it is, as long as you get the 4 x 1Gbps version of the board, and not the 2 x 1Gbps + 2 x 10Gbps version.

I'm sure someone is running around like a chicken with it's head off, trying to get drivers together to make this happen. I hope so, anyway.

0 Kudos
Highlighted
Hot Shot
Hot Shot

As Supermicro promised, to me (and to others, such as roberthenderson), they updated their compatibility table appropriately, just as these servers are becoming widely available (mine arrived last week).


I will attempt to reach out to an Intel networking contact (that I met at VMworld 2012), to see if we can learn more about when we can expect support.

Condensed, edited version of the Supermicro compatibility table at

http://www.supermicro.com/support/resources/OS/Broadwell-DE.cfm

Before (June 29th) at left, and after (June 30th) at right.

10GbEsupportSeenJune292015edited.png10GbEsupportUpdatedJune302015edited.png

TinkerTry.com
0 Kudos
Highlighted
Enthusiast
Enthusiast

That should clear up some confusion for Supermicro purchasers.

I did speak to an Intel representative at a roadshow late last week, and he indicated that it was up to the vendor, Supermicro in this case, to push through drivers, which struck me as odd. Usually, in my experience, it's the manufacturer that produces the drivers, and the vendor simply redistributes them, sometimes with a few little tweaks for their specific hardware or a repackage into their own branded installer.

From what I understand, the existing Linux drivers are compatible with ESXi, but may need a mild massage and a recompile, and of course put into VIB format. That all seems like a pretty small thing for Intel to do to reach an audience that is clamoring to get their latest processor offering. Hopefully your contact and Intel can provide some insight and maybe produce a little shove on the VMWare community's behalf.

0 Kudos
Highlighted
Hot Shot
Hot Shot

Just for sport, of course I tried (and failed) with some other similar Intel VIBs, oh well. Given the X552/X557 are in the same family as the 82598/82599 (according to the below site), you'd think they might share VIBs, but they don't.

Here's the Linux driver site at Intel:

Intel® Download Center

TinkerTry.com
0 Kudos
Highlighted
Hot Shot
Hot Shot

Interesting points you've made, PaulWestNet. Also interesting that the usual ways of determining which driver might work don't work for this motherboard (I tried).

VMware KB: Identifying correct driver for ESXi/ESX host PCI devices (HBA) using VMware Hardware Comp...

For folks reading along, my contact at Intel is pretty thin, it's been years, and I'm not even sure he's still in that role. So if you know somebody at VMware or Intel who can weigh in here, by all means, don't wait for a (slight) chance for me to get somewhere with this in the near-term.

Thanks!

TinkerTry.com
0 Kudos
Highlighted
Enthusiast
Enthusiast

The driver we need is the ixgbe one, but a newer version than is currently available as a VIB. The one that's shipped with ESXi 6.0 is 3.7.13.7.14, which is pretty ancient now (November, 2011).

The latest VIB for the ixgbe driver that I can find via VMWare's HCL is 3.21.6 from March, 2014. There have been a bunch of versions since then in the *nix world, but it's the 4.x series we need. I have found posts that 4.0.3‌‌ (April, 2015) worked fine in Linux for the new XEON D-1500 SoC's 10Gbps NICs on the very Supermicro board we're discussing. There's a 4.1.1‌ (June, 2015) now, as well.

We just need a newer version made available as a VIB, and we'd be set.

0 Kudos
Highlighted
Contributor
Contributor

So I see we have ESXi 6.0.0b released two days ago. The ixgbe version looks to still  be 3.7.13.7.14 when I look at the vibs in the zip file. 😞

0 Kudos
Highlighted
Hot Shot
Hot Shot

Yeah, you're right, I did the 6.0.0b update patch, and the X552/X557 still isn't seen by this latest ESXi level.

2015-07-21_20-57-39.png

TinkerTry.com
0 Kudos
Highlighted
Enthusiast
Enthusiast

Just for kicks, I decided to take a look at the release date of the Linux driver vs the release date of the VMWare driver for the same version. There was a 11 month spread between the two. That seems to imply to me that we won't see a 4.x series driver for VMWare until approximately March, 2016, if that time frame holds.

I guess any of the D-1500 series servers coming out won't be selling a whole lot of them to VMWare users until somewhere late in the quarter next year, due to the missing driver problem. You'd think there'd be some significant pressure from OEMs like Supermicro and Intel to get drivers approved so product can flow. I wonder if there is...?

Highlighted
Contributor
Contributor

Hi all, same problem here.

VMware engineers, please add support for X552/X557-AT, the SuperMicro X10SDV-TLN4F motherboard is becoming very popular here too!

Best regards

Domenico

Highlighted
Enthusiast
Enthusiast

For what it's worth, I tried compiling the 4.1.1 drivers for 6.0 a month or so back and completely struck out.  The 4.x driver looks to be a substantial rewrite because there are large changes to the source, even for older NICs.  It may take a while to get it working under vSphere.

Jason Litka http://www.jasonlitka.com
0 Kudos
Highlighted
Enthusiast
Enthusiast

It's good to hear that someone with the necessary skill set has tried this. Thanks for the input.

It's unfortunate the driver is so different and isn't compiling as easy as one would hope. Hopefully Intel and VMWare can collaborate and get something worked out.

0 Kudos
Highlighted
Contributor
Contributor

Hi There,

I have bought this motherboard too in order to use VMware ESXi.

Any news about the compatibility of this chipset?

Thank you.

0 Kudos
Highlighted
Hot Shot
Hot Shot

Still working on it! (I did meet Intel folks at VMworld 2015, and am keeping in touch)

TinkerTry.com
0 Kudos
Highlighted
Hot Shot
Hot Shot

While we wait for proper ESXi 6.x support, a workaround for me is to use VT-d, but I realize that approach has drawbacks, including disabling vMotion.

2015-09-21_9-39-16.png

I then assign one or two 10GbE interface(s) to a VM such as Windows Server 2012 R2 or Windows 8.1/10, which works just fine, using the driver found at "Drivers & Utilities" at Supermicro here:

http://www.supermicro.com/products/system/midtower/5028/SYS-5028D-TN4T.cfm

TinkerTry.com
0 Kudos