vjain1183
Contributor
Contributor

VMXNET3 No Performance Data VSphere

Any of my VMS that I have added the VMXNET3 card to do not show network performance data in the VSphere client.

It Says "Performance data is currently not available for this entity"

But If I look at the VM that still has the VMXNET2 Nic card I can see the realtime performance data.

This is not a SQL issue, I have well under 10 VMS.

Any Vm that has the VMXNET3 nic has this problem.

Any ideas?

Thanks guys

0 Kudos
14 Replies
RenaudL
Hot Shot
Hot Shot

Thanks for the report, we're looking into it.

0 Kudos
vjain1183
Contributor
Contributor

Thanks

0 Kudos
Scissor
Virtuoso
Virtuoso

0 Kudos
RenaudL
Hot Shot
Hot Shot

We successfully reproduced the issue in-house, we identified the problem, a fix will be issued in a future patch or update release.

Thanks again.

0 Kudos
vjain1183
Contributor
Contributor

thanks

0 Kudos
horace_ng
Contributor
Contributor

Tagging this thread, I would need an update. Thanks. :smileygrin:

0 Kudos
RobertoRosa
Contributor
Contributor

RenaudL,

Do you have any idea of how long will it take to address this issue ? I have installed the latest patches - which bumped the build number to 175625 - and the issue is still present. Of course - it's not critical, but fixing it can help a lot the administration tasks....

Regards,

Roberto

0 Kudos
brainslice
Enthusiast
Enthusiast

Same issue here. No performance data available for vmxnet3 on any vm.

http://communities.vmware.com/message/1332047

0 Kudos
1ppInc
Contributor
Contributor

I would like an update on this as well.

Reporting of network performance is vital to our operation and we currently have no way of monitorning this through the vsphere client.

Thank you.

0 Kudos
beckhamk
Enthusiast
Enthusiast

Has there been any status update or a fix released for this issue?

0 Kudos
joekeg
Contributor
Contributor

Looks like there were 6 patches released on 9/24, nothing about this that I see.

0 Kudos
vjain1183
Contributor
Contributor

This is pretty bad that they are not even catering to a wide range of customers for performance monitoring.

There are other 3rd party tools, but VMware should fix this.

This is why we pay support costs!

0 Kudos
Michel_Sijmons
Contributor
Contributor

Well, it would be nice to finally receive the patch which fixes this issue!

Since it's only been almost 4 months since the bug was successfully reproduced and the buggy code localized and indentified.

0 Kudos
Paul11
Hot Shot
Hot Shot

Seems to be fixed with the latest Updates from Nov 19, 2009: (VMware ESX 4.0, Patch ESX400-200911201-UG: Updates Core); KB 1014792

•Fixes an issue where networking performance data is missing when the VMNEXT3 adapter is used. The Networking panel is missing in the Performance tab of a virtual machine when a guest is using a VMNEXT Generation 3 adapter. If a virtual machine has a mix of virtual adapters, the Networking panel of the guests not using VMNEXT3 is still displayed. This issue is resolved in this release.

0 Kudos