Highlighted
Enthusiast
Enthusiast

VM Guest Connectivity after Host Reboot

Hello, VMware Community!

I've searched high and low and can't find a good answer for this one. Any help would be fantastic.

Here is the situation, I have two ESXi 4.1 hosts running with shared storage. My vCenter server is a guest on one of the Hosts and all of my networking is running through a vDS. I some issues with my storage and had to bring my hosts down in order to fix it. I have my hosts back online but have lost network connectivity within all of my guests.

I had some trouble getting my vCenter server back online. What I ended up doing was logging directly into the Host with the vCenter VM, removed a NIC from the vDS and created a vSwitch so that I could restore connectivity to the guest. I had to actually install a second NIC and disable the original to get the network up again.

I have vCenter back up and the Hosts reconnected but still no network access within the Guests. On one system I basically did the same thing as with the vCenter server, removed the original NIC and added a new one. This got the network back up but I don't want to do this with all of my guests. I had a great system running with vShield running some VPN connections over Edge and I fear that having to do this one all of those systems will be a disaster.

I've tried restarting the services via SSH, migrated machines between datastores and guests, rebooted machines, moved the vNIC to different port groups and back. None of this helps solve the problem. If I look at the vDS itself I can see the guests on their ports and it reports the link as being up but there is no connectivity. I can't ping anything into or out of the guest including the gateway.

This is the second time I've had something like this happen, the first was no big deal because it was in a small lab and I just rebuilt. This is more complex and I'd like to know if anyone has run into this and can assist me in getting connectivity restored without any major work around's. Any help would be appreciated.

Thank you!

0 Kudos
1 Reply
Highlighted
Enthusiast
Enthusiast

Hi, I'm a similar problem with a failed install of vShield. VM guest are correct, vSwicth correct, delete vmNIC, create new, new vSwitch, but no network on guest.

I delete this lines on the .vmx file of the VM:

ethernet1.filter0.name = ""
ethernet0.filter0.name = ""
ethernet0.filter0.param1 = ""
ethernet1.filter0.param1 = ""

and all it's ok

0 Kudos