didier_voeltzel
Contributor
Contributor

Unable to connect VM through vSwitch

Hi,

I'm using ESXi version 6.7.0 Update 3 (Build 14320388)
I have a problem I've never encountered before:
I created 2 more vSwitches to have 3 subnets (LAN, DMZ and WAN)

LAN and WAN are not a problem, but the switch associated with the DMZ does not work.

pastedImage_7.png

Everything seems normal but the VMs are not connected (no DHCP and no pinging between them)

I've tried to recreate another vSwitch but the problem remains

does anyone have any idea what's going on and how to fix it?

Thank You

Didier

0 Kudos
3 Replies
scott28tt
VMware Employee
VMware Employee

Moderator: Moved to vSphere vNetwork


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
KocPawel
Hot Shot
Hot Shot

Check if there is not a local firewall on operating systems and if it possible disable it for tests.

0 Kudos
T180985
Expert
Expert

You said no DHCP, have you tried manually assigning IP addresses to confirm they ping?
The vSwitch doesnt have any physical network adapters so the VMs wouldnt be able to access any services e.g. DHCP on another VLAN or another host.

I suspect you just need to add some physical adapters to the vSwitch and ensure your physical switch is correctly configured

Please mark helpful or correct if my answer resolved your issue. How to post effectively on VMTN https://communities.vmware.com/people/daphnissov/blog/2018/12/05/how-to-ask-for-help-on-tech-forums
0 Kudos