VMware Cloud Community
TDTechAdmin
Contributor
Contributor
Jump to solution

Trunk over Etherchanel/802.3ad, does it work with vmware esx?

Setup trunk over etherchanel in cisco switch,does it work with vmware esx?

Cisco switch configuration like this(I do not have a switch,can't test it):

port-channel load-balance src-dst-ip
interface vlan 4094
  no ip address
interface Port-channel1
  switchport
  switchport mode trunk
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan all
  switchport trunk native vlan 4094
  no ip address
interface GigabitEthernet1/1
  switchport
  switchport mode trunk
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan all
  switchport trunk native vlan 4094
  no ip address
  chanel-group 1 mode on
interface GigabitEthernet1/2
switchport
  switchport mode trunk
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan all
  switchport trunk native vlan 4094
  no ip address
  chanel-group 1 mode on
end

0 Kudos
1 Solution

Accepted Solutions
SteveFuller2011
Enthusiast
Enthusiast
Jump to solution

What you have should work OK, as it's not too different from the following working example from my lab:

ocs4948-1#sh run int gi1/2

Building configuration...

Current configuration : 536 bytes
!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,10
switchport mode trunk
mtu 9198
channel-group 64 mode on
spanning-tree portfast
spanning-tree bpduguard enable
end

ocs4948-1#sh run int gi1/6

Building configuration...

Current configuration : 536 bytes
!
interface GigabitEthernet1/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,10
switchport mode trunk
mtu 9198
channel-group 64 mode on
spanning-tree portfast
spanning-tree bpduguard enable
end

ocs4948-1#sh run int po64

Building configuration...
Current configuration : 291 bytes
!
interface Port-channel64
description LACP link esx402
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,10
switchport mode trunk
mtu 9198
load-interval 30
storm-control broadcast level 5.00
spanning-tree portfast
spanning-tree bpduguard enable
end


ocs4948-1#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Po64        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po64        2,10

Port        Vlans allowed and active in management domain
Po64        2,10

Port        Vlans in spanning tree forwarding state and not pruned
Po64        2,10

The one thing to take a look at will be the VLANs you've got configured on the vSwitch. As you've set native VLAN i.e., the untagged VLAN on the switch to be 4094, all other traffic sent on the trunk will have VLAN tags, which will be stripped by the vSwitch.

In my setup I've established port groups using VLAN 2 and VLAN 10. Traffic to VMs in these VLANs are .1Q tagged by the physical switch, which is then stripped by the vSwitch.

Take a look at the section "VLANs in VMware Infrastructure" on page 7 of the Virtual Networking Concepts that Andre already mentioned, but also the other document worth a read is http://www.vmware.com/pdf/esx3_vlan_wp.pdf.

Finally for the switch side of things, take a look at the examples on Scott Lowe's blog at http://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/.

Regards

View solution in original post

0 Kudos
7 Replies
a_p_
Leadership
Leadership
Jump to solution

You may configure EtherChannel with ESX(i), however keep in mind that only outgoing traffic will be balanced (based on the policy you configure for the vSwitch). If you want to use LACP you need to have the NEXUS 1000V add-on (in addition to the Enterprise Plus license)

see http://kb.vmware.com/kb/1004048 and http://www.vmware.com/files/pdf/virtual_networking_concepts.pdf

André

0 Kudos
TDTechAdmin
Contributor
Contributor
Jump to solution

Thanks.

But you'r talking about access mode, not trunk mode.

How about trunk mode?

0 Kudos
TDTechAdmin
Contributor
Contributor
Jump to solution

Do I need a Cisco Nexus 1000V device?

0 Kudos
SteveFuller2011
Enthusiast
Enthusiast
Jump to solution

What you have should work OK, as it's not too different from the following working example from my lab:

ocs4948-1#sh run int gi1/2

Building configuration...

Current configuration : 536 bytes
!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,10
switchport mode trunk
mtu 9198
channel-group 64 mode on
spanning-tree portfast
spanning-tree bpduguard enable
end

ocs4948-1#sh run int gi1/6

Building configuration...

Current configuration : 536 bytes
!
interface GigabitEthernet1/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,10
switchport mode trunk
mtu 9198
channel-group 64 mode on
spanning-tree portfast
spanning-tree bpduguard enable
end

ocs4948-1#sh run int po64

Building configuration...
Current configuration : 291 bytes
!
interface Port-channel64
description LACP link esx402
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,10
switchport mode trunk
mtu 9198
load-interval 30
storm-control broadcast level 5.00
spanning-tree portfast
spanning-tree bpduguard enable
end


ocs4948-1#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Po64        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po64        2,10

Port        Vlans allowed and active in management domain
Po64        2,10

Port        Vlans in spanning tree forwarding state and not pruned
Po64        2,10

The one thing to take a look at will be the VLANs you've got configured on the vSwitch. As you've set native VLAN i.e., the untagged VLAN on the switch to be 4094, all other traffic sent on the trunk will have VLAN tags, which will be stripped by the vSwitch.

In my setup I've established port groups using VLAN 2 and VLAN 10. Traffic to VMs in these VLANs are .1Q tagged by the physical switch, which is then stripped by the vSwitch.

Take a look at the section "VLANs in VMware Infrastructure" on page 7 of the Virtual Networking Concepts that Andre already mentioned, but also the other document worth a read is http://www.vmware.com/pdf/esx3_vlan_wp.pdf.

Finally for the switch side of things, take a look at the examples on Scott Lowe's blog at http://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/.

Regards

0 Kudos
TDTechAdmin
Contributor
Contributor
Jump to solution

Thanks a lot.

Please help me with another question:

Do you use NEXUS 1000V add-on and Cisco NEXUS 1000V  device?

Or just configure it in cisco switch?

Do you use "port-channel load-balance src-dst-ip" or another load-balance mode?

0 Kudos
SteveFuller2011
Enthusiast
Enthusiast
Jump to solution

The Nexus 1000V is not something I've had opportunity to play with at this point in time, but it resides within the ESX host and replaces the vSS or the vDS from VMware. The configuration and operation is separate to the external Cisco switch, although the CLI is similar so those with Cisco experience should be able to manage fairly easily.

As far as the load balancing, the vSwitch only supports source-destination IP, but the Nexus 1000V supports balancing utilising information up to and includnig Layer 4 protocol and port numbers (see http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_2_1_s_v_1_4/interface/configurati... for details).

If you want specific details for the Nexus 1000V you should consider raising another question to the forum such that it gets proper attention.

Regards

TDTechAdmin
Contributor
Contributor
Jump to solution

Great,thanks.

0 Kudos