rob_ellison
Contributor
Contributor

Nexus 1000v remove config for a VEM

Hi All, bit of a weird one here...

I have a port-profile setup like this:

port-profile Uplink-Trunk capability uplink vmware port-group switchport mode trunk switchport trunk allowed vlan 2-998 channel-group auto mode active no shutdown system vlan 111-112 state enabled

this works fine for most of the hosts but one of them seems to make up it's own config when i add it into this profile - it's module 3 in this example..

interface port-channel2 inherit port-profile Uplink-Trunk

interface port-channel3 switchport mode access inherit port-profile Uplink-Trunk interface Ethernet3/2 inherit port-profile Uplink-Trunk interface Ethernet3/3 inherit port-profile Uplink-Trunk interface Ethernet4/2 switchport mode access inherit port-profile Uplink-Trunk interface Ethernet4/3 switchport mode access inherit port-profile Uplink-Trunk

is there any way of removing this config that seems to always appear? i've tried removing the DVS from the server, changing it manually (not possible) and even rebooting the VSM. I cant find a solution. every time i add that same server into the DVS it gets the same (wrong) config.

any help here would be much appreciated.

Tags (2)
0 Kudos
3 Replies
lwatta
Hot Shot
Hot Shot

Rob,

Hold on. What I posted won't work. I'm trying to find out why you can't undo the changes with the no command.

louis

rob_ellison
Contributor
Contributor

Hi Louis, i tried the 'no vem 4' command and re-added the host - it does seem to be almost right now.. however, as you can see, the config is not quote the same. the newly added module has the 'switchport mode trunk' command in there for some reason. if i try and get rid of it with a 'no switchport mode trunk' it just changes to switchport mode access! very strange.

interface port-channel3 switchport mode trunk inherit port-profile Uplink-Trunk interface Ethernet3/2 inherit port-profile Uplink-Trunk interface Ethernet3/3 inherit port-profile Uplink-Trunk interface Ethernet4/2 switchport mode trunk inherit port-profile Uplink-Trunk interface Ethernet4/3 switchport mode trunk inherit port-profile Uplink-Trunk

0 Kudos
lwatta
Hot Shot
Hot Shot

Rob,

Apparently there is a bug and the "no vem module#" does not erase everything.

So right now the best solution is to "no" all the commands you have set on the individual ethernet connection.

In the case of the "switchport mode access" since you can't "no switchport mode" just set it to the same as the port-profile. I know this sucks but hopefully there will be fix soon. I'll look into other workarounds.

louis

0 Kudos