dlietz
Contributor
Contributor

Network Failover Issue

Jump to solution

Working with a new install that consists of an HP c7000 blade enclosre with (3) BL680c's running ESX4 configured as a single cluster. Each server has 4 NIC's, vmnic0 and 1in a vSwitch for vmotion and service console, vmnic2 and 3 in a vswitch for VM's. The NIC's are configured in the active/active failover configuration. I'm using tagged vlans at the vswitches. The enclosure networking consists of (2) HP Virtual Connect 1/10 Gb Ethernet modues in bays 1 and 2. So vmnic0 and 2 map to bay 1 and vmnic1 and 3 map to bay 2. On the interconnects, there are 4 external ports on each switch configured as a shared uplink set carrying all of the VLAN's, each trunk patched in to an etherchannel group on a single Cisco 2960. So both etherchannels are patched to the same 2960.

When testing failover I'm having a slight problem. If I pull the plug on 4 ports from one of the interconnects, I loose maybe one ping from the VM's. However, when I plug the 4 patch cables back in, I will loose up to 6 or 7 pings when the switch fails back. What appears to be happening is that when I plug the 4 patch cables in and a link is established, the ESX servers are trying to fail back, however on the virtual Connect side the 4 ports do not immediately go in to active mode, but rather go to standby first, then active a few seconds later. I think what is happening is that the ESX servers detect the link and start trying to fail back before the ports have actually been made available on the VC switch.

There is a pdf drawing attached of the basic setup.

Does anyone know if there is a way this issue could be resolved, either on the ESX network config or on the HP VC config?

Thanks.

Dan

0 Kudos
1 Solution

Accepted Solutions
jpdicicco
Hot Shot
Hot Shot

I recommend you open a case with HP. This shouldn't happen with Smart Link. Smart Link should only enable a downlink if there is an active uplink available.

ITMT, try beacon probing as suggested.

JP

Happy virtualizing! JP Please consider awarding points to helpful or correct replies.

View solution in original post

0 Kudos
6 Replies
Texiwill
Leadership
Leadership

Hello,

I think you need to contact HP on this one. There is no 'Failback' timing. You can only disable Failback or change the Network failure detection rules to Beacon Probing.


Best regards,
Edward L. Haletky VMware Communities User Moderator, VMware vExpert 2009

Virtualization Practice Analyst[/url]
Now Available: 'VMware vSphere(TM) and Virtual Infrastructure Security'[/url]
Also available 'VMWare ESX Server in the Enterprise'[/url]
[url=http://www.astroarch.com/wiki/index.php/Blog_Roll]SearchVMware Pro[/url]|Blue Gears[/url]|Top Virtualization Security Links[/url]|
[url=http://www.astroarch.com/wiki/index.php/Virtualization_Security_Round_Table_Podcast]Virtualization Security Round Table Podcast[/url]

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
dlietz
Contributor
Contributor

How is the behavior of 'beacon probing' different than 'link detection'.

Thanks.

Dan Lietz

Gracon Services, Inc.

Technical Services Coordinator

BUS: 517-349-4900

dlietz@gracon.com

0 Kudos
jpdicicco
Hot Shot
Hot Shot

Do you have Smart Link enabled on your VC Ethernet Networks?

JP

Happy virtualizing! JP Please consider awarding points to helpful or correct replies.
dlietz
Contributor
Contributor

Yes, smartlink is enabled.

0 Kudos
jpdicicco
Hot Shot
Hot Shot

I recommend you open a case with HP. This shouldn't happen with Smart Link. Smart Link should only enable a downlink if there is an active uplink available.

ITMT, try beacon probing as suggested.

JP

Happy virtualizing! JP Please consider awarding points to helpful or correct replies.

View solution in original post

0 Kudos
dlietz
Contributor
Contributor

Switching all of the vswitches to failover using 'beacon probing' seems to have done the trick. Thanks for the help everyone.

0 Kudos