jeffj2000
Enthusiast
Enthusiast

LLDP not working with Intel X710 cards

Hi. Is anyone having issues with LLDP not working with Intel X710 10gb?

We just got a batch of Dell PowerEdge 730s with a Dual-Port Intel X710 card and a Quad port Motherboard card which is a dual-port Intel I350 and a dual-port Intel X710 jammed on 1 card. LLDP works for the 1GB ports on those. But those use a different driver obviously. The 10GB ports use the i40en.

The box has the last firmware, bios, drivers, etc from Dell. And VMware. And since the HCL doesnt totally agree on the driver between VMware and Dell (when does it ever) I tried both.

Interesting CDP works on these cards at another one our sites that uses Cisco.

I found this link which was interesting, but no one answered the ESXi question on it.

X710 dropping LLDP frames ? |Intel Communities

Thanks you any help you can provide. Thanks,,,

20 Replies
mhampto
VMware Employee
VMware Employee

Please ensure that the driver you are running on the X710s are compatible: VMware Compatibility Guide - I/O Device Search​. What version of ESXi are you running? Please review Determining Network/Storage firmware and driver version in ESXi 4.x and later (1027206) to shed more light on this.

0 Kudos
jeffj2000
Enthusiast
Enthusiast

Hi. I confirmed with an Intel engineer that the X710 card will not work with VMware LLDP, and they have no plans to fix it. Very disappointing.

0 Kudos
jeffj2000
Enthusiast
Enthusiast

Looks like Intel just fixed this on the driver out 4 days ago.

- Add LLDP driver load param to allow or disallow LLDP frames forwarded to the network stack

  This feature only supports Intel X710 and XL710 adapters with FW 6.0.x and  later

  LLDP agent is enabled by default (FW default setting)

  Set LLDP=0 to disable LLDP agent

  Set LLDP=1 to enable LLDP agent back

  Set LLDP to anything other then 0 or 1 will fallback to a default setting (LLDP enabled)

  LLDP agent is always enabled when MFP (Multi Functional Port, i.e. NPAR) enabled, regardless of the driver param LLDP setting

  When LLDP agent is enabled, all LLDP frames will be dropped

stephenhowellvc
Contributor
Contributor

Where is the driver available, do you have a link?

thanks

0 Kudos
jeffj2000
Enthusiast
Enthusiast

Hi. I am not sure if you need a firmware pair to go with this though. And I havent tried it yet.

https://my.vmware.com/group/vmware/details?downloadGroup=DT-ESXI65-INTEL-I40EN-156&productId=615

Thanks,,,

0 Kudos
TheHevy
Contributor
Contributor

0 Kudos
jeffj2000
Enthusiast
Enthusiast

Yes I saw that. We use Dell PowerEdge, so I think we need to wait for Dell to get the firmware in their update bundle. Still so happy this is finally fixed.

0 Kudos
JulianBrison
Contributor
Contributor

Hi,

I'm encountering the same issue on our hosts.

I installed the latest native driver (i40en 1.5.6) and the latest firmware (6.0.1) on the card. In the release not of the driver they says that you can disable the LLDP agent by providing a parameters to the Driver Module.

I provided the parameter in the driver module :

[root@xxxx:~] esxcli system module parameters list -m i40en

Name     Type          Value  Description

-------  ------------  -----  ----------------------------------------------------------------------------------

LLDP     array of int  0      Link Layer Discovery Protocol (LLDP) agent: 0 = disable, 1 = enable, (default = 1)

RxITR    int                  Default RX interrupt interval (0..0xFFF), in microseconds (default = 50)

TxITR    int                  Default TX interrupt interval (0..0xFFF), in microseconds, (default = 100)

VMDQ     array of int         Number of Virtual Machine Device Queues: 0/1 = disable, 2-16 enable (default =8)

max_vfs  array of int         Maximum number of VFs to be enabled (0..128)

Unfortunately, the problem didn't disappeared, vCenter always claim that the card is not LLDP capable and I can't see if LLDP frames are dropped or not.

I really need LLDP or CDP to work to be able to configure my SDN backend correctly so he can do his magic.

Have anyone already tried or tested this before ?

Thanks in advance for your help.

Best regards,

Julian

0 Kudos
Vaikis_
Contributor
Contributor

Hi JulianBrison, did you tried to disable agent on the i40en driver ? run this command

esxcli system module parameters set -m i40en -p LLDP=0

show output by command

esxcfg-module -g i40en

this should disable internal LLDP agent on network card that it could pass LLDP to ESXi

Does LLDP started to work for you ? What servers you have, Dell or HP ?

0 Kudos
jeffj2000
Enthusiast
Enthusiast

Unfortunately this new driver that is mentioned in this thread, is not on the HCL for the Intel 710 on Dell poweredge. The HCL driver is a v2.07 but for ESXi v6/6.5 So its really damn confusing here.

0 Kudos
JulianBrison
Contributor
Contributor

Hi Vaikis,

I already tried to do that with no success. LLDP is not passed to the OS. Do you know if there is a way to see LLDP Frames getting out the NIC?

I'm currently running those tests on Supermicro servers

Jeff,

I'm not talking about the Dell drivers (since dell as their own drivers release). I use the native intel drivers and native firmware.

Best regards,

0 Kudos
Vaikis_
Contributor
Contributor

Hi Julian,

Dont know how to check within ESXi, I believe there is no working command to check LLDP Frames getting out the NIC....

0 Kudos
Vaikis_
Contributor
Contributor

Jeff, there is different driver sets , one for i40en and other for i40e

0 Kudos
BruceHB
Contributor
Contributor

I have vmnic1, vmnic2 in same VSS and enable their lldp.

#esxcfg-vswitch -l

Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks

vSwitch0         7802        7           128               1500    vmnic1,vmnic2

#esxcfg-module -g i40en

i40en enabled = 1 options = 'LLDP=0'

switch# do show lldp neighbors

Loc PortID          Rem Host Name       Rem Port Id                    Rem Chassis Id

-------------------------------------------------------------------------------------

ethernet1/1/11      Not Advertised      3c:fd:xxxxx             3c:fd:xxxx    <-- this is still 710 lldp message.

ethernet1/1/12      xxxxx          3c:fxxx           vmnic1    <--- this is correct now.

however,

only vmnic1 can work with vsphere lldp.

vmnic2 lldp is still dropped and 710 lldp message is still on in the port.

0 Kudos
BruceHB
Contributor
Contributor

finially found by myself.  the option can be LLDP=0,0  for my issue.

JulianBrison
Contributor
Contributor

Holy F**k Bruce you found the cause.

To be honest the type "Array of Int" bothered me a lot and I didn't check it further.

I tried your solution and it activate the LLDP feature on 2 of my 4 port NIC.

This means that if you want to deactivate the LLDP agent from intel on a 4 port NIC you have to give LLDP=0,0,0,0 as parameter. Each 0 corresponding to one NIC.

Many thanks Bruce for this finding !

Jeff, when you will get the intel driver, be careful of those parameters.

Have a nice day !

0 Kudos
Vaikis_
Contributor
Contributor

Found this yesterday and forgot to asnwer, that LLDP=0,0,0,0 should be used if you need to enable all 4 ports.

0 Kudos
jeffj2000
Enthusiast
Enthusiast

Hi. I actually cannot go to the new driver yet Smiley Sad. It is not on the Dell PowerEdge HCL yet. Soon I hope!! And I imagine Dell will some new firmware release package to go with it. I am glad everyone says this works finally though. Thanks,,,

0 Kudos
wreedMH
Hot Shot
Hot Shot

I finally got this to work by running i40en driver version 1.5.6 and running the following command: esxcli system module parameters set -m i40en -p LLDP=0,0,0,0.