MrVmware9423
Hot Shot
Hot Shot

Duplex Mode or Physical Switch

Jump to solution

Dear VMware Experts,

my vmnic is able to support 1gb connection, below is the snapshot of the same.

vmnics.JPG

but when i see vmnic0 in vswitch networking page over there it shows 100 Full, below is the snap of the same.

Duplex.JPG

but when i try to reconfigure the duplex from 100 FUll to 1000 Full, the vmnic connection is down / unplugged, Please help me with the same.

Regards

MrVMware

0 Kudos
1 Solution

Accepted Solutions
rickardnobel
Champion
Champion

If it does work in 100 Full mode it should not be expected to work in 1000 Full without configuration changes on the physical switch.

I would recommend you the make sure that the physical switch is set to AUTO and set the same on the ESXi vmnics. There are very few reasons these days to hard set the duplex mode.

My VMware blog: www.rickardnobel.se

View solution in original post

0 Kudos
9 Replies
chriswahl
Virtuoso
Virtuoso

Make sure the physical switch that the ports are plugged in to supports gigabit and is configured properly (such as auto negotiation). Gigabit should always be configured to full duplex.

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators
aravinds3107
Virtuoso
Virtuoso

Check if your physical switch port is set to  1000 FD and set the VMNIC to 1000FD manually under vSwitch properties - >network adapters tab

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful |Blog: http://aravindsivaraman.com/ | Twitter : ss_aravind
0 Kudos
rickardnobel
Champion
Champion

If it does work in 100 Full mode it should not be expected to work in 1000 Full without configuration changes on the physical switch.

I would recommend you the make sure that the physical switch is set to AUTO and set the same on the ESXi vmnics. There are very few reasons these days to hard set the duplex mode.

My VMware blog: www.rickardnobel.se
0 Kudos
a_p_
Leadership
Leadership

I fully agree with Rickard. Starting with gigabit, autonegotiation has been a fixed standard and is recommended by the manufacturers. In addition to setting the ESXi hosts as well as the physical switch ports to auto/auto, you also need to use the appropriate network cables (Cat 5 - four cable pairs).

André

MrVmware9423
Hot Shot
Hot Shot

Many thanks experts for ur precious suggestions, really appriciate the same.

as per ur suggesstions it means that lan cable is connected to 100MB FULL duplex switch ports , thats y at esx end  i m able to see 100 FULL . if i want 1000Full duplex setting i need to do some changes on switch port end, 

we are not managing the physical switches, the same  is managed by n/w team, will discuss the same with n/w team and lt you know the same.

Dear Rickard,

if 100Full is there so y i m not able to see 1000F duplex setting, can u plz explain the same in brief.

Regards

Muhammad

0 Kudos
rickardnobel
Champion
Champion

MrVmware9423 wrote:

if 100Full is there so y i m not able to see 1000F duplex setting, can u plz explain the same in brief.

I am not really able to understand your exact question? Do you ask why it does not work when changing to 1000 Full Duplex or is the selection not available in the vSphere Client interface at all?

My VMware blog: www.rickardnobel.se
0 Kudos
MrVmware9423
Hot Shot
Hot Shot

Dear Rickard,

I want to ask why it does not work when changing to 1000 Full Duplex?

Regards

MrVMware

0 Kudos
rickardnobel
Champion
Champion

I want to ask why it does not work when changing to 1000 Full Duplex?

When using a "hard configured" duplex settings they must be exactly the same on both sides, in this case on your ESXi host and on your physical switch.

If you at the moment have a working setup with hard 100 Full this means that the physical switch is configured to 100 Full too. If you now change the setting on only one side to 1000 Full then this will not be compatible on the physical switch.

I would recommend you to look at the switch configuration and see what the settings are - and make sure they are AUTO, then change the ESXi host to AUTO too. You will then get the highest possible common mode and less issues as when setting this manually.

My VMware blog: www.rickardnobel.se
0 Kudos
MrVmware9423
Hot Shot
Hot Shot

Many Many thanks Rickard, now my confusion is over bcoz of ur clear explanation.

I really appriciate the same.

Many thanks once again for ur excellent efforts.....

Regards

Muhammad Ahmed

India

0 Kudos