tdubb123
Expert
Expert

[vCenterServer:443] Database Temporarily Unavailable or has Network Problem

i keep getting this error when enabling update manager plugin.

But when I change the update manager service startup account to a domain user instead of local system, it works

any idea?

0 Kudos
11 Replies
rcporto
Leadership
Leadership

Any change on VUM database ? Moved to another server or changed the user credentials ?

First, check this KB article: VMware KB: Enabling Update Manager fails with the error: database unavailable or has network problem...

And if changed the user password or setup a new service account, try this one: VMware KB: Changing the vCenter Update Manager database password

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
tdubb123
Expert
Expert

i tried updating the info with the utility but still same issue. It just doesnt want to use the local system account for starting update manager.

on the sql side I am using sql local user authentication and not domain user.

0 Kudos
JJustino
Enthusiast
Enthusiast

Its 32-bit ODBC connection to the base of the update manager was created?

    The SQL database manager and the update only for him or you installed vCenter and update manager sso in a single SQL database?

0 Kudos
tdubb123
Expert
Expert

yes its 32bit. sql satabase is separate server. um and vcenters are both separate machines.

0 Kudos
JJustino
Enthusiast
Enthusiast

Got your topology

That his error to occur by the following


1-This issue can Occur if we are using a remote SQL database with Windows authentication and the Update Manager service is Set to log on to the local system account.


Try the following


"NOTE: Make sure the vci-integrity.xml file, located at C:. \ Program Files \ VMware \ Infrastructure \ Update Manager, vCenter has the correct IP address If the IP address is incorrect, update it and restart the Update Manager service "

To change the service to the Windows NT login the same account que Has Been Given dbo permissions to the SQL database, please perform the instructions Following:

Login to vCenter System installed using RDP.

Click on Start, Run, Type Services.msc.

Locate and right click on VMware vCenter Update Manager Guest Agent and VMware vCenter Update Manager Service and then choose properties option (One service at the time) and then go to LogOn Tab.

Select the This Account option and then specify the SQL database administrator user name and password of the Appropriate SQL database administrator.

Click on Apply and OK.

Login to vCenter Server and then click on Plugins. From the Plug-In Manager console, right-click on installed VMware vCenterUpdate Manager and choose enable option.

0 Kudos
tdubb123
Expert
Expert

im using sql native client 11 to sql 2012. I dont see any issues here since I use that for vc and sso database.

0 Kudos
tdubb123
Expert
Expert

in the vci-integrity.xml file

I found this section and looks like this

<database>

    <dbtype>SQL Server Native Client 11.0</dbtype>

    <dsn>vum</dsn>

    <initialConnections>20</initialConnections>

    <maxConnections>40</maxConnections>

    <password>MBoF/wpnXQ3HZsfWWRWUP65yBrcJs9tQ</password>

    <username>vpxadmin</username>

  </database>

vpxadmin is a local sql user with dbo rights to the vum database.

Do I need this line in there?

0 Kudos
JJustino
Enthusiast
Enthusiast

See my settings from my vCenter, the User bank attributed this, it has to be!

<dbtype> SQL Server Native Client 10.0 </ dbtype> <dsn> VUM_DB_VCENTER_GCONFIGURACAO </ dsn> <initialConnections> 20 </ initialConnections> <maxconnections> 40 </ maxconnections> <password> BNdrA738muS0KUjWRQzNeyOhCPBFGsucnf5xF6Na2VI = </ password> <username> vmware_dba </ username>

0 Kudos
tdubb123
Expert
Expert

what do you mean? There has to be a User and password line?

0 Kudos
JJustino
Enthusiast
Enthusiast

Change to the client version of SQL

"SQL Server Native Client 10.0"

   With the client version 11.0've had many connection problems.

   Apparently your vci-integrity.xml is correct, revise part of networking and SQL.

<database>

    <dbtype>SQL Server Native Client 11.0</dbtype>

    <dsn>vum</dsn>

    <initialConnections>20</initialConnections>

    <maxConnections>40</maxConnections>

    <password>MBoF/wpnXQ3HZsfWWRWUP65yBrcJs9tQ</password>

    <username>vpxadmin</username>

  </database>

0 Kudos