Highlighted
Contributor
Contributor

steps to upgrade from 4.1 to 5.0 & question on 2005 express db

Hi,

I am a bit confused on the steps needed to upgrade from 4.1 to 5.0, both for the VC and ESXi hosts.

I have ESXi hosts on 4.1 and also VC 4.1 running on W2k8 R2 64bit server with sql 2005 express db

My first confusion is of the 2005 express db is supported for in-place upgrade. I read the doc and am confused

MS SQL Server 2005 Express                               No After you upgrade to a database server that is supported by vCenter  Server, you can install or upgrade to vCenter Server.

is it supported or not ??

to clarify some steps -

step 1  - perform in-place upgrade of VC (I have to start the autorun.exe and then VC will be upgraded. then enter the new license key)

step 2  - migrate vm's from one ESX 4.1 host to others

step 3  - perform an upgrade of this host

step 4  - migrate vm's from ESX 4.1 host to ESXi 5.0

step 5  - perform an upgrade of remaining ESXi 4.1 hosts

step 6 - done ???

can someone please guide me. Thanks         

0 Kudos
5 Replies
Highlighted
Immortal
Immortal

According to the vCenter Installation guide http://pubs.vmware.com/vsphere-50/topic/com.vmware.ICbase/PDF/vsphere-esxi-vcenter-server-50-install... - SQL 2005 is not supported only SQL 2008 Epress is supported - check page 162 

You will have to back up the database and restore it to one of the supported databases - the upgrade guide should have the steps on how to switch database engines - http://pubs.vmware.com/vsphere-50/topic/com.vmware.ICbase/PDF/vsphere-esxi-vcenter-server-50-upgrade...

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
Highlighted
Contributor
Contributor

Thanks for your reply....If I run the installer, I get

"The installation detects the current vCenter server database and the used ODBC driver. Check whether the correct database is displayed to avoid upgrading the incorrect database"

I have also read on other blogs that you can just upgrade the current VC.

the upgrade guide on pg 26 suggests we can do a in place upgrade of VC4.1.

Page 32 also suggests that After you upgrade to a database server that is supported by vCenter Server, you can install or upgrade to vCenter Server.

so this is confusing. Some sites suggests you can do a inplace upgrade while the guide says you can't use 2005 express edition.         

0 Kudos
Highlighted
Contributor
Contributor

0 Kudos
Highlighted
Expert
Expert

HI

The only MSSQL Express version supported by vSphere5 is 2008 but in docs is written:

You can perform a fresh installation of vCenter Server 5.0.

You cannot upgrade because vCenter Server 5.0 is the first release that supports Microsoft SQL Server 2008 Express.

looks like you have to do fresh installation not upgrade

VCDX77 My blog - http://vmwaremine.com
0 Kudos
Highlighted
Hot Shot
Hot Shot

Hi please follow the document which from where you can gain more confident .

http://www.vmware.com/pdf/vsp_vum_41_admin_guide.pdf

Yours,

Satya

0 Kudos