PerryWhittle
Enthusiast
Enthusiast

esx 6.5 installer not available

Jump to solution

Hi

ive inherited a 5.5.0 esx server and want to preserve it and I cant upgrade to 6.5 then 7.0 as I cant download the 6.5 installer, can anyone help please

Please rememeber to award points if you found this helpful or correct
0 Kudos
1 Solution

Accepted Solutions
jburen
Expert
Expert

If your datastore is VMFS5 then this is compatible with 7. The hardware version of the VMs shouldn't be a problem as well. See https://kb.vmware.com/s/article/2007240 The other way around is a bit harder (newer VM hardware on an older host). When you are done with the reinstall you can upgrade VMFS but that is not required. The same goes for the VM hardware version and VMware Tools.

 

Consider giving Kudos if you think my response helped you in any way.

View solution in original post

17 Replies
scott28tt
VMware Employee
VMware Employee

@PerryWhittle 

1. Check that all the hardware (system, CPU, IO devices) is compatible: https://www.vmware.com/resources/compatibility/search.php

2. Downloads are available to those with a license entitlement.

 

0 Kudos
e_espinel
Expert
Expert

Hello.
To download VMware software you need to have a user and password (free registration) and have a product you purchased registered.

https://my.vmware.com

You can obtain ISO image of VMware vSphere Hypervisor and Free license by clicking on the following links, if you do not have a user you can also obtain a free user. The free license has several limitations

https://my.vmware.com/en/web/vmware/evalcenter?p=free-esxi7

https://my.vmware.com/en/group/vmware/evalcenter?p=free-esxi6

https://kb.vmware.com/s/article/2107518

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

i'm aware of what you posted.

I have a v7.0 licence but need to get the machine there from 5.5.0 and need a 6.0 or 6.5 installer

Please rememeber to award points if you found this helpful or correct
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

no, the link you posted is 6.7 I need 6. or 6.5 but don't have media, I have a 7.0 licence but to get there from 5.5.0 I need a 6.0 or 6.50 installer to preserve the current install

Please rememeber to award points if you found this helpful or correct
0 Kudos
e_espinel
Expert
Expert

Hello.
If you have the v7.0 license registered in My VMware, you can enter with the user and password that registered this license and get the versions you need to migrate. Remember to validate your hardware because if it is very old it may not be compatible with the new versions of VMware vSphere.

When you install VMware vSphere, you get a 60-day Full Demo license. After this time or before you must enter either a Free license or a paid license.

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

I have logged with the user that has 7.0 license but do not get an option to obtain v6.0 or v6.5 media

Please rememeber to award points if you found this helpful or correct
0 Kudos
e_espinel
Expert
Expert

Hello.
choose download Product and then select the version you require

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

I get what you're saying but there is no where I can request a key for an older product this means that you cant download that product!!

Please rememeber to award points if you found this helpful or correct
0 Kudos
jburen
Expert
Expert

What exactly are you trying to preserve? Why is it not possible to reinstall the host with ESXi 7?

If the VMs are on local storage you can shut down the VMs. Then boot the host with an ESXi 7 image and do a clean install. When the host is up and running again you should be able to see the datastore and start the VMs. The only thing you should keep in mind that you select the correct partition on which to install ESXi7. DO NOT OVERWRITE YOUR DATASTORE...

When your VMs are on shared storage it's even easier. Move them to another host and reinstall the host with ESXi 7. Or shut them down and do the reinstall.

 

Consider giving Kudos if you think my response helped you in any way.
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

Hi

to preserve the vmfs doesn't it need to go through the appropriate upgrade paths. I don't mind selecting new install and preserve vmfs but will that allow vms running at 5.5.0 kernel level to boot and upgrade. Will allow the VMFS to upgrade through the versions too?

Please rememeber to award points if you found this helpful or correct
0 Kudos
jburen
Expert
Expert

If your datastore is VMFS5 then this is compatible with 7. The hardware version of the VMs shouldn't be a problem as well. See https://kb.vmware.com/s/article/2007240 The other way around is a bit harder (newer VM hardware on an older host). When you are done with the reinstall you can upgrade VMFS but that is not required. The same goes for the VM hardware version and VMware Tools.

 

Consider giving Kudos if you think my response helped you in any way.

View solution in original post

scott28tt
VMware Employee
VMware Employee

@PerryWhittle 

Have you downgraded the v7 license key to a v6 key?

 

0 Kudos
PerryWhittle
Enthusiast
Enthusiast

jburen, thank you

so i'll run the v7.0 install against my 5.5.0 esx server and select new install, preserve vmfs

thanks for the help

Please rememeber to award points if you found this helpful or correct
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

Jburen

ok all done, the disk had a default datastore on it (datastore1) and the installer warned it would get wiped. I decides to use a different disk anyway for my new esx partition. The vm is up and running but I do have some compatibility issues and will need new hardware before going up any further versions. For right here and now though, its all ok, thanks for your expert help👍

Please rememeber to award points if you found this helpful or correct
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

Everytime i tried to get 6.0 or 6.5 it took me to 6.7

the best solution was provided by jburen

Please rememeber to award points if you found this helpful or correct
0 Kudos
jburen
Expert
Expert

If the host had ESXi 5.5 it probably is a couple of years old 😉  So upgrading some parts (or the whole server) is not a bad idea. I'm glad you figured it out. Good luck!

 

Consider giving Kudos if you think my response helped you in any way.
0 Kudos
PerryWhittle
Enthusiast
Enthusiast

Its not an actual server its s custom built pc.

its complaining about pci compatibility so likely it means a new motherboard

Please rememeber to award points if you found this helpful or correct
0 Kudos