Enthusiast
Enthusiast

Windows VC 6.5 to VCSA 6.7 - Error while disabling jobs

Jump to solution

Hi Everyone, I've recently attempted to migrate a fairly small Windows vCenter implementation (embedded PSC & local SQL 2014 DB) to VCSA 6.7.

All the pre-migration checks come back fine, deployment of the VCSA is fine and all goes well.


Data and configuration export starts, the installer displays "Copy data from source vCenter to target vCenter Server" and is at 42%. then we get an error message with a vague resolution suggestion.

vcsa-error1.JPG

The logs pretty much just repeat the error message seen here, but with some specific details showing the most recent tasks. Specifically:

File "C:\mig51F4.tmp\PFiles\VMware\CIS\cis_upgrade_runner\payload\component-scripts\vcdb\vcdb_db_utils.py", line 883, in disable_jobs

  raise PermanentError(cause=error, resolution=sugg_action)

PermanentError: Error while disabling jobs: disable_jobs(cur_odbc, con_odbc, args.rdbms)

I've done quite a few VCSA migrations over the past year or so and not seen this before. Anyone got any thoughts?

Thanks in advance.

1 Solution

Accepted Solutions
Enthusiast
Enthusiast

if anyone's interested I got to the bottom of this.

Seems the SQL permissions for the user account used for the ODBC DSN had been modified from its original configuration. Consequently the user account didn't have the relevant permissions to the MSDB DB in order to query and disable jobs.

Once the DBAs assigned the correct permissions the migration went through fine.

_______________________________________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

4 Replies
Enthusiast
Enthusiast

if anyone's interested I got to the bottom of this.

Seems the SQL permissions for the user account used for the ODBC DSN had been modified from its original configuration. Consequently the user account didn't have the relevant permissions to the MSDB DB in order to query and disable jobs.

Once the DBAs assigned the correct permissions the migration went through fine.

_______________________________________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

Contributor
Contributor

我也遇到了这个问题,已解决。

建议:

1.查看vcenter系统 odbc数据库连接设置,给予数据库连接账户sysadmin权限。

2.将migration-assistant程序和文件夹放在C盘根目录,不要放在用户配置文件中,如桌面。

I also encountered this problem and it has been resolved.

Suggest:

1. View the vcenter system odbc database connection settings and give the database connection account sysadmin permissions.

2. Place migration-assistant programs and folders in the root directory of drive C, not in user configuration files, such as the desktop.

0 Kudos
Expert
Expert

Give yourself the credits you deserve and mark your answer as Correct Answer...

Consider giving Kudos if you think my response helped you in any way.
0 Kudos
VMware Employee
VMware Employee

Thank You.

This should be helpful for others who are looking for the same error.


Regards,

Jonathan

Regards
Jonathan
Install-Upgrade Specialist
0 Kudos