vicodas
Contributor
Contributor

VMware Tools are to old

Hi,

what is the aktual Version of VMwareTools for ESX 4.0U2 ( 244038)?

I install the tools from /vmimages/tools-isoimages/linux.iso on ESX Host, this is Version 4.0.0 build-261974 and the VC say Tools Status is old...

thx

vicodas

0 Kudos
11 Replies
VTsukanov
Virtuoso
Virtuoso

Build number for ESX 4.0 U2 and ESXi 4.0 U2 is 261974, not 244038.

Are you sure that version your ESX is 244038?

Inconsistency in version ESX and vmware tools may be reason of message about old tools.

How did you install vmware tools, from rpm or from source code?

0 Kudos
Troy_Clavell
Immortal
Immortal

what is the aktual Version of VMwareTools for ESX 4.0U2 ( 244038)?

244038 is U1, not U2

see below to get detailed build information

http://kb.vmware.com/kb/1012514

0 Kudos
vicodas
Contributor
Contributor

sorry a was not of the right ESX Host.

The Version is 4.0.0 261974.

I Ioad the tools from the ESX Host with Version 261974, but the version of Tool ist build-261974 and the VC say Tools Status is old.

I install the tools from Source and build an Debian Lenny Host.

(VMwareTools-4.0.0-261974.tar.gz)

unpack & vmware-install.pl

how can i see which version is on my linux installed?

0 Kudos
VTsukanov
Virtuoso
Virtuoso

You can check the current version of vmware tools using RVTools. I have not ever installed vmware tools on Debian Lenny in ESX 4.0U2. But in ESX 3.5u5 you had to :

1. Set the correct type of vm (in vm settings) (Debian GNU/Linux 5 32/64bit)

2. In menu vm select item "Install vmware tools"

3. The further steps are described in the following instruction - Installing VMware tools on lenny (don't pay attention that this instruction describes installation steps for vmware server, it suits ESX)

0 Kudos
vicodas
Contributor
Contributor

the probleme are an update older Tollinstallation to the currend.

On a new maschine the tolls are correct???

I analyse this problem.

It is on all machins ;-(

0 Kudos
VTsukanov
Virtuoso
Virtuoso

It's strange.... Usually perl installation script (./vmware-install.pl) uninstalls old version tools and installs new version tools.

Which type of OS is set in vm settings?

0 Kudos
vicodas
Contributor
Contributor

Debian GNU/Linux 5 (32-Bit)

It's the currend OS.

0 Kudos
VTsukanov
Virtuoso
Virtuoso

Try upgrade vmware tools using the instruction about reinstallation of vmware tools which was given above.

0 Kudos
vicodas
Contributor
Contributor

I do that...

INSTALLING/UPGRADING

To install/upgrade VMware Tools for Linux,

run the program "vmware-install.pl" from a command prompt, either in text

mode or from a terminal inside an X session. You must have super user

privileges (i.e. be logged as root) to run it.

./vmware-install.pl

0 Kudos
VTsukanov
Virtuoso
Virtuoso

Yes, you have to perform necessary prerequisites (install gcc & header for your version kernel) and execute the command "./vmware-install.pl" as a root.

Take a look for detail Installing VMware tools on lenny

0 Kudos
vicodas
Contributor
Contributor

i has the same problem with the upgrade to 4.1 tools.

The solution is after the vmware-install.pl scprit execute the vmware-tools-upgrader binary.

0 Kudos