craftyp
Contributor
Contributor

VM clone from ESX to ESXi not working

Joined a new company and all the hosts here are ESX 4.1.  I need to add a host and so went with ESXi 4.1.  Now I am trying to clone a VM from one of the old ESX to the new ESXi and it fails with a cannot connect to host error.  Tried to migrate a powered off VM and got the same error.

Found a post that talked about the IP address having changed but the steps were not there for ESXi 4.1 and since this is brand new I don't think the IP address has actually changed.

0 Kudos
4 Replies
craftyp
Contributor
Contributor

This has been incredibly frustrating.  Found this KB article that basically says the IP address has changed in the vpxa.cfg file.   I didn't think that possible since I just built the machine but low and behold it is.  The vpxa.cfg has a 192.x.x.x address when it should be 10.x.x.x

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=101083...

I followed the instruction in the file, as best I could, but the problem persists.  I know I modified the /etc/opt/vmware/vpxa/vpxa.cfg file with the correct IP address but when vpxa starts it must build that file from somewhere else because it puts it right back to the wrong address again.

The instructions in the KB are for ESX or ESXi 5 but I am running ESXi 4.1.  It says to do "/etc/init.d/vpxa start" but the closest I could get to that was to do "services.sh start".  Could this be the issue?  Or am I editing the wrong file?  Where is /etc/opt/vmware/vpxa/vpxa.cfg getting the IP address?

0 Kudos
a_p_
Leadership
Leadership

To configure the IP address for the host you don't want to edit files, but login to the DCUI (yellow/gray console) and edit the network setting there.

André

0 Kudos
craftyp
Contributor
Contributor

That is actually how the IP was set.  So even though the DCUI shows the correct address, the wrong address was in the vpxa.cfg and the clone fails.  

0 Kudos
craftyp
Contributor
Contributor

There was a note about turning off SSL before doing this.  Tried that and the IP still didn't hold.  But I think I might have skipped a step so I went through it once again and that time it worked.  

0 Kudos