jp3457
Contributor
Contributor

VCSA 6.7 to 7 upgrade fails

Jump to solution

Trying to upgrade from a VCSA 6.7 to 7.0.  I was able to deploy the new appliance via step 1.

At step 2 (Upgrade) I'm getting the following error:

"Certificate validation failed during pre-upgrade check"

I checked the KB VMware Knowledge Base but confused on where I'm supposed to run the commands listed here.

As far as I can tell though, my self-signed cert on the existing 6.7 appliance is still valid.

Is there a way to get around/fix this certificate error?

0 Kudos
1 Solution

Accepted Solutions
daphnissov
Immortal
Immortal

The 6.7 appliance. You have to fix the cert issue before you attempt the migration again.

____________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

0 Kudos
5 Replies
scott28tt
VMware Employee
VMware Employee

Moderator: Thread moved to the vSphere Upgrade & Install area.

0 Kudos
daphnissov
Immortal
Immortal

As stated in the KB to which you linked, they need to be run on the appliance itself.

0 Kudos
jp3457
Contributor
Contributor

On which appliance, the existing 6.7 or the new 7.0?

0 Kudos
daphnissov
Immortal
Immortal

The 6.7 appliance. You have to fix the cert issue before you attempt the migration again.

____________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

0 Kudos
jp3457
Contributor
Contributor

That got it.  Thank you!!!

I wasn't sure where to run those commands and was a bit confused since the cert on the 6.7 VCSA wasn't expired.

I appreciate the assist.

0 Kudos