wilkinsontech
Contributor
Contributor

Upgrade from VCSA 6.7 to 7.0 failure

Jump to solution

I am attempting to upgrade my VCSA 6.7.0.45000 instance to 7.0.  I've made a number of attempts, none have succeeded.  Each attempt ended with the error

==========VCSA Deployment Progress Report==========        

Task: Install required RPMs for the appliance.(SUCCEEDED 100/100)       - Task has completed successfully.        

Task: Run appliance precheck.(FAILED 0/100)     -                 

Error: Cannot validate target appliance configuration as not enough information from the source appliance can be collected.

In order to diagnose better, I attempted to upgrade with the cli script so I could actually see what it was doing.  At the end of the run, I get an exception that I think is the crux of the problem, but I have no idea what to do about it. As seen below, the start time is correct, but the end time appears to have gone to the beginning of the epoch.  i have ntp running on the 6.7 VCSA and have manually sync'd it.  I've also verified ntp on my ESXi nodes. 

Exception message: The VCSA deployment has failed VCSA Deployment Start Time: 2020-09-17T18:55:20.256Z VCSA Deployment End Time: 1970-01-01T00:00:00.000Z

I'm not sure where else to look for a solution, I haven't been able to turn up answers with Google.

1 Solution

Accepted Solutions
wilkinsontech
Contributor
Contributor

Well, I did look at the things that Nawals and a.p. suggested.  But the thing that actually made this work, and my mind is blown, is the original vCSA had a capital letter in its name.  I changed that and it ran smoothly all the way through.  I'm now on 7.0. Thanks folks!

_______________________________________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

6 Replies
Nawals
Expert
Expert

Hi,

Do you have IPv6 disabled on the source? Maybe it helps to enable it for the upgrade!?

NKS Please Mark Helpful/correct if my answer resolve your query.
0 Kudos
wilkinsontech
Contributor
Contributor

I have IPv6 enabled on the ESXi boxes.  I've been trying to enable it on the VCSA as well, but I don't use ipv6 on my network yet, so every time I try to get it set up, I wind up without a functioning default gateway.

0 Kudos
a_p_
Leadership
Leadership

Just to rule that out. Please confirm that neither the root password, nor the administrator@vsphere.local password have expired.

André

0 Kudos
Nawals
Expert
Expert

check as a.p said about root and administrator@vsphere.local not expired. Also, I would suggest to change the root password of source vCenter and reboot, then try it.

NKS Please Mark Helpful/correct if my answer resolve your query.
0 Kudos
wilkinsontech
Contributor
Contributor

Well, I did look at the things that Nawals and a.p. suggested.  But the thing that actually made this work, and my mind is blown, is the original vCSA had a capital letter in its name.  I changed that and it ran smoothly all the way through.  I'm now on 7.0. Thanks folks!

_______________________________________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

Nawals
Expert
Expert

Great.

NKS Please Mark Helpful/correct if my answer resolve your query.
0 Kudos