Highlighted
Contributor
Contributor

Upgrade from ESX 4.1 to ESX 4.1 U1

Hello,

Yesterday, I did an upgrade from ESX 4.1 to ESX 4.1 U1 on a cluster of 2 hosts.

I selected the host patch "VMWare ESX 4.1 Complete Update 1" in Update Manager.

At the beginning, the host compliance showed that the 2 hosts were incompatible.

I did a stage of the patch and then the hosts became non-compliant. After doing a remediate, the hosts appeared compliant.

My question : is is normal that at the beginning (before the staging) the update was showed as incompatible ?

Thanks in advance for your answers.

VMGuy.

0 Kudos
8 Replies
Highlighted
Contributor
Contributor

We are having the same issue. I have imported the ISO and scanned a couple hosts, the upgrade shows as incompatable for 4.1. I have not staged it or ran the upgrade yet.

0 Kudos
Highlighted
Expert
Expert

Once you created the base line and attach the host, the patches will show in the incompatibile state. Once you scan the baseline against host/cluster, it will check the compatibility of patches with ESX/ESXi host and will show the status non-compliant if you the base line ready for install in RED color.

After the installation of patches the baseline will show in Compliant status GREEN in color. This is expected behavior.

Thanks

Nithin

--Nithin
0 Kudos
Highlighted
Expert
Expert

Also during the staging time of the baseline. the Update manager will first do a scan operation on host against the baseline and then do the staging. So the baseline will show its status as non-compliant.

Thanks

Nithin

--Nithin
0 Kudos
Highlighted
Enthusiast
Enthusiast

My understanding is once you attach a baseline (which is not yet applied or previously scanned) it will show up as 'gray -- unknown'

Then once you scan it, it should turn 'red -- non-compliant'

Then once you remediate it will turn 'green -- compliant'

My problem is when I try to update from ESX 4.1 to ESX 4.1 Update 1..

I both allowed Update Manager to download from VMware.com’s repository and made a baseline and I tried to import "update-from-esx4.1-4.1_update01.zip"

By using a 'Host Patch Baseline'  -- Type Fixed -- Then attached the patch as shown below..

Then when, I do the patch scan and I am getting a 'yellow - incompatible'...

I might have to call this in, Im not sure what is going on..

VMware VCP 3.5 VMware VCP 4.0 VMware VCP 5.0
0 Kudos
Highlighted
Contributor
Contributor

Jreininger -

You indicated that you're upgrading from 4.1 to 4.1 Update 1, but your baseline shows 4.0 to 4.1 update 1; hence it's not compatible.  You should download the ISO file, not the ZIP file.

ESX 4.1 Update 1 (DVD ISO)
Boot your server with this DVD ISO in order to install ESX 4.1 Update 1. Use this DVD ISO with vCenter Update Manager to upgrade from ESX 3.5 Update 5a to ESX 4.1 Update1.

- Hieu

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hieu.

You have good Eagle Eyes, that is just the name I gave the baseline I created, which I will go rename now. But the fact of the matter is the patch attached to my baseline was the correct patch (which is shown in the 2nd image)...

My host was 4.1 (ie build #258902), I just had the same exact problem that vmguy1 listed, but it remeidated just fine from UpdateManager own pulled repository..

VMware VCP 3.5 VMware VCP 4.0 VMware VCP 5.0
0 Kudos
Highlighted
Contributor
Contributor

Hello, i have the same problem as you. What exactly is the solution for that?

thanks a lot

0 Kudos
Highlighted
Contributor
Contributor

Hello,

I only had 2 clusters to update from 4.1 to 4.1 U1. Except for the first status which was incompatible, it worked fine.

The other hosts have been upgraded from 4.0U2 to 4.1U1 by using the ZIP file. I had no issues at all.

Cheers.

0 Kudos