Hot Shot
Hot Shot

Upgrade HP Gen8 ESXi 6 to 6.5 using Update Manager 6.7

Jump to solution

Hello,

I have two HP Gen8 servers that are not in the compatibility matrix for anything newer than ESXi 6.5.  I downloaded both an offline bundle zip (HPE-ESXi-6.5.0-Update2-preGen9-650.U2.9.8.3) and also an ISO as well.

First in vSphere 6.7 under Update Mnager > ESX images, I tried to upload the .ISO file VMware-ESXi-6.5.0-Update3-14990892-HPE-preGen9-650.U3.9.6.10.1-Dec2019.iso, and it uploads ok but then I get an error message in the recent tasks list that says "The uploaded upgrade package cannot be used with VMware vSphere Update Manager".  It does not say why and there are no further details.

So then I thought maybe I can use the zip file, so I uploaded the offline zip file in Update Manager under the updates tab.  It show sup there now at the very end of page 8 of all of my updates.  I created a baseline called 6.5 upgrade, and found that patch and added it in.  I attached this baseline to one of the HP servers that needs it and when I do a compliance check its not coming up as non-compliant.  In short, VUM doesn't think the 6.0 ESXi needs it.

Whats the best way to upgrade two ESXi 6.0 to 6.5 under vCenter 6.7?

0 Kudos
1 Solution

Accepted Solutions
Virtuoso
Virtuoso

That problem is very common.  Over the time it looks like that some drivers get lost.....

esxcli software vib list | grep 500

and than just uninstall them

esxcli software vib remove -n DRIVERNAME1 -n DRIVERNAME2 -n DRIVERNAME3

Reboot and try again or just insert the ISO and do a Upgrade.

Regards,
Joerg

_______________________________________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

0 Kudos
10 Replies
Immortal
Immortal

VUM is only capable of accepting images, regardless of the format, of the same target version. To upgrade a 6.0 host to a 6.5 version, you won't be able to do it through VUM. You'll probably have to do it manually outside of VUM/vCenter by doing an upgrade with the depot in hand and through esxcli.

0 Kudos
Leadership
Leadership

I've explained the basic steps for a manual upgrade in Re: Update VM ESXI 6.5 Update 1 to EXSI 6.5 Update 2

What you need to do is to evacuate the host (i.e. place it into maintenance mode) before you run the upgrade, and - once the upgrade command completes successfully - enter reboot to restart the host. That's actually also a good time to update the host's firmware, using e.g. HPE's SPP.


André

0 Kudos
Expert
Expert

Best way you can upgrade using offline bundle. Below the procedure to upgrade via esxcli using offline bundle.

  • Download offline bundle from VMware portal
  • upload to datastore
  • enable SSH
  • login to host
  • put host MM mode
  • run  esxcli software sources profile list -d "/vmfs/volumes/5b48662e-e1e205e8-92b7-0017a477240c/ISO/VMware-ESXi-6.5.0-Update1-6765664-HPE-650.U1.9.6.5.1-Nov2017-depot.zip"
  • then you can get the profile name like below

Name                                   Vendor                      Acceptance Level-------------------------------------  --------------------------  ----------------HPE-ESXi-6.5.0-Update1-650.U1.9.6.5.1  Hewlett Packard Enterprise  PartnerSupported

  • then run command to upgrade the ESXi as show below.

# esxcli software profile update -d /vmfs/volumes/5b48662e-e1e205e8-92b7-0017a477240c/ISO/VMware-ESXi-6.5.0-Update1-6765664-HPE-650.U1.9.6.5.1-Nov2017-depot.zip -p Prfilename as show above in red color

#

Update Result

   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

   Reboot Required: true

# reboot

Note: All above given example. You can change path and profile name according to your environment if you like to use esxcli.

NKS Please Mark Helpful/correct if my answer resolve your query.
0 Kudos
Hot Shot
Hot Shot

Ok I tried the --dry-run flag to see what it would say before actually doing it and I did get two dependencies:

esxcli software profile update -d /vmfs/volumes/1fe43b18-44f1ee63/iso/VMware-ESXi-6.5.0-Update3-14990892

-HPE-preGen9-650.U3.9.6.10.1-Dec2019-depot.zip -p HPE-ESXi-6.5.0-Update3-preGen9-650.U3.9.6.10.1 --dry-run

[DependencyError]

VIB Emulex_bootbank_scsi-lpfc820_8.2.4.151.65-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB Emulex_bootbank_scsi-lpfc820_8.2.4.151.65-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

Not sure if I should proceed without the --dry-run or not.  I dont recall having any Emulex controllers in this box.

In iLO it just shows a Smart Array P420i Controller 4 drive bays, 500GB drive in bay 1 and 2, Raid1.  Its just to boot off of.  All the VM's are on an NFS connected storage array.

0 Kudos
Hot Shot
Hot Shot

I could force it, dry run shows this would be done if I use -f

/vmfs/volumes/1fe43b18-44f1ee63/iso] esxcli software profile update -d /vmfs/volumes/1fe43b18-44f1ee63/iso/VMware-ESXi-6.5.0-Update3-14990892

-HPE-preGen9-650.U3.9.6.10.1-Dec2019-depot.zip -p HPE-ESXi-6.5.0-Update3-preGen9-650.U3.9.6.10.1 -f --dry-run

Update Result

   Message: Dryrun only, host not changed. The following installers will be applied: [BootBankInstaller, LockerInstaller]

   Reboot Required: true

   VIBs Installed: Avago_bootbank_scsi-mpt2sas_15.10.07.00-1OEM.550.0.0.1331820, ELX_bootbank_elx-esx-libelxima.so_11.1.216.0-03, EMU_bootbank_elxiscsi_11.1.216.0-1OEM.650.0.0.4240417, EMU_bootbank_elxnet_11.1.196.3-1OEM.650.0.0.4240417, EMU_bootbank_lpfc_11.1.257.0-1OEM.650.0.0.4598673, HPE_bootbank_amshelper_650.10.6.0-24.4240417, HPE_bootbank_conrep_6.0.0.01-02.00.1.2494585, HPE_bootbank_hpe-cru_650.6.5.8.24-1.4240417, HPE_bootbank_hpe-esxi-fc-enablement_650.2.6.10-4240417, HPE_bootbank_hpe-ilo_650.10.0.2-2.4240417, HPE_bootbank_hpe-nmi_600.2.4.16-2494575, HPE_bootbank_hpe-smx-provider_650.03.11.00.17-4240417, HPE_bootbank_hponcfg_6.0.0.4.4-2.4.2494585, HPE_bootbank_oem-build_650.U3.9.6.10-4240417, HPE_bootbank_scsi-hpdsa_5.5.0.54-1OEM.550.0.0.1331820, HPE_bootbank_scsi-hpvsa_5.5.0.102-1OEM.550.0.0.1331820, HPE_bootbank_ssacli_2.60.18.0-6.0.0.2494585, Microsemi_bootbank_nhpsa_2.0.28-1OEM.650.0.0.4598673, QLC_bootbank_qedentv_3.0.4.13-1OEM.650.0.0.4240417, QLC_bootbank_qfle3_1.0.28.0-1OEM.650.0.0.4240417, QLogic_bootbank_misc-cnic-register_1.713.10.v60.1-1OEM.600.0.0.2494585, QLogic_bootbank_net-bnx2_2.2.6a.v60.4-1OEM.600.0.0.2494585, QLogic_bootbank_net-bnx2x_2.713.10.v60.4-1OEM.600.0.0.2494585, QLogic_bootbank_net-cnic_2.713.20.v60.5-1OEM.600.0.0.2494585, QLogic_bootbank_scsi-bnx2fc_1.713.20.v60.4-1OEM.600.0.0.2494585, QLogic_bootbank_scsi-bnx2i_2.713.10.v60.3-1OEM.600.0.0.2494585, VMW_bootbank_ata-libata-92_3.00.9.2-16vmw.650.0.0.4564106, VMW_bootbank_ata-pata-amd_0.3.10-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-atiixp_0.4.6-4vmw.650.0.0.4564106, VMW_bootbank_ata-pata-cmd64x_0.2.5-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-pdc2027x_1.0-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-serverworks_0.4.3-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-sil680_0.4.8-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-via_0.3.3-2vmw.650.0.0.4564106, VMW_bootbank_block-cciss_3.6.14-10vmw.650.0.0.4564106, VMW_bootbank_bnxtnet_20.6.101.7-23vmw.650.3.96.13932383, VMW_bootbank_char-random_1.0-3vmw.650.0.0.4564106, VMW_bootbank_ehci-ehci-hcd_1.0-4vmw.650.0.14.5146846, VMW_bootbank_hid-hid_1.0-3vmw.650.0.0.4564106, VMW_bootbank_i40en_1.8.1.9-2vmw.650.3.96.13932383, VMW_bootbank_igbn_0.1.1.0-4vmw.650.3.96.13932383, VMW_bootbank_ipmi-ipmi-devintf_39.1-5vmw.650.2.50.8294253, VMW_bootbank_ipmi-ipmi-msghandler_39.1-5vmw.650.2.50.8294253, VMW_bootbank_ixgben_1.7.1.15-1vmw.650.3.96.13932383, VMW_bootbank_lsi-mr3_7.708.07.00-3vmw.650.3.96.13932383, VMW_bootbank_lsi-msgpt35_09.00.00.00-5vmw.650.3.96.13932383, VMW_bootbank_lsi-msgpt3_17.00.02.00-1vmw.650.3.96.13932383, VMW_bootbank_misc-drivers_6.5.0-3.96.13932383, VMW_bootbank_mtip32xx-native_3.9.5-1vmw.650.0.0.4564106, VMW_bootbank_ne1000_0.8.3-8vmw.650.2.75.10884925, VMW_bootbank_nenic_1.0.29.0-1vmw.650.3.96.13932383, VMW_bootbank_net-cdc-ether_1.0-3vmw.650.0.0.4564106, VMW_bootbank_net-e1000_8.0.3.1-5vmw.650.0.0.4564106, VMW_bootbank_net-e1000e_3.2.2.1-2vmw.650.0.0.4564106, VMW_bootbank_net-enic_2.1.2.38-2vmw.650.0.0.4564106, VMW_bootbank_net-fcoe_1.0.29.9.3-7vmw.650.0.0.4564106, VMW_bootbank_net-forcedeth_0.61-2vmw.650.0.0.4564106, VMW_bootbank_net-libfcoe-92_1.0.24.9.4-8vmw.650.0.0.4564106, VMW_bootbank_net-mlx4-core_1.9.7.0-1vmw.650.0.0.4564106, VMW_bootbank_net-mlx4-en_1.9.7.0-1vmw.650.0.0.4564106, VMW_bootbank_net-usbnet_1.0-3vmw.650.0.0.4564106, VMW_bootbank_net-vmxnet3_1.1.3.0-3vmw.650.0.0.4564106, VMW_bootbank_nmlx4-core_3.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_nmlx4-en_3.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_nmlx4-rdma_3.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_nmlx5-core_4.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_ntg3_4.1.3.2-1vmw.650.2.75.10884925, VMW_bootbank_nvme_1.2.2.28-1vmw.650.3.96.13932383, VMW_bootbank_nvmxnet3_2.0.0.23-1vmw.650.1.36.7388607, VMW_bootbank_ohci-usb-ohci_1.0-3vmw.650.0.0.4564106, VMW_bootbank_pvscsi_0.1-1vmw.650.1.26.5969303, VMW_bootbank_qflge_1.1.0.3-1vmw.650.0.0.4564106, VMW_bootbank_sata-ata-piix_2.12-10vmw.650.0.0.4564106, VMW_bootbank_sata-sata-nv_3.5-4vmw.650.0.0.4564106, VMW_bootbank_sata-sata-promise_2.12-3vmw.650.0.0.4564106, VMW_bootbank_sata-sata-sil24_1.1-1vmw.650.0.0.4564106, VMW_bootbank_sata-sata-sil_2.3-4vmw.650.0.0.4564106, VMW_bootbank_sata-sata-svw_2.3-3vmw.650.0.0.4564106, VMW_bootbank_scsi-aacraid_1.1.5.1-9vmw.650.0.0.4564106, VMW_bootbank_scsi-adp94xx_1.0.8.12-6vmw.650.0.0.4564106, VMW_bootbank_scsi-aic79xx_3.1-5vmw.650.0.0.4564106, VMW_bootbank_scsi-fnic_1.5.0.45-3vmw.650.0.0.4564106, VMW_bootbank_scsi-ips_7.12.05-4vmw.650.0.0.4564106, VMW_bootbank_scsi-iscsi-linux-92_1.0.0.2-3vmw.650.0.0.4564106, VMW_bootbank_scsi-libfc-92_1.0.40.9.3-5vmw.650.0.0.4564106, VMW_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.650.0.0.4564106, VMW_bootbank_scsi-megaraid-sas_6.603.55.00-2vmw.650.0.0.4564106, VMW_bootbank_scsi-megaraid2_2.00.4-9vmw.650.0.0.4564106, VMW_bootbank_scsi-mptsas_4.23.01.00-10vmw.650.0.0.4564106, VMW_bootbank_scsi-mptspi_4.23.01.00-10vmw.650.0.0.4564106, VMW_bootbank_shim-iscsi-linux-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-iscsi-linux-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libata-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libata-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfc-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfc-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfcoe-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfcoe-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-vmklinux-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-vmklinux-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-vmklinux-9-2-3-0_6.5.0-0.0.4564106, VMW_bootbank_smartpqi_1.0.1.553-28vmw.650.3.96.13932383, VMW_bootbank_uhci-usb-uhci_1.0-3vmw.650.0.0.4564106, VMW_bootbank_usb-storage-usb-storage_1.0-3vmw.650.0.0.4564106, VMW_bootbank_usbcore-usb_1.0-3vmw.650.2.50.8294253, VMW_bootbank_vmkata_0.1-1vmw.650.1.36.7388607, VMW_bootbank_vmkplexer-vmkplexer_6.5.0-0.0.4564106, VMW_bootbank_vmkusb_0.1-1vmw.650.3.96.13932383, VMW_bootbank_vmw-ahci_1.1.6-1vmw.650.3.96.13932383, VMW_bootbank_xhci-xhci_1.0-3vmw.650.0.0.4564106, VMware_bootbank_cpu-microcode_6.5.0-3.108.14990892, VMware_bootbank_emulex-esx-elxnetcli_11.1.28.0-0.0.4564106, VMware_bootbank_esx-base_6.5.0-3.108.14990892, VMware_bootbank_esx-dvfilter-generic-fastpath_6.5.0-1.36.7388607, VMware_bootbank_esx-tboot_6.5.0-3.108.14990892, VMware_bootbank_esx-xserver_6.5.0-2.50.8294253, VMware_bootbank_lsu-hp-hpsa-plugin_2.0.0-16vmw.650.3.96.13932383, VMware_bootbank_lsu-lsi-drivers-plugin_1.0.0-1vmw.650.2.79.11925212, VMware_bootbank_lsu-lsi-lsi-mr3-plugin_1.0.0-11vmw.650.2.75.10884925, VMware_bootbank_lsu-lsi-lsi-msgpt3-plugin_1.0.0-8vmw.650.2.79.11925212, VMware_bootbank_lsu-lsi-megaraid-sas-plugin_1.0.0-8vmw.650.1.26.5969303, VMware_bootbank_lsu-lsi-mpt2sas-plugin_2.0.0-6vmw.650.1.26.5969303, VMware_bootbank_native-misc-drivers_6.5.0-0.0.4564106, VMware_bootbank_rste_2.0.2.0088-4vmw.650.0.0.4564106, VMware_bootbank_vmware-esx-esxcli-nvme-plugin_1.2.0.36-3.96.13932383, VMware_bootbank_vsan_6.5.0-3.108.14833668, VMware_bootbank_vsanhealth_6.5.0-3.108.14833669, VMware_locker_tools-light_6.5.0-2.92.13873656

  

     VIBs Removed: EMU_bootbank_elxnet_10.7.110.13-1OEM.600.0.0.2768847, EMU_bootbank_lpfc_10.7.110.4-1OEM.600.0.0.2768847, EMU_bootbank_scsi-be2iscsi_10.7.110.10-1OEM.600.0.0.2159203, HPE_bootbank_amsHelper_600.10.4.0-22.2494585, HPE_bootbank_conrep_6.0.0.01-01.00.7.2494585, HPE_bootbank_hpe-build_600.9.5.0.48-2494585, HPE_bootbank_hpe-esxi-fc-enablement_600.2.5.20-2494585, HPE_bootbank_hpe-ilo_600.10.0.0.26-1OEM.600.0.0.2494585, HPE_bootbank_hpe-smx-provider_600.03.10.00.13-2768847, HPE_bootbank_hponcfg_6.0.0.04-00.14.4.2494585, Hewlett-Packard_bootbank_char-hpcru_6.0.6.14-1OEM.600.0.0.2159203, Hewlett-Packard_bootbank_hpnmi_600.2.3.14-2159203, Hewlett-Packard_bootbank_scsi-hpdsa_5.5.0.48-1OEM.550.0.0.1331820, Hewlett-Packard_bootbank_scsi-hpvsa_5.5.0.100-1OEM.550.0.0.1331820, LSI_bootbank_scsi-mpt2sas_15.10.06.00.1vmw-1OEM.500.0.0.472560, MEL_bootbank_nmlx4-core_3.1.0.0-1OEM.600.0.0.2348722, MEL_bootbank_nmlx4-en_3.1.0.0-1OEM.600.0.0.2348722, QLogic_bootbank_misc-cnic-register_1.712.70.v60.1-1OEM.600.0.0.2494585, QLogic_bootbank_net-bnx2_2.2.5k.v60.1-1OEM.600.0.0.2494585, QLogic_bootbank_net-bnx2x_2.712.70.v60.3-1OEM.600.0.0.2494585, QLogic_bootbank_net-cnic_2.712.70.v60.3-1OEM.600.0.0.2494585, QLogic_bootbank_scsi-bnx2fc_1.712.70.v60.5-1OEM.600.0.0.2494585, QLogic_bootbank_scsi-bnx2i_2.712.70.v60.2-1OEM.600.0.0.2494585, VMWARE_bootbank_mtip32xx-native_3.8.5-1vmw.600.0.0.2494585, VMware_bootbank_ata-pata-amd_0.3.10-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-atiixp_0.4.6-4vmw.600.0.0.2494585, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-via_0.3.3-2vmw.600.0.0.2494585, VMware_bootbank_block-cciss_3.6.14-10vmw.600.0.0.2494585, VMware_bootbank_cpu-microcode_6.0.0-3.135.15018929, VMware_bootbank_ehci-ehci-hcd_1.0-4vmw.600.3.69.5572656, VMware_bootbank_emulex-esx-elxnetcli_10.2.309.6v-0.0.2494585, VMware_bootbank_esx-base_6.0.0-3.138.15169789, VMware_bootbank_esx-dvfilter-generic-fastpath_6.0.0-3.79.6921384, VMware_bootbank_esx-tboot_6.0.0-3.57.5050593, VMware_bootbank_esx-xserver_6.0.0-3.76.6856897, VMware_bootbank_ipmi-ipmi-devintf_39.1-5vmw.600.3.79.6921384, VMware_bootbank_ipmi-ipmi-msghandler_39.1-5vmw.600.3.79.6921384, VMware_bootbank_lsi-mr3_6.605.08.00-7vmw.600.1.17.3029758, VMware_bootbank_lsi-msgpt3_06.255.12.00-9vmw.600.3.129.14513180, VMware_bootbank_lsu-hp-hpsa-plugin_2.0.0-14vmw.600.3.129.14513180, VMware_bootbank_lsu-lsi-lsi-mr3-plugin_1.0.0-3vmw.600.3.57.5050593, VMware_bootbank_lsu-lsi-lsi-msgpt3-plugin_1.0.0-1vmw.600.0.0.2494585, VMware_bootbank_lsu-lsi-megaraid-sas-plugin_1.0.0-3vmw.600.3.57.5050593, VMware_bootbank_lsu-lsi-mpt2sas-plugin_1.0.0-4vmw.600.1.17.3029758, VMware_bootbank_misc-drivers_6.0.0-3.129.14513180, VMware_bootbank_net-e1000_8.0.3.1-5vmw.600.0.0.2494585, VMware_bootbank_net-e1000e_3.2.2.1-2vmw.600.3.57.5050593, VMware_bootbank_net-enic_2.1.2.38-2vmw.600.0.0.2494585, VMware_bootbank_net-forcedeth_0.61-2vmw.600.0.0.2494585, VMware_bootbank_net-mlx4-core_1.9.7.0-1vmw.600.0.0.2494585, VMware_bootbank_net-mlx4-en_1.9.7.0-1vmw.600.0.0.2494585, VMware_bootbank_net-vmxnet3_1.1.3.0-3vmw.600.2.43.4192238, VMware_bootbank_nmlx4-rdma_3.0.0.0-1vmw.600.0.0.2494585, VMware_bootbank_nvme_1.2.0.27-4vmw.550.0.0.1331820, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.600.0.0.2494585, VMware_bootbank_rste_2.0.2.0088-4vmw.600.0.0.2494585, VMware_bootbank_sata-ata-piix_2.12-10vmw.600.0.0.2494585, VMware_bootbank_sata-sata-nv_3.5-4vmw.600.0.0.2494585, VMware_bootbank_sata-sata-promise_2.12-3vmw.600.0.0.2494585, VMware_bootbank_sata-sata-sil24_1.1-1vmw.600.0.0.2494585, VMware_bootbank_sata-sata-sil_2.3-4vmw.600.0.0.2494585, VMware_bootbank_sata-sata-svw_2.3-3vmw.600.0.0.2494585, VMware_bootbank_scsi-aacraid_1.1.5.1-9vmw.600.0.0.2494585, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.600.0.0.2494585, VMware_bootbank_scsi-aic79xx_3.1-5vmw.600.0.0.2494585, VMware_bootbank_scsi-fnic_1.5.0.45-3vmw.600.0.0.2494585, VMware_bootbank_scsi-ips_7.12.05-4vmw.600.0.0.2494585, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.600.0.0.2494585, VMware_bootbank_scsi-megaraid-sas_6.603.55.00-2vmw.600.0.0.2494585, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.600.0.0.2494585, VMware_bootbank_scsi-mptsas_4.23.01.00-9vmw.600.0.0.2494585, VMware_bootbank_scsi-mptspi_4.23.01.00-9vmw.600.0.0.2494585, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.600.0.0.2494585, VMware_bootbank_vsan_6.0.0-3.138.15080872, VMware_bootbank_vsanhealth_6.0.0-3000000.3.0.3.138.15080873, VMware_bootbank_xhci-xhci_1.0-3vmw.600.3.129.14513180, VMware_locker_tools-light_6.0.0-3.125.14475122

  

     VIBs Skipped: HPE_bootbank_hpbootcfg_6.0.0.02-02.00.6.2494585, HPE_bootbank_hptestevent_6.0.0.01-01.00.5.2494585, QLogic_bootbank_qlnativefc_2.1.50.0-1OEM.600.0.0.2768847, VMW_bootbank_ima-qla4xxx_2.02.18-1vmw.650.0.0.4564106, VMW_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.650.0.0.4564106, VMW_bootbank_net-igb_5.0.5.1.1-5vmw.650.0.0.4564106, VMW_bootbank_net-ixgbe_3.7.13.7.14iov-20vmw.650.0.0.4564106, VMW_bootbank_net-nx-nic_5.0.621-5vmw.650.0.0.4564106, VMW_bootbank_net-tg3_3.131d.v60.4-2vmw.650.0.0.4564106, VMW_bootbank_sata-ahci_3.0-26vmw.650.1.26.5969303, VMW_bootbank_scsi-qla4xxx_5.01.03.2-7vmw.650.0.0.4564106, VMware_bootbank_esx-ui_1.33.4-13786312

0 Kudos
Virtuoso
Virtuoso

That problem is very common.  Over the time it looks like that some drivers get lost.....

esxcli software vib list | grep 500

and than just uninstall them

esxcli software vib remove -n DRIVERNAME1 -n DRIVERNAME2 -n DRIVERNAME3

Reboot and try again or just insert the ISO and do a Upgrade.

Regards,
Joerg

_______________________________________________________________________________________________________

"Did you find this helpful? Let us know by completing this survey (takes 1 minute!)"

View solution in original post

0 Kudos
Hot Shot
Hot Shot

That worked like a charm. It was just one driver to remove.

The update went through.

I also got the BIOS and ilo firmwares updated as well.

Just updated my storage arrays plugin.

Seems that its working fine now.  Its on 6.5 14990892.  I just have to get it up to build 15256549 and it will be up to date on 6.5.

0 Kudos
Leadership
Leadership

Unrelated, but maybe interesting for you.

Unless you have iLO Advance already licensed, HPE currently offers a free trial license that works until the end of 2020.

see https://www.hpe.com/us/en/resources/integrated-systems/ilo-advanced-trial.html

André

0 Kudos
Expert
Expert

It’s common. just check if not in use or not using vib you can remove it and proceed it will work without any issues...

NKS Please Mark Helpful/correct if my answer resolve your query.
0 Kudos
Contributor
Contributor

Thanks for this, I removed three drivers this way, and was able to upgrade with no problems! Gen8 that was at 6.0, upgraded to 6.5 in a 6.7 vCenter.

0 Kudos