andvm
Hot Shot
Hot Shot

The upgrade has VIBs that are missing dependencies

Hi,

Was going to try to upgrade the first host in a vSAN cluster from 6.7 to 7.0 (Using Custom Dell Image) but upon attaching upgrade baseline and run Check Compliance it showed Status "Incompatible"

The upgrade has VIBs that are missing dependencies:

QLogic_bootbank_net-qlge_3.0.0.59-1OEM.550.0.0.1331820

QLogic_bootbank_net-qlge_3.0.0.59-1OEM.550.0.0.1331820

Remove the VIBs or use Image Builder to create a custom upgrade ISO image that contains the missing dependencies, and try to upgrade again.

esxcli software vib list | grep 3.0.0.59-1OEM.550.0.0.1331820

net-qlge  3.0.0.59-1OEM.550.0.0.1331820 QLogic VMwareCertified 2019-03-16

By removing the VIB's does it mean login to ESXi and remove the the above VIB such as by doing following command?

esxcli software vib remove -n net-qlge

Why is this an issue and more important will removing the above VIB cause any issue as presumably since it is listed it is in use?

Although I can not see net-qlge listed under Driver when doing esxcli network nic list or esxcli storage core adapter list

Thanks

11 Replies
scott28tt
VMware Employee
VMware Employee

Moderator: Thread moved to the vSphere Upgrade & Install area.


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
a_p_
Leadership
Leadership

Such dependency errors have been around for quite some time. Anyway, since you've already verified that the mentioned drivers are not in use, there should be no issues with removing them using the command that you've mentioned.


André

andvm
Hot Shot
Hot Shot

ok so net-qlge is just loaded but not in use as otherwise it would show under "Drivers"

In which case I will esxcli software vib remove -n net-qlge

Then will check Compliance Status again and push the upgrade.

0 Kudos
andvm
Hot Shot
Hot Shot

ok following the above and rebooting Status showed as Non Compliant

Remediated and upgrade completed however in Events I could see message "vSAN network is not configured" after it completed!

I checked the vmkernel and in fact vSAN Service is unticked (otherwise rest of settings (IP/MTU) on vmkernel look to have persisted)

Is this known or any reason why this would happen and any further checks you suggest me doing as at this point it might have missed other config?

Thanks

0 Kudos
andyhilton27
Contributor
Contributor

To find the missing VIBS we ended up having to mount the ISO through HPE ILO and try a manual upgrade which did show the conflicting VIBS.

mcdvoice and mybkexperience

0 Kudos
andvm
Hot Shot
Hot Shot

thank you, in my case the vib listed was not in used so I could remove it prior the ESXi upgrade.

The strange thing is that vSAN is getting ticked off from the vSAN dedicated vmkernel after the upgrade, it must be a bug as the same happened with 2nd host upgrade.

0 Kudos
IRIX201110141
Virtuoso
Virtuoso

For sure a VIB from 5.5 will not work under 7.0 any more.  Seen this more than once.

Regards,
Joerg

gparker
Enthusiast
Enthusiast

Hi Andvm,

I just had the exact same issue upgrading 2 Dell PowerEdge R630's from ESXi v6.7-u3 to 7.0-u1. I followed your steps and it worked, got them both upgraded successfully after removing that spurious VIB. 🙂

dzak64
Enthusiast
Enthusiast

Thank you. I have the issue upgrading from 6.7 u3 to 7.0 u1 on Cisco UCS C-Series. You steps allow me to perform the upgrade.

 

 

0 Kudos
Qmarsm
Contributor
Contributor

Hi andvm,

hope you are doing well. I saw your post which is for long time ago for VIBs missing dependencies.

I reach out to ask for your help if you finaly found a solution for that.

I have a somehow same situation with one of the hosts of my vSAN cluster. Iwanted to upgrade it from v.6.5 to 7u2, and I saw the same error as you mentioned for QLogic_bootbank_net-qlge_3.0.0.59-1OEM.550.0.0.1331820.

It is prodution and I can't bear any risk. 

thanks for your help

Q

 

0 Kudos
andvm
Hot Shot
Hot Shot

Hi @Qmarsm

Would say follow the same process, check if in use and if not remove and test on a Host in Maintenance Mode.

 

0 Kudos