pym
Contributor
Contributor

The Execute Disable/No Execute CPU feature is not enabled for this machine.

Jump to solution

Hi all!

After my first installation of ESX 4.0.0 build-164009 on a HP Proliant BL680c G5 (2CPUs - 40GB Mem), I get the usual screen with the HTTP host address and the Alt-F1 and Alt-F11 stuff, but at the bottom, in red, I get the following error :

TSC: 1246869 cpu0:0)Init: 461: The Execute Disable/No Execute CPU feature is not enabled for this machine.

I suspect I need to change this setting somewhere in the BIOS but I can find it. This BL was originally setup with W2k3-32-bit which was pushed from an Altiris console; as believe the PSP usually "optimize" some settings depending on the O/S to be installed.

Any ideas

0 Kudos
1 Solution

Accepted Solutions
Texiwill
Leadership
Leadership

Hello,

I would also enable Intel-VT if it is not already within your BIOS. It is always very good to verify your BIOS settings are correct for ESX. HP should have a whitepaper or documentation with the proper settings.

So far enable for Intel based HP systems my list includes:

Intel VT

No eXecute

If you CAN select an OS type select Windows NOT Linux.


Best regards,

Edward L. Haletky VMware Communities User Moderator, VMware vExpert 2009, Virtualization Practice Analyst[/url]
Now Available: 'VMware vSphere(TM) and Virtual Infrastructure Security: Securing the Virtual Environment'[/url]
Also available 'VMWare ESX Server in the Enterprise'[/url]
[url=http://www.astroarch.com/wiki/index.php/Blog_Roll]SearchVMware Pro[/url]|Blue Gears[/url]|Top Virtualization Security Links[/url]|Virtualization Security Round Table Podcast[/url]

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill

View solution in original post

0 Kudos
4 Replies
pym
Contributor
Contributor

Oups! I posted it by mistake before I was done ?:| .

There is No-Execute Memory Protection parameter, which is disabled, under the Processor Options (under Advanced Options) in the BIOS. I enabled it and the error is gone. SO I don't need help anymore, but in case it helps someone else...:D

0 Kudos
Texiwill
Leadership
Leadership

Hello,

I would also enable Intel-VT if it is not already within your BIOS. It is always very good to verify your BIOS settings are correct for ESX. HP should have a whitepaper or documentation with the proper settings.

So far enable for Intel based HP systems my list includes:

Intel VT

No eXecute

If you CAN select an OS type select Windows NOT Linux.


Best regards,

Edward L. Haletky VMware Communities User Moderator, VMware vExpert 2009, Virtualization Practice Analyst[/url]
Now Available: 'VMware vSphere(TM) and Virtual Infrastructure Security: Securing the Virtual Environment'[/url]
Also available 'VMWare ESX Server in the Enterprise'[/url]
[url=http://www.astroarch.com/wiki/index.php/Blog_Roll]SearchVMware Pro[/url]|Blue Gears[/url]|Top Virtualization Security Links[/url]|Virtualization Security Round Table Podcast[/url]

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill

View solution in original post

0 Kudos
pym
Contributor
Contributor

Hello and thank you Texiwill!

Intel VT was already enabled indeed but there is no parameters to choose the O/S in the BIOS that I could find.

And for the sake of more complete information, one other parameter to set in the BIOS prior to a VMware installation would also be the time in UTC, not local. I don't use Linux or Unix myself but I would guess that is probably a standard.

I haven't found any HP documentation but I can rarely find anything quickly on HP's site ;-).

Again thank you!

0 Kudos
snantel
Enthusiast
Enthusiast

Thanks BTW.

I just upgrade my first HP DL380 G5 and get the same result.

You save me the time to find it in all these menu items Smiley Happy

0 Kudos