HamR
Enthusiast
Enthusiast

Preupgrade Check Tool

I'm having trouble running the Preupgrade Check Tool to upgrade vCenter from 4.0m to 4.1.

The 64bit host won't run a 16bit app.

What am I missing?

Thanks,

HamR

0 Kudos
5 Replies
williamz
VMware Employee
VMware Employee

Which OS you run preupgrade check tool?

Could you post the screenshot of the error and let us know the steps run into this?

Thanks.

0 Kudos
admin
Immortal
Immortal

Are you getting any of the messages mentioned in KB articles below-

http://kb.vmware.com/kb/1017105

http://kb.vmware.com/kb/1018486

Anand

0 Kudos
HamR
Enthusiast
Enthusiast

The OS is Windows 2008 R2 Standard (64bit), which was suppored for vCenter 4.0 and still supported with vCenter 4.1

I get a different error message depending on whether I run the utility from the vCenter installer or directly from the executable; however, both messages advise that the 64bit OS won't run the 16bit app - which is the expected behaviour.

Is there a 32/64bit version of the app, or have VMware assumed the source platform would always be 32bit?

0 Kudos
admin
Immortal
Immortal

In http://www.vmware.com/pdf/vsphere4/r40/vsp_compatibility_matrix.pdf, Windows 2008 R2 Standard (64bit) is not listed in supported platform for 4.0 and 4.1, but Windows Server 2008 Enterprise 64‐bit and Windows Server 2008 Standard 64‐bit, are you have 4.0 installed on your box when you run PUC?

0 Kudos
HamR
Enthusiast
Enthusiast

Windows Server 2008 R2 is definately supported with vCenter 4.1

The problem was a truncated download. I downloaded the binaries at home and it worked.

0 Kudos