mronsman
Contributor
Contributor

No COS NICs Added By User - HP RDP PXE Scripted Install

Using HP Rapid Deployment Pack 6.01 to try to deploy ESX 4.0 U1. It gets to the GRUB menu and loads all the drivers and what not but then I get the error NO COS NICs Added By User followed immediately by Press (enter) to reboot. As far as I can tell it is not communicating with the FTP server to grab the .cfg file. It is on a subnet that has open DHCP and the FTP share works fine from my browser. I have also tried to use a static IP address to no avail.

I have seen other posts about on some servers the vmnic0 is not there or is a different number perhaps? As far as I know there is no log file of anything and I don't have a CLI to enter commands into. Please let me know if anyone out there has seen this. I also tried to mess around with the GRUB and to add IPAPPEND 2 or 1 to it but it does not like that.

Please let me know if anyone has any advise. I would post my .cfg but it is not even getting to that part to the point were that would be the issue.

Thanx,

Matt

Tags (2)
0 Kudos
4 Replies
mronsman
Contributor
Contributor

Well I guess I should have posted my kickstart because it was off. The no COS error is inconsequential. I changed my dist directory to be ESX 4.0 (Non U1) and rather than clearing the screen and giving me the reboot message it actually showed me some helpful output concerning my kickstart syntax. But I couldn't see it before. So now all is well.

Thanx,

Matt

0 Kudos
Astro
Contributor
Contributor

Hi

Same problem. Have you solved ? Could you please attach your kickstart ?

The documentation of RDP 6.x is very incomplete. Have you created a ftp share ? Where ?

Many thanks

Max

0 Kudos
mronsman
Contributor
Contributor

The FTP share is created on the RDP server. You need to have the FTP service installed prior to installing RDP. Even then it does not always work. You can create the FTP share manually by making a share called 'ds' that maps to the eXpress share. It needs to have anonymous enabled.

In general the 6.x install for the standalone RDP is horrid. It does not check for prerequisites and take forever! Hopefully the 6.0 Insight Control DVD will be out soon which tends to be more thoughtful.

I have posted the kickstart that I am using. I customized it to do the networking after the fact. Let me know if you have any questions.

Thanx,

Matt

0 Kudos
jakoma
Contributor
Contributor

While that error is still on your screen, hold down AltF2 or AltF3 to get to a bash console.

Review the logs within the /var/log folder, specifically the installation log file, which will shed more light on your specific situation.

I had the same exact issue, and it turned out that my MD5 encrypted password for the root account was not formatted correctly in the kickstart file. Interesting that there was no indication of this from the console without reviewing the logs.

- Jason

0 Kudos