VMware Cloud Community
optimus75
Contributor
Contributor

HP Microserver Gen8 Update Esxi 6.0 to Esxi 6.5 U3 not deteced CDRom/DVD

i tried to update my HP Microserver Gen 8 with internal B120i to ESXI 6.5. U3 (HP Custom Image).

My configuration:

HP Gen 8 with  B120i with 4 x 3TB WD Red and also include internal CDRom / DVD

2 logical Drives over B120i Raid

in ESXI 6.0 everything is detected logical drives and also DVD. So that i could passtrough my physical DVD to my VMs.

After Update (offline update HP Custom Image) and also i tried new install to ESXI 6.5 U3.  I used HPE-ESXi-6.5.0-Update3-iso-preGen9-650.U3.9.6.10.1 (Hewlett Packard Enterprise) with 6.5.0 Update 3 (Build 14990892).

Also both logical drives were deteced, but NOT my physical DVD device. ESXI 6.5 used hpvsa driver from HP Custom Image .....

My question what should i do? so my esxi 6.5 detect my physical DVD device on B120i? Thanx

 
Reply
0 Kudos
4 Replies
Ferozrah
VMware Employee
VMware Employee

Hi,

 

Greetings for the day.

 

Could you please have a check if AHCI is configured properly as with b120i controller raid mode cannot be used to install OS.

System Options - SATA Controller Options - Embedded SATA Configuration.

For more details you can also check with your hardware vendor.

 

Best

Feroz Rah

Reply
0 Kudos
nachogonzalez
Commander
Commander

Have you checked if all drivers/firmware are on the correct version?

Maybe some firmware version ran old when you upgraded to vSphere 6.5U3

Reply
0 Kudos
optimus75
Contributor
Contributor

yes, firmware and bios are up to date. In BIOS the onboard array controller B120i is enabaled and also my setting is Dynamic HP Smart Array B120i RAID.  I have the right settings in BIOS:

The issue is  following: (see also my config:  onboard B120i with 4 hard disk drives and one CD-Rom/DVD  on ODD Port 5 - this is the purchased equipment from HP)

the ESXI 6.5 system found all 4 hard disk drives on the onboard controller B120i. Also it detected both logical volumes on it and i can use hard drives as datastore. BUT the ESXI 6.5 DID NOT recognize the CD-ROM/DVD on this onboard controler B120i. I could see only the logical devices and NO CD-Rom/DVD Drive. 

For Installation I use ESXI 6.5 U3  -- HPE-ESXi-6.5.0-Update3-iso-preGen9-650.U3.9.6.10.1 (Hewlett Packard Enterprise) for the installation also the the problem with ESXI 6.5 U2 HP Custon Image exists.

Reply
0 Kudos
optimus75
Contributor
Contributor

now i could find some things in vmkernel.log....

2021-02-10T20:05:57.742Z cpu2:2097720)hpvsa0: Found 2 scsi device(s)
2021-02-10T20:05:57.742Z cpu2:2097720)hpvsa: Number of DVDs found 1
2021-02-10T20:05:57.742Z cpu2:2097720)hpvsa0: Disk found[type=0]
2021-02-10T20:05:57.742Z cpu2:2097720)hpvsa0: Disk found[type=0]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0: Optical device found[type=5]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0: Controller found[type=12]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0 Adding Direct-Access device. [0000004000000000]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0: Direct-Access device added (b0t0l0).
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0 Adding Direct-Access device. [0100004000000000]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0: Direct-Access device added (b0t0l1).
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0 Adding CD-ROM device. [0000000000000401]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0: CD-ROM device added (b0t1l0).
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0 Adding RAID device. [0000000000000000]
2021-02-10T20:05:57.743Z cpu2:2097720)hpvsa0: RAID device added (b0t0l0).
2021-02-10T20:05:57.743Z cpu7:2097720)hpvsa0: shost[0x430903e080a0] added b0t0l0
2021-02-10T20:05:57.743Z cpu7:2097720)hpvsa0: shost[0x430903e080a0] added b0t0l1
2021-02-10T20:05:57.743Z cpu7:2097720)hpvsa: setting ODD queue depth to 1
2021-02-10T20:05:57.743Z cpu7:2097720)WARNING: LinScsiLLD: scsi_add_device:1478: Failed to add device on channel=0, id=1, lun=0
2021-02-10T20:05:57.743Z cpu7:2097720)hpvsa0: scsi_add_device of b0t1l0 failed.
2021-02-10T20:05:57.743Z cpu7:2097720)hpvsa0: shost[0x430903e080a0] added b0t0l0

 

seems to me that there is a bug in HPE module hpvsa??

Reply
0 Kudos