itnifl123
Contributor
Contributor

Get error message "Did not get an IP Address from DHCP server" during a scripted usb installation

I get the error message "Did not get an IP Address from DHCP server" during a scripted usb installation. The message times out, and then the installation continues. I don't want the error uring the process.

The relevant boot.cfg line looks like this:

kernelopt=runweasel ks=usb:/KS.CFG bootproto=static addvmportgroup=0 netdevice=vmnic0 ip=172.0.1.12 netmask=255.255.255.0 gateway=172.0.1.1 hostname=ESXiHost1 vlanid=100 nameserver=8.8.8.8


The relevant KS.CFG line looks like this:

network --bootproto=static --addvmportgroup=0 --device=vmnic0 --ip=172.0.1.12 --netmask=255.255.250.0 --gateway=172.0.1.1 --hostname=ESXiHost1 --vlanid=100 --nameserver=8.8.8.8

The error I found in /var/log/weasel.log looks like this:

2015-09-07T09:56:54.910Z DEBUG    Validating command: vnc

2015-09-07T09:56:54.910Z DEBUG    Validating command: volgroup

2015-09-07T09:56:54.910Z DEBUG    Validating command: xconfig

2015-09-07T09:56:54.910Z DEBUG    Validating command: xdisplay

2015-09-07T09:56:54.910Z DEBUG    Validating command: zerombr

2015-09-07T09:56:54.945Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:56:54.945Z INFO     Network choices not specified.  Using DHCP.

2015-09-07T09:56:54.945Z INFO     connectDhcp called for pnic None

2015-09-07T09:56:55.002Z WARNING  no pnicName specified, no changes made to connect via DHCP

2015-09-07T09:56:55.003Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:56:58.003Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:56:58.005Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:01.008Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:01.010Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:04.013Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:04.015Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:07.018Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:07.020Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:10.022Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:10.024Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:13.029Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:13.031Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:16.033Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:16.035Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:19.039Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:19.041Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:22.044Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:22.046Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:25.049Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:25.051Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:28.054Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:28.056Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:31.059Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:31.061Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:34.064Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:34.066Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:37.069Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:37.071Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:40.074Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:40.076Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:43.079Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:43.081Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:46.082Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:46.085Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:49.088Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:49.090Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:52.093Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:52.095Z WARNING  Still waiting for an IP address from DHCP

2015-09-07T09:57:55.097Z DEBUG    Progress happened on a task that has not started

2015-09-07T09:57:55.100Z ERROR    Could not bring up network (Did not get an IP Address from DHCP server)

Traceback (most recent call last):

  File "/usr/lib/vmware/weasel/scripted/cursed_ui.py", line 786, in tryNetworkConnect

    connect()

  File "/usr/lib/vmware/weasel/networking/networking_base.py", line 51, in newFn

    return fn(*args, **kwargs)

  File "/usr/lib/vmware/weasel/networking/networking_base.py", line 187, in connect

    return connectDhcp(None)

  File "/usr/lib/vmware/weasel/networking/networking_base.py", line 51, in newFn

    return fn(*args, **kwargs)

  File "/usr/lib/vmware/weasel/networking/networking_base.py", line 154, in connectDhcp

    raise ConnectException('Did not get an IP Address from DHCP server')

ConnectException: Did not get an IP Address from DHCP server

2015-09-07T09:57:55.101Z WARNING  Could not bring up network (Did not get an IP Address from DHCP server)

This looks like a bug to me.

0 Kudos
3 Replies
SG1234
Enthusiast
Enthusiast

is it a possible NIC driver issue?   is it possible that the NIC type is not supported?

is the DHCP server responding  fine in your LAN?

0 Kudos
itnifl123
Contributor
Contributor

There is no DHCP server in that vlan. As you can see in the configuration, the nic is configured to use a static address. It is configured to do so both in boot.cfg and KS.CFG.

There are no other places that I know of that bootproto can be specified.

After the dhcp error times out, the nic is as configured set up with the static IP-address and works as expected.

This happens on all HP Gen8 servers that we deploy this on, and this all happens the same way on them all.

After the system is finished installing, there is no problem with any of the nics, and the static IP works fine as set at boot time.

So I can not see any problem with the nics, I see vmwares weasel that is supposed to parse the kickstart scripts having some type of bug when usb booting the installer with a static ip address. It is as if it is stuck in believing it should PXE boot and receive an IP-address from dhcp.

0 Kudos
SG1234
Enthusiast
Enthusiast

ok - got it now --  one more suggestion is set the switch port to portfast enable mode and see if it makes any difference.

0 Kudos