Exp-user
Contributor
Contributor

ESXi upgrade from V6.5 to V7

Hello,

I was going to do the upgrade using "VMware-ESXi-7.0.1.-16850804-LNV-20200917.iso" . I asked the support if that will solve the following Vulns:
CVE-2021-21972, CVE-2021-21973, CVE-2021-21974

He said for that, I need to use "ESXi 7.0 Update 1d  ISO Build 17551050". I tried to find it or any thing related to this release for lenovo but no luck.

I appreciate any help to download this custom image.

Thanks.

 

0 Kudos
3 Replies
a_p_
Leadership
Leadership

Most vendors usually provide customized ESXi images for main/update releases only, or once vendor specific components need to be updated.
According to what you found, you'd need to upgrade the host using the vendor customized image, and then apply the latest VMware patches either through Update-Manager/Life-Cycle-Controller, or manually.

That said, please make sure that the ESXi version/build that you want to upgrade to supports your hardware! You may also want to check whether firmware/BIOS upgrades are required/recommended.

André

0 Kudos
e_espinel
Expert
Expert

Hello.

You can first use the Lenovo Update 1 version and then apply the patches to get to Update 1d (VMware), I attach the links where to get the patches.

https://vmware.lenovo.com/content/custom_iso/7.0/7.0u1/

https://my.vmware.com/group/vmware/patch#search

It is very important to verify that all hardware is compatible with version 7.X to avoid complications.

https://www.vmware.com/resources/compatibility/search.php

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
Exp-user
Contributor
Contributor

Thank you e_espinel,

So after upgrading first using "VMware-ESXi-7.0.1.-16850804-LNV-20200917.iso", I need to do the same steps to apply "VMware-ESXi-7.0U1d-17551050-depot" ?

another thing, I did really come with compatibility problems with some VIBs:

scsi-bfa_3.2.5.0-1OEM.550.0.0.1331820

net-qlge_3.0.0.59-1OEM.550.0.0.1331820

net-qlge_3.0.0.59-1OEM.550.0.0.1331820

net-bna_3.2.5.0-1OEM.550.0.0.1331820

net-bna_3.2.5.0-1OEM.550.0.0.1331820

scsi-mpt3sas_08.00.01.00.1vmw-1OEM.550.0.0.1331820

scsi-mpt3sas_08.00.01.00.1vmw-1OEM.550.0.0.1331820

scsi-bfa_3.2.5.0-1OEM.550.0.0.1331820

some postes say that I can remove them and proceed. is that safe to do and continue normally?

Thanks You!

 

 

Tags (1)
0 Kudos