Toolix
Contributor
Contributor

ESXi 6.7 install failed due to missing network adapter although it is in the supported hardware list

Hi all,

due to good experience with the previous model I bought an HP EliteDesk 800 G4 Desktop-Mini-PC (65W) to run VMware vSphere Hypervisor (ESXi) 6.7 on.

However during the installation procedure I received the error message “Relocating modules and starting up the kernel…”. I changed to legacy boot, followed the instruction https://talesfromthedatacenter.com/2016/02/esxi-6-install-stuck-on-relocating-modules-and-starting-u... and added the option “ignoreHeadless=TRUE” during startup of the installation process.

This led me to the next error “No network adapters”.

I checked the VMware hardware compatibility list if my “Intel Ethernet Connection I219-LM” is support and it should be.The correct vendor description on my internal network adapter is "Ethernet Connection (7) I219-LM". Regarding to the supported hardware list of VMware this model is supported. VMware Compatibility Guide - I/O Device Search

Until now I couldn’t get beyond this error and highly appreciate any helpful advise.

Thx.

0 Kudos
12 Replies
dbalcaraz
Expert
Expert

Not a fan of those Mini-PCs for running an ESXi host...

Are you running a generic ISO?

Did you try to customize the ISO with the driver you need just be sure that it will be installed?

Regarding your NIC is compatible, is also the rest of hardware (CPU, MB and RAM)?

-------------------------------------------------------- "I greet each challenge with expectation"
0 Kudos
Toolix
Contributor
Contributor

I tried to install the standard ESX 6.7 U1 iso. Do you have any how-to link available for integrating other drivers and where to find these drivers?

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

Try disabling the on-board WiFi in the UEFI, it looks like the presence of WiFi might have an effect with the on-board wired NIC. See page 54 of the service manual, there is an option called "LAN/WLAN Auto Switching"

http://h10032.www1.hp.com/ctg/Manual/c06063157#page=61&zoom=auto,-214,301

Also on page 53, it looks like Intel VT-x is also disabled by default. Make sure that it is enabled.

0 Kudos
Toolix
Contributor
Contributor

Thanks for this hint. Auto-switching of WLAN/LAN was already deactivated. VTX support was enabled. I disabled onboard WLAN/BT but without further success. The network adapters seem to be still not detectable.

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

The other thing to try is to disable the "Power Saving" features that either deliver less voltage or turn off devices altogether (see page 55). Things like "PCI Express Power Management" looks like is enabled; it certainly won't do good for an NIC controller that has been idle while the installation was in progress.

http://h10032.www1.hp.com/ctg/Manual/c06063157#page=63&zoom=auto,-214,515

But other than these things, there is not much else to do and try as the NIC is in the qualified list. Desktops are hit or miss affairs to get it to work with ESXi. Workstation desktop/towers such as HP-Z or Dell Precision line have a much better chance of success as some models share the same chipset as the some of the lower end servers (be it rack or tower) such as Dell PowerEdge that are in the VMware ESXi HCL.

0 Kudos
Toolix
Contributor
Contributor

What a pity. Disabling the PCI Express Power Management didn't solve my problem either. If the previous model of the HP EliteDesk would have not worked that good I'd thought about buying a different model. Now it's too late. Any other ideas what I could do to get ESXi running?

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

Since EliteDesk mini does not have expansion slot capability, you cannot get another PCIe Ethernet card to try. Only other way is to use VMware Workstation/Player and create an ESXi VM and run nested virtualisation within it. You can have as much virtual adapters in the ESXi VM that Workstation/Player can accommodate.

By the way, what made you so sure to say that the NIC you have is "Ethernet Connection (7) I219-LM"? Did you get to check the device ID?

From what I can speculate, I think the direction of VMware ESXi is to move away from these types of unqualified equipment/components. I recall reading a VMware blog post that in the next major ESXi release (presumably ESXi 7.x) that only native drivers will be supported. Since native drivers will only come from vendors who write the drivers and officially qualify them for ESXi, effectively, the days of using unqualified components will also be coming to an end.

0 Kudos
Toolix
Contributor
Contributor

Model :Ethernet Connection (7) I219-LM
Device Type :NetworkDID :15bb
Brand Name :IntelSVID :0000
Number of Ports:0SSID :0000
VID :8086
Notes:
  • Firmware versions listed are the minimum supported versions. Refer to http://kb.vmware.com/kb/2030818 for additional information on other supported driver and firmware combinations

Model, VID and DID are the same in my HP 800 G4 MD computer.

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

Considering that you had already changed to legacy boot, I would think Secure Boot is already and that is not the issue. But one more thing to try is to disable the Trusted Execution Technology.

Here is the VMware blog post that I was referring to that the next ESXi major version will only support native drivers.

https://blogs.vmware.com/vsphere/2017/08/vmware-plans-deprecate-vmklinux-apis-associated-driver-ecos...

0 Kudos
BarrettC
Contributor
Contributor

I've had the same problem, I've used many EliteDesk 800's for VMware machines. The problem is simple and it was a big facepalm for me, and for the fact that this is needed ... Just make sure the NIC is plugged in to a network during the install Smiley Wink

Although, since the newer VMware and/or EliteDesk's (not sure which one is causing the problems), but I'm experiencing the "Relocating modules and starting up the kernel" issue. I've done a ton of searching and have tried the following without success. Mind you, I'm able to get through the install without doing anything special, it's after the install that I get this.

  1. ignoreHeadless=TRUE
  2. Increased Video RAM
  3. Enabled/Disabled TPM
  4. Changed between all UEFI/Legacy boot settings
  5. Enabled/Disabled TXT
  6. Downgraded BIOS to v2.02.04 then back up to the latest 2.04.01

I've also adjusted some other settings without change. Anyone have any other ideas? This is with v6.5 U2, as I've tried 6.7 but it complains about the NIC. I'm beginning to believe they finally found a way to block running VMware on these Smiley Sad.

0 Kudos
Froggiz
Contributor
Contributor

Hi,

I had a similar trouble with an industrial mini PC with a realtek network card.

I found the solution there :

https://www.v-front.de/2014/12/how-to-make-your-unsupported-nic-work.html

To gain some time i tell you the step i did :

when you are stuck on

ESXi-Install-NoNICs.png

To enter in console mode type the key

[Alt] and [F1]

To know your NIC name, launch the command

lspci -v | grep "Class 0200" -B 1

Then search on internet for the NIC driver in .vib format

Once you get the driver, you can inject it into the original Esxi .iso using the tool in the link https://www.v-front.de/p/esxi-customizer.html

ESXi-Customizer-v2.7.2-GUI.png

Then run the iso on your Esxi and driver should be found, and install could be done !

There is another solution more recommanded using PS, for it you can read fully the link https://www.v-front.de/2014/12/how-to-make-your-unsupported-nic-work.html

But i didnt tried it.

Btw, maybe i was lucky but i had the same card use in the example : Realtek 8168 Gigabit Ethernet

I hope it will help.

Regards.

wiki.frogg.fr
0 Kudos
MirandaESXI
Contributor
Contributor

Hallo,

simpy use HPE-ESXi-6.7.0-Update1-iso-Gen9plus-670.U1.10.3.5.12 (Hewlett Packard Enterprise) this ISO to have Working NIC.

Gruß, Andreas

0 Kudos