andreashergert1
Contributor
Contributor

[solved] Intel rs3wc080

Hi,

i have purchased an vSphere 6.5 Essetials Bundle to evaluate some Datacenter ideas.

I have installed an Rizen-Server which works fine with ESXi 6.5u1.

The only problem i have is the RAID-Controller.

I have ordered a controller which ist listed in der Compatibilitylist of VMWare.

It ist the Intel rs3wc080 (LSI 3008 based).

I have Upgraded the Controller-Firmware to 4.680.01-8248  as listed in the vmware-List.(VMware Compatibility Guide - I/O Device Search )

I downloaded the driver (lsi-mr3 version 7.702.14.00-1OEM) and installed via esxcfg.

After booting no controller and drives are shown in the client.

via SSH is inspected the Kernel-Buffer:

2017-10-16T18:42:18.945Z cpu18:66103)Loading module lsi_mr3 ...

2017-10-16T18:42:18.946Z cpu18:66103)Elf: 2043: module lsi_mr3 has license ThirdParty

2017-10-16T18:42:18.949Z cpu18:66103)lsi_mr3: 7.702.14.00

2017-10-16T18:42:18.950Z cpu18:66103)Device: 191: Registered driver 'lsi_mr3' from 18

2017-10-16T18:42:18.950Z cpu18:66103)Mod: 4968: Initialization of lsi_mr3 succeeded with module ID 18.

2017-10-16T18:42:18.950Z cpu18:66103)lsi_mr3 loaded successfully.

2017-10-16T18:42:18.951Z cpu13:66068)lsi_mr3: mfi_AttachDevice:647: mfi: Attach Device.

2017-10-16T18:42:18.951Z cpu13:66068)lsi_mr3: mfi_AttachDevice:655: mfi: mfiAdapter Instance Created(Instance Struct Base_Address): 0x4304cb76d0d0

2017-10-16T18:42:18.951Z cpu13:66068)lsi_mr3: mfi_SetupIOResource:338: mfi bar: 1.

2017-10-16T18:42:18.951Z cpu13:66068)VMK_PCI: 915: device 0000:0b:00.0 pciBar 1 bus_addr 0xef800000 size 0x10000

2017-10-16T18:42:18.951Z cpu13:66068)DMA: 646: DMA Engine 'mfi00110000-dmaEngine' created using mapper 'DMANull'.

2017-10-16T18:42:18.951Z cpu13:66068)DMA: 646: DMA Engine 'mfi00110000-dmaEngine64' created using mapper 'DMANull'.

2017-10-16T18:42:18.951Z cpu13:66068)lsi_mr3: fusion_init:1535: RDPQ mode not supported

2017-10-16T18:42:18.951Z cpu13:66068)lsi_mr3: fusion_init:1547: fusion_init Allocated MSIx count 4 MaxNumCompletionQueues 4

2017-10-16T18:42:18.952Z cpu13:66068)VMK_PCI: 765: device 0000:0b:00.0 allocated 4 MSIX interrupts

2017-10-16T18:42:18.952Z cpu13:66068)lsi_mr3: fusion_init:1576: Dual QD exposed

2017-10-16T18:42:18.952Z cpu13:66068)lsi_mr3: fusion_init:1614: Extended IO not exposed:disable_1MB_IO=0

2017-10-16T18:42:18.952Z cpu13:66068)lsi_mr3: fusion_init:1626: maxSGElems 64 max_sge_in_main_msg 8 max_sge_in_chain 64

2017-10-16T18:42:18.952Z cpu13:66068)lsi_mr3: fusion_init:1678: fw_support_ieee = 67108864.

2017-10-16T18:42:20.820Z cpu13:66068)WARNING: lsi_mr3: fusion_init:1685: Failed to Initialise IOC

2017-10-16T18:42:20.820Z cpu13:66068)lsi_mr3: fusion_cleanup:1771: mfi: cleanup fusion.

2017-10-16T18:42:20.820Z cpu13:66068)WARNING: lsi_mr3: mfi_FirmwareInit:1972: adapter init failed.

2017-10-16T18:42:20.820Z cpu13:66068)WARNING: lsi_mr3: mfi_AttachDevice:687: mfi: failed to init firmware.

2017-10-16T18:42:20.820Z cpu13:66068)lsi_mr3: mfi_FreeAdapterResources:612: mfi: destroying timer queue.

2017-10-16T18:42:20.820Z cpu13:66068)lsi_mr3: mfi_FreeAdapterResources:616: mfi: destroying locks.

2017-10-16T18:42:20.820Z cpu13:66068)DMA: 691: DMA Engine 'mfi00110000-dmaEngine' destroyed.

2017-10-16T18:42:20.820Z cpu13:66068)DMA: 691: DMA Engine 'mfi00110000-dmaEngine64' destroyed.

2017-10-16T18:42:20.820Z cpu13:66068)WARNING: lsi_mr3: mfi_AttachDevice:715: Failed - Failure

2017-10-16T18:42:20.820Z cpu13:66068)Device: 2482: Module 18 did not claim device 0x4fc94303ec1d04c9.

2017-10-16T18:42:20.832Z cpu4:66106)Loading module iscsi_trans ...

any ideas?

greetings Andreas

Tags (1)
0 Kudos
1 Reply
andreashergert1
Contributor
Contributor

ok i found the solution .. for me.

a have the ASUS PRIME X399-A Mainboard.

There is an option in the BIOS/EFI:

CSM this musst be disabled and everything works fine..

0 Kudos