Enthusiast
Enthusiast

Vsphere and Openfiler

Hello,

I am trying to set up an Openfiler iSCSI SAN with my vSphere server. This is in my home training environment. I have used these two documents to do this:

http://www.petri.co.il/use-openfiler-as-free-vmware-esx-san-server.htm

http://www.vladan.fr/how-to-connect-esx4-vsphere-to-openfiler-iscsi-nas/

I have done this previously using ESX 3.5 (albeit a couple of years ago now).

Everything seems to go fine using the Openfiler configuration settings above, however when I use the vSphere instructions I get to step #7 and then the train starts coming off the rails. After putting the server IP in the dynamic discovery tab no LUN or disk information populates even after countless rescans/refreshes.

I have tried logging into the vsphere host and done ping and vmkping and both returned successfully.

I have also used a Windows 7 client to connect and the connection happens immediately. After connecting I can do whatever I want with the disk, format it, etc. I then disconnect from the Windows 7 machine and try again on my vShphere host and it's just not having it.

Can anyone suggest anything I can try next?

0 Kudos
20 Replies
Enthusiast
Enthusiast

You might want to take a quick look in the security profile to make sure the software iSCSI port is open on the firewall.

VMware VCP - Consider awarding points for "helpful" and/or "correct" answers.

Blog: http://www.virtualizetips.com Twitter = @bsuhr
0 Kudos
Hot Shot
Hot Shot






Hello,

It seems you have ghost LUN0 that's why the iSCSI LUNs are not appearing. Check this out it might be helpful for you.

Double Lun IDs within ESX3 in combination with Openfiler

Best Regards,

Hussain Al Sayed

If you find this information useful, please award points for "correct" or "helpful".

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
0 Kudos
Enthusiast
Enthusiast

I'm only presenting a single LUN from my openfiler SAN. Could this still be causing my problem?

0 Kudos
Hot Shot
Hot Shot

Hello,

  1. Make sure proper communication between the OpenFiler and ESX host.

  2. Make sure the iSCSI Target in the OpenFiler is Started.

  3. Make sure the Outgoing port in Software iSCSI Client is configured.

  4. Complete all the nicessary configuration in OpenFiler to create and present the LUN.

  5. Add the IP Address of OpenFiler To the iSCSI Adapter in ESX host.

  6. Rescan for new SAN Storage.

  7. If not, then try to check out the Dublicate LUN(0) in OpenFiler, and rescan your host after completeing the changes.

  8. If not, then try StarWind iSCSI or another iSCSI Target and configure ESX for that target, check do u see your iSCSI LUNs!!

    1. This will determined the issue if it is from the iSCSI Target or the ESX Host.

    2. If nither of these, install put a VM beside the iSCSI PortGroup, and configure this VM as an ISCSI Target and see you can present a LUN.

Best Regards,

Hussain Al Sayed

If you find this information useful, please award points for "correct" or "helpful".

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
Enthusiast
Enthusiast

Thanks I am going to try all of those things. Here are the contents of my /etc/ietd.conf. Do you see anything abnormal there?

login as: root

root@192.168.1.118's password:

Last login: Mon Jun 14 13:02:42 2010 from 192.168.1.116

# vi /etc/ietd.conf

          1. WARNING!!! - This configuration file generated by Openfiler. DO NOT MANUALLY EDIT. #####

Target iqn.2006-01.com.openfiler:tsn.68885b5f004f

HeaderDigest None

DataDigest None

MaxConnections 1

InitialR2T Yes

ImmediateData No

MaxRecvDataSegmentLength 131072

MaxXmitDataSegmentLength 131072

MaxBurstLength 262144

FirstBurstLength 262144

DefaultTime2Wait 2

DefaultTime2Retain 20

MaxOutstandingR2T 8

DataPDUInOrder Yes

DataSequenceInOrder Yes

ErrorRecoveryLevel 0

Lun 0 Path=/dev/vg/volume,Type=fileio,ScsiSN=ViPSp1-rrPl-eRQW,ScsiId=ViPSp1-rrPl-eRQW,IOMode=wt

0 Kudos
Enthusiast
Enthusiast

1.Make sure proper communication between the OpenFiler and ESX host.

I have run ping and vmkping without issue. I have also verified the firewall setting on the vSphere host.

2.Make sure the iSCSI Target in the OpenFiler is Started.

I am able to connect to this from a Windows machine without issue, so the iSCSI target is definately started.

3.Make sure the Outgoing port in Software iSCSI Client is configured.

I believe this is also confirmed by connection from my Windows 7 machine via iSCSI.

4.Complete all the nicessary configuration in OpenFiler to create and present the LUN.

Once again, since Windows sees it, I believe I must have done this correctly.

5.Add the IP Address of OpenFiler To the iSCSI Adapter in ESX host.

Done. I have tried by the dynamic and static tabs without success.

6.Rescan for new SAN Storage.

I have tried this numerous times, I just don't see the presented LUN.

7.If not, then try to check out the Dublicate LUN(0) in OpenFiler, and rescan your host after completeing the changes.

I've checked this out and I don't think this is applicable since I'm only presenting a single LUN. Can someone verify?

8.If not, then try StarWind iSCSI or another iSCSI Target and configure ESX for that target, check do u see your iSCSI LUNs!!

I think I'll be trying this step next!

1.This will determined the issue if it is from the iSCSI Target or the ESX Host.

2.If nither of these, install put a VM beside the iSCSI PortGroup, and configure this VM as an ISCSI Target and see you can present a LUN.

0 Kudos
Enthusiast
Enthusiast

3.Make sure the Outgoing port in Software iSCSI Client is configured.

I believe this is also confirmed by connection from my Windows 7 machine

via iSCSI.

This is not a valid statement. A virtual machine is not bound by the same firewall that protects the ESX host.

VMware VCP - Consider awarding points for "helpful" and/or "correct" answers.

Blog: http://www.virtualizetips.com Twitter = @bsuhr
0 Kudos
Virtuoso
Virtuoso

Can you run below command and paste the output here?

$vmkiscsi-tool -D -l vmhba33

$vmkiscsi-tool -I -l vmhba33






vcbMC-1.0.6 Beta

vcbMC-1.0.7 Lite

http://www.no-x.org

http://www.no-x.org
0 Kudos
Immortal
Immortal

If this is an ESXi host there will be no firewall ports to consider since ESXi does not have a firewall.

-- David -- VMware Communities Moderator
0 Kudos
Enthusiast
Enthusiast

No this is vSphere and I believe that the iSCSI ports are opened as soon as you add the iSCSI host bus adapter. In any case the firewall appears to be correctly set up.

0 Kudos
Enthusiast
Enthusiast

"Can you run below command and paste the output here?

$vmkiscsi-tool -D -l vmhba33

$vmkiscsi-tool -I -l vmhba33"

I've run these commands by logging in through putty and using the root username. I get the following output:

login as: operator

operator@192.168.1.142's password:

Last login: Mon Jun 14 14:47:46 2010 from 192.168.1.116

Could not chdir to home directory /root: Permission denied

-bash: /root/.bash_profile: Permission denied

-bash-3.2$ su root

Password:

# $vmkiscsi-tool -D -l vmhba33

bash: -tool: command not found

# $vmkiscsi-tool -I -l vmhba33

bash: -tool: command not found

#

I'm pretty certain I'm just doing something wrong. I'm very new to this, I'm a windows guy. I have granted shell access to the operator account and added it to the adm group. I log in with that account and then su root. I get the output above when I run those commands but I think I'm just missing a step....

0 Kudos
Contributor
Contributor

You probably don't have the ACL set correctly on OpenFiler. Easiest way is to input your ESX server's IP address into the ACL with a 255.255.255.255 subnet. Make sure that it is checked in the target configuration and make sure that's the only box checked in the network ACL section.

0 Kudos
Virtuoso
Virtuoso

$ su -

Then run the command again






vcbMC-1.0.6 Beta

vcbMC-1.0.7 Lite

http://www.no-x.org

http://www.no-x.org
0 Kudos
Immortal
Immortal

vSphere doesn't indicate ESX or ESXi as both are part of vSphere.

-- David -- VMware Communities Moderator
0 Kudos
Enthusiast
Enthusiast

"You probably don't have the ACL set correctly on OpenFiler. Easiest way is to input your ESX server's IP address into the ACL with a 255.255.255.255 subnet. Make sure that it is checked in the target configuration and make sure that's the only box checked in the network ACL section."

Previously I had the following setting on the ACL:

Name Network/Host Netmask Access

Local 192.168.1.0 255.255.255.0 Allow

I have changed it to:

Name Network/Host Netmask Access

Local 192.168.1.0 255.255.255.0 Allow

ESX 192.168.1.142 255.255.255.255 Allow

No change. Windows is able to connect so I don't see how this can be an ACL issue, with my previous settings everything on my network should be able to connect... shouldn't they?

0 Kudos
Enthusiast
Enthusiast

"vSphere doesn't indicate ESX or ESXi as both are part of vSphere. "

Sorry, I should have clarified. This is ESX, not ESXi.

0 Kudos
Contributor
Contributor

Sorry, I missed that part. Only issues I've ever had were network ACLs and static targets left over from old configs. Could you post a pic of your vswitch configuration on the ESX server?

0 Kudos
Contributor
Contributor

edi the /etc/initiators or and I open up the "/etc/initiators.deny file and # out the deny line.

G

0 Kudos
Enthusiast
Enthusiast

Thanks everyone for all the help. This appears to have been some kind of network issue. I began to suspect a networking problem when I noticed that when I connected to the iSCSI storage from my Windows box some text came up on the Openfiler console. I believe my mistake what that when I was using ping I was pinging the service console, not the VMkernel used for iSCSI. So even though I was getting ping replies I was not detecting the underlying network issue, possibly an IP conflict.

I corrected this by putting everything on a single vSwitch using the same physical nic. I know it's not recommended by I did it for troubleshooting purposes only. Afterwards I added a second service console and a VMKernel, configured using known good IPs, and viola, my storage was visible.

Thanks to everyone for all the input!

0 Kudos