Jazsko
Contributor
Contributor

Synology NAS with iSCSI

Hi,

I have a huge issue with Synology rack NAS. First to describe my infrastructure.

We have three ESXi servers running 4.1, they are all in a cluster, with a essentials plus license. When it was first set up, everything worked like a charm, synology was fast, and things went great. Last night our network became ultra-slow, we found later a loop on one of the unmanaged switches. For some reason this caused our VMware infrastructure to collapse...

On all the ESXi servers the synology lun went in inactive mode. I successfully removed it from one server, logged in on that server via vSphere client, and added it again. That worked. I tried to do the same thing on the other to, but without success. After a lot of goggling, i decided to restart the ESXi hosts. When they came back up, the storage that was once named Syno-1, suddenly changed its name to snapxxxxxxxx-Syno-1. Same name on both ESXi servers. Tried disabling iscsi on both, enabling, restarting nothing helped, they came up with the same name...

This has happened once before, but at that time, the name of the iscsi store didn’t change, but just became inactive. We managed to get it back online after a while. But not without restarting both Synology and esxi hosts.

Anyone has any idea what is going on, and why this is happening?

0 Kudos
0 Replies