actyler1001
Enthusiast
Enthusiast

Storage vMotion fails between NFS 4.1 and iSCSI

As the title suggests I am having trouble with Storage vMotion.  I've used iSCSI for years and it works great.  I recently discovered that on my particular storage device, NFS runs better.  So I am looking into giving it a shot.  Setup my first NFS 4.1 share and got it connected.  I'm able to create new VMs on this datastore and the new fancy multi-pathing appears to be working.  The rub comes in when I try to move VMs between my iSCSI datastores and my new NFS 4.1 datastores.

 

This is a 3 node vSphere 7 cluster.  Each host runs build "ESXi, 7.0.2, 17867351".  I am able to storage vMotion newly created VMs on my NFS 4.1 share to an iSCSI datastore, but not in the reverse direction.  Once the VM is off of the NFS datastore, it cannot get moved back, I simply an presented with the following error...

 

Task name: Relocate virtual machine
Status: The virtual disk is either corrupted or not a supported format.

 

What gives?  All VMs are using thin provisioned VMDKs, is there some gotcha with NFS 4.1 that I am not aware of?  What would stop me from using storage vMotion to move VMs to this datastore?  Doesn't work whether the VM is powered on or off.  I can storage vMotion between iSCSI datastores all day long.

Regards,

Adam Tyler

 

###Update.  I found if I mount these same datastores using NFS3, Storage vMotion works just fine.  This is only a problem when using NFS 4.1 for some reason.  Anyone have more info?

Labels (5)
0 Kudos
7 Replies
actyler1001
Enthusiast
Enthusiast

Thanks for all the input community!  Lol.  This is a Synology storage device, DS1817.  I see in the latest DMS 7 release notes for my device they actually remove support for NFS 4.1.  Weird.  Anyway, I gave up and am back to LAG (LACP) with NFS 3, works fine I just don't get multi-pathing.  Ah well, my little home lab can't saturate a single 10Gb NIC anyhow.

Regards,

Adam Tyler

0 Kudos
ShoHRock
Enthusiast
Enthusiast

do you have any other NFS 3 datastore on same host?

I had the same issue. ESXi 7 can support either ALL NSF3 or ALL NFS4, it cant have both.

0 Kudos
actyler1001
Enthusiast
Enthusiast

Nope, I only had NFS 4.1 in use in the VMware cluster at the time I experienced this issue.  The more I investigate the more I am thinking this is a poorly written/implemented NFS 4.1 mechanism by Synology.

Regards,

Adam Tyler

0 Kudos
depping
Leadership
Leadership

Never seen this, and I have actually migrated VMs between all storage types (iSCSI/FC/vSAN/NFS etc). Very strange...

0 Kudos
actyler1001
Enthusiast
Enthusiast

Agreed.  Doesn't make any sense.  I'm curious if I would run into this problem on an older build of ESXi.  6.5 or 6.7.  Not that I am going to roll the entire environment back just to test.  Back to LAG and NFS 3 for now.  rock solid.

Regards,

Adam Tyler

0 Kudos
alantz
Enthusiast
Enthusiast

Any firewalls ? NFS 3 vs 4.1 is stateless vs stateful. If not its got to be some technical difference like this getting in your way.

--Alan--

 

0 Kudos
actyler1001
Enthusiast
Enthusiast

No firewalls, interfaces responsible for handling NFS traffic are on same broadcast domain as NFS target.  I really do think this is a limitation of the older Synology NAS I am using.  Synology actually released a firmware update of this model (DS1817) and dropped NFS 4.1 support completely.

I opened a support case back in July and asked them about it...  Here are some related comments...

 

Initial question:

[Symptoms]
I was reading through the release notes for DSM7 and noticed that NFS 4.1 support was removed from Apline architecture units.  Can you give me any information as to why this change was made?

[Error Messages and Screenshots]

NFSv4.1 and related advanced functions (multipathing) are no longer supported on Synology NAS models with the following package architectures: Alpine, Alpine4k, armada38x, Avoton, Braswell, Bromolow, Cedarview, Grantley, Monaco. If you had previously enabled NFSv4 and NFSv4.1, the maximum NFS protocol is set to NFSv4 by default after the update. For more information about the package architecture of your model, please refer to this article.

 

 

Snyology Support Response:

"It appears to be that nfs 4.1 was removed on some models with kernel 3.10 as it can cause instability. So they have removed this in DSM 7 to avoid the instability that may come with it.

So, you'd have to use just NFS 4 or if you want 4.1, you'd need to use a different device at this time. There's no ETA or information on if or when that'd be changed/resolved."

0 Kudos